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Getting Started 
Welcome to FloorRight™ 

Welcome to FloorRight™ by Saltire Software. 

FloorRight™ is a full-featured program for estimating floor covering bids.  Its 
features include: 

• A layout facility for defining the shapes of rooms, the floor coverings to be 
used in those rooms, and the preferred lay direction and pattern orientation 
for the floor coverings. 

• An automatic stock layout facility for optimally defining cuts and seams, 
reducing the amount of waste and labor. 

• A job quote facility for computing and printing job costs. 

To get started using FloorRight™, consult the Quick Start Guide, try out the 
multi-media tutorial (see Running the Tutorial, p. 7, for help), or see Steps for 
Creating a Quote, p. 12. 

If you are an experienced FloorRight™ user, you may wish to review New 
Features for this release. 

For more information, see:  

Related Documentation, p. 13. 

Accessing the FloorRight™ Website, p. 219. 

Contacting Saltire Software, p. 219.  

Running the Tutorial 
A multi-media tutorial has been included on the distribution CD. It includes 
interactive lessons on most FloorRight  features. 

The tutorial is installed along with FloorRight .  You can run the tutorial from the 
FloorRight  Start menu.   

Alternatively, you can run the tutorial from your CD.  Simply follow these steps: 

• Insert the FloorRight™ Distribution CD into your CD player. 

• Select the Start menu in the lower left corner of your screen. 

• Select the Run… menu option. 

• Type d:\FloorRightTutorial into the Run dialog box. If your CD device is set up 
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as some other letter, use that letter instead of d: 

Error Opening Tutorial 
You can only run the tutorial from the Help File if it has been installed on your 
hard drive. 

Copy the file FloorRightTutorial.exe from the CD to the directory in which you 
have installed FloorRight, and you will be able to access it from the Help facility. 

Using the Help Facility 
There are many ways to get help with FloorRight.   

In the FloorRight Help system you can: 

•  Use the table of contents to help answer broad questions, such as “How 
Do I Create Stairs?” 

•  Use the index for help on a particular topic, such as “Doors”. 

•  Use the search tool to find all topics based on a key word, such as 
“pattern”. 

• Use context-sensitive help.  Pressing F1 will provide help on the dialog box 
you are currently using. 

• Browse through help with the left and right buttons . This 
will step you through the help sub-topics in a logical sequence. 

• You can click on green text to get more information. 

Clicking on Green Text 
Green text always indicates a link to another topic in the help file. 

You can back up to the previous topic by clicking on the Back button. 

Understanding the Display 
If you see nothing but a blank screen, you may wish to go ahead and create a 
room.  It will help you to understand the screen.  You can always delete it later.  
Drawing Rectangular Rooms (p. 21) will guide you through this process. 

The FloorRight™ display window is sometimes divided into two parts, and 
sometimes divided into three parts. 

The top-most part of the display contains a variety of configurable menus and 
buttons.   

 8



  

See Toolbar Help, p. 113, for an overview of all of these controls. 

The main part of the screen contains an area for drawing diagrams of rooms.   
This is called the "Room View." 

  

You can create rooms of any desired size and shape. Rooms are color-coded to 
indicate which type of floor covering is used in each room.   

The drawing can be split into two by clicking on the Seam / Stock toggle button 
. Clicking the toggle button again removes the split.  When the screen is split, 

the top part is called the "Seam View," as seams are displayed in the rooms.   
The bottom part shows the stock and how it is cut to accommodate all of the 
rooms.  This is called the "Stock View." 
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Notice these differences between the room view and the seam view when the 
stock view is activated: 

1. Rooms that do not need to be laid out (laminate, ceramic tile, and wood 
flooring are examples) are omitted from the seam view. 

2. Locations of seams are displayed in the seam view. 

3. The stock that applies to the currently selected room is displayed, though you 
can zoom out to see the other types of stock.  For more information, see 
Zooming, p. 98. 

4. When you select a room in the seam view, its pieces change to the 
highlighted color in the stock view.  Likewise, when you select a piece of 
stock in the stock view, the piece is highlighted in the seam view. 

5. In the Commercial version, you can see individual rolls of material and the 
exact amount used from the stock view if you enable the Roll Allocation 
feature from the Layout menu. 

The bottom and right side of the view windows contain the scroll bars to 
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manipulate the placement of your drawing. 

Highlighting 
When you select a room, window, door, wall, menu option, or anything else, it will 
normally change colors to indicate which object you have selected.  This is 
referred to as the "highlighted color." 

You can find out what the highlighted color is by clicking on a menu item, or even 
on a topic or book from the table of contents or index.  The color the object turns 
to when you click it is the highlighted color. 

The highlighted color is controlled by Windows and can easily be changed, so it 
is not necessarily going to stay the same.  You can change the highlighted color 
with these steps.  As you do so, recall the colors you commonly use for materials 
-- you will want the highlighted color to contrast with these colors. 

1. Double-click the My Computer icon on the desktop. 

  

2. Double-click the Control Panel folder. 

  

3. Double-click the Display icon.  Display icons vary by manufacturer, but yours 
should look something like this. 

  

4. Select the tab labeled "appearance", and choose Selected Item from the 
Item menu. 

5. Use the Color menu to choose the color you like. 

Company Information 
When you installed FloorRight  you were asked to enter your company 
information.  This information can be modified by selecting the Defaults menu, 
and then selecting Company Info. This allows you to specify or change your 
company's name, address and phone number. 
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This information will be displayed on your printouts. 

Steps for Creating a Quote 
Follow these basic steps for creating an estimate for your customer. 

1. Draw the rooms, stairs, and hallways to the customer’s specifications.  See: 

Drawing Rectangular Rooms, p. 21  Joining Rooms, p. 130 

Drawing Non-rectangular Rooms, p. 22  Splitting Rooms, p. 130 

Drawing Circular Rooms, p. 25  Creating Stairs, p. 34  

Creating Room Borders, p. 30   Doors, p. 37 

Drawing Holes in Rooms, p. 32  Windows, p. 36  

Aligning Rooms, p. 38  Expanding Rooms, p. 167  

Positioning Rooms, p. 178  Rotate Rooms, p. 182  

2. Create materials matching the customers’ needs, and assign them to the 
rooms.  See: 

Adding a Material to the Estimate, p. 16  

Defining the Material for a Room, p. 17  

3. Create and inspect the layout.  See: 

Viewing the Stock Window, p. 69  

Experimenting With the Layout, p. 77  

4. Enter material and labor costs.  See: 

Entering Prices, p. 85  

5. Print the finished layouts and itemized quotes.  See: 
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Job Estimate Dialog Box, p. 87  

Related Documentation 
For more information on FloorRight , please see: 

The FloorRight  Quick Start Guide 

Provides information on installation and licensing, as well as an overview of the 
product.  Appendices include information on Frequently Asked Questions.  This 
document is located in the Doc subdirectory of your installation. 

The FloorRight™ Tutorial 

Provides in-depth interactive instruction on FloorRight  and its capabilities.  You 
can access the tutorial by simply following these steps:   

1. Insert the FloorRight™ Distribution CD into your CD player. 

2. Select the Start menu in the lower left corner of your screen. 

3. Select the Run… menu option. 

4. Type d:\FloorRightTutorial into the Run dialog box. If your CD device is set up 
as some other letter, use that letter instead of d: 

The FloorRight™ Report Designer Tutorial (Commercial Version) 

Takes you through the basic steps for creating customized reports from your 
FloorRight data.  You can find this .pdf file in your FloorRight installation in a 
folder of the same name. 

The Report Designer manual (Commercial Version) 
This is the complete detailed manual for designing reports from FloorRight™ 
Commercial.  You can find it with a choice of formats, .pdf and .doc, in the Doc 
subdirectory of your installation. 

The FloorRight™ Disto Pro Guide 

Details how to use the Disto Pro4 with FloorRight™.  The document describes 
how to use the Disto Pro4 to take room measurements so FloorRight can 
recognize them and the procedure for transferring measurements into FloorRight 
via a serial cable.  This document is located in the Doc subdirectory of your 
installation. 

The FloorRight™ Website 

Information on upgrades, distributors, and additional technical support is 
available through the FloorRight™ website at www.FloorRight.com. 
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Licensing This Program... 
FloorRight has a 60-minute trial to give you a hands-on look at its powerful 
features. To purchase an unlimited usage license for a single computer, you 
must contact your FloorRight distributor. The distributor will provide you with a 
WIBU key that allows you to run FloorRight.  

The License Info selection (p. 136) under the Help menu gives you details of 
your license. 
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Working with Materials 
Material Types 

A material type holds all the information you need to know about a material as 
you are planning its installation. 

Many materials have the same type.  For example, you most likely sell more than 
one color of a particular sort of carpet.  As you lay out the carpet, you don’t have 
to think about which particular carpet will be ordered.  You just need to know 
what that carpet is like.  

Specifically: 

• Is the material sold by the square yard, square foot, or square meter? 

• Does the material need to be cut and laid out, like carpeting, or does it need 
to be set, like ceramic tile? 

• How much waste do I need to factor in? 

• How wide is the stock when it is still on the roll? 

• Are T-Seams allowed on this type of material? 

• Does the material require a pad? 

• Do I charge for labor for this material? 

• Are there any other items or expenses associated with this material? 

• Is the material patterned?  What are the dimensions of the pattern? 

• Should the material be hidden from the job estimate? 

When using FloorRight™, first define a material type and then create a material 
that has that type.  

Many common material types have been supplied with the software.  You may 
wish to use an existing type instead of creating a new one. 

Factory Defaults 
A large selection of material types are available for you to use and customize 
using the Edit Material Types dialog box.  From this dialog you can add, modify 
and delete materials from the default list provided by FloorRight .   

If, in your next FloorRight  file, you want the original default Material Types, 
choose Set Factory Defaults from the File menu.  This will replace your edited 
Material Types list with the original default Materials and their attributes that 
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came with FloorRight .   

Types of Flooring Material 
The Material Types dialog box includes many kinds of pre-defined flooring 
material types.  The names of these types indicate the kind of flooring material 
they represent. 

• Berber – Berber is a particular type of carpet that comes in several standard 
pattern repeats.  FloorRight™ allows you to quickly choose a defined Berber 
pattern instead of going through the process of defining it. 

• CPT – CPT is just an abbreviation for Carpet. 

• Carpet – Carpet is a fiber-based material that is sold in large rolls.  It requires 
layout as well as padding. 

• Ceramic – Ceramic refers to ceramic tile flooring.  Ceramic tile does not 
require layout or padding. 

• Laminate – Laminate flooring is a layered material that is typically sold by the 
square foot.  It is a tongue-and-groove interlocking material that is installed on 
top of the existing substrate.  Most laminate flooring is made in long planks, 
though some styles and patterns are made in square tiles.  Laminate requires 
a pad for installation. 

• VCT – VCT stands for vinyl composition tile.  VCT is a commercial-grade tile, 
usually sold by the square foot.  VCT does not require layout, and does not 
need padding. 

• Vinyl – Vinyl flooring consists of a synthetic material with a felt backing and a 
wear layer on top.  It is typically patterned, and requires layout.  No pad is 
required for installation. 

• Wood – Wood flooring is sold by the square foot, and does not require layout. 

• Other Types of Flooring – If you do not find a material type that matches your 
flooring, you can create your own by using the Edit Material Types dialog 
box. 

Material List 
Selecting Material List from the Edit menu will bring up the New Material - 
Detailed dialog box.  This dialog box displays details for all of the materials you 
have defined for this project.  

Adding a Material to the Estimate 
You need to define each material that you are going to use in your estimate. 
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First, think about what type of material you are using – whether it is carpet or tile, 
how wide it is, and that sort of information.  All of these considerations are put 
together in a material type. Material types are general and apply to many 
different materials.   

Next, assign a color to the material, match it to its type, and give it an identifying 
name.  Use either the New Material - Detailed dialog box or the Add New 
Material dialog box to do this. 

Use the Add New Material dialog box if - 

• You want to add new materials that have or do not have a pattern. 

• The material type already defines the material’s pattern.  For example, if you 
have a carpet with a pattern length of 1’ 6", a pattern width of 1’ 6", and a half-
drop, you could use the pre-defined pattern type "CPT12’ 1’6X1’6HalfDrop" 

• You don’t want to enter a name for the material or price information until later. 

• You want to create a "rough draft" of the material, and refine it later with the 
New Material - Detailed dialog box. 

Use the New Material - Detailed dialog box if 

• You want to add or edit pattern information for the material. 

• You want to enter a name or a description for the material. 

• You want to enter a price for the material. 

• You want to change the sales tax for the material 

• You want to change the job estimate items for the material. 

Defining the Material for a Room 
You can tell which material is being used in a room by its color.  The Count 
Rooms command from the Job menu can give you a quick run-down of the 
materials you have defined for your estimate, and what their color-codes are. 

Before drawing a room, check in the upper-left of the display to see that the 
correct color and style is shown. 
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If the wrong material is displayed, click the pull-down button 

 to see the rest of the materials you have defined, and pick 
the right one. 

If you do not see the material you need, add a new material using the Add New 
Material dialog box or the New Material - Detailed dialog box  

Now you are ready to draw your rooms. 

If a room has been created and it is the wrong material, select the room and then 
choose the material as above. 

Color-Coding Materials 
Each material that you are using is color-coded so that you can quickly 
distinguish between rooms with different materials, just by looking at the display.  

Match colors to material types with the Add New Material dialog box. 

Here are some things to keep in mind: 

• The color code you use does not have to be related to the actual color of the 
material. 

• It is better to use colors that contrast with each other so you can easily tell 
them apart. 

• Avoid using colors that are similar to the highlighted color.  These colors 
make it difficult to tell whether a room is selected.  This may be unavoidable, 
since other users may change the highlighted color without warning you. 

Defining Tile  
You can create a Tile material in the Edit Material Type dialog box. Select the 
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Defaults menu and then choose Material Type. 

When defining a tiled material be sure to check Boxed, enter the Amount / box 
(square feet, square yards, or square meters), and enter the width and length of 
a tile in the Pattern width and Pattern length columns.  Use Pattern drop to 
optionally enter tile drop.  You can also edit an existing material type to make it 
tiled material with the above modifications. 

Now you can add new tile material to your material list using the Add New 
Material and Detailed New / Edit selections in the material drop down window. 

You can create a room of tiled material by selecting it before you draw the room, 
or you can use tiles to decorate an existing room with the Tile Editor. 

Tiles are arranged such that those around the edge of the room are at least half 
a tile wide. 

When changing the room size or lay direction, tiles are automatically rearranged 
for the modification. 

You cannot use Tile as a border material. 

Why Can't I Just Use the Same Material All the Time? 
In some instances, you can. 

You can totally ignore materials and material types as long as: 

• All of the rooms in the estimate are using the same carpet. 

• The carpet is sold by the square yard, is 12 feet in width, and does not have a 
pattern. 

You must use materials and material types if: 

• You are using a carpet with different dimensions than listed above. 

• You are using more than one kind of carpet. 

• You are using ceramic tile, vinyl, wood, or any other types of flooring material. 

Materials and material types allow FloorRight™ to figure out the best way to 
layout the materials, and how to calculate the amount of money to charge the 
customer. 
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Drawing Rooms 
Drawing Rectangular Rooms 

 Dimensions of rooms are based on the amount of floor covering required, not 
on the distances specified by the blueprint. Please add a few inches to 
accommodate the unevenness of walls or mistakes in cutting and measuring. 

The Rectangle drop down box allows you to switch between the rectangle room 
drawing tool and the rectangular hole-cutting tool.  To draw a rectangular room, 
make sure the Rectangle Room drawing button is displayed on the tool bar.  

 

Draw your room by clicking and dragging in the room view. 

1. Position the cursor to one corner of the room and click and hold the left 
mouse button. 

2. Without releasing the mouse button, move the mouse cursor to where you 
would like the opposite corner to be.  Notice that the dimensions of the room 
are displayed, and that they change as you move your mouse. 

3. Release the mouse button when you have the right sized room. 

The Rectangle button continues to be in effect until you select one of the other 
drawing buttons. 

You can also draw rectangular rooms by typing directly into the W x L box and 
the Room Name box. 

 

1. Type the dimensions of the room in the W x L box, separated by an "x".  For 
example, you would type 20’ x 18’ for a room with dimensions of 20 feet and 
18 feet.  See Entering Lengths, p. 29, for more information on how 
FloorRight™ interprets the lengths you specify. 

2. Type the name of the room in Room Name. 
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3. Click on the green checkmark button . 

4. If you wish to cancel this action, click on the red x button   

These steps can also be used to modify the name or dimensions of an existing 
room.  First, select the room you wish to modify.  Type your changes in the W x L 
box and the Room Name box.  Again, use the green check button to accept the 
changes, or the red x button to reject them. 

Other changes can be made after selecting a room by using the right click mouse 
button. 

Drawing Non-rectangular Rooms 
 Dimensions of rooms are based on the amount of floor covering required, not 

on the distances specified by the blueprint. Please add a few inches to 
accommodate the unevenness of walls or mistakes in cutting or measuring. 

Most rooms are not simple rectangles, but in many cases using a rectangular 
approximation will suffice.  It makes more sense to use the simple room, on the 
right, than the complex room, on the left. 

  

On those occasions when using a rectangle would cause too much waste, 
FloorRight™ helps you do layout more efficiently.  Use the line and curve 
drawing tools to specify non-rectangular rooms. 

The Line Drawing drop down box allows you to switch between the room line 
drawing tool and the non-rectangular hole-cutting tool. 

  

These steps are the simplest way to draw a non-rectangular room: 

1. Click the Line Draw button  on the toolbar. 

2. Click the locations on the room view where you would like the corners of the 
room to be. 
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HINT: FloorRight  will make your lines horizontal or vertical if you hold down the 
SHIFT key as you drag the mouse. 

The Curves / Points drop down box  gives you two 
additional drawing tools to add more details to walls. 

The Insert point tool can help you join or split rooms and correctly align rooms 
without the need for a grid. 

  

It easy to add points to a wall for a more precise drawing: 

1. Select the Insert point tool from the toolbar . 

2. Move the cursor along the wall to the approximate place where you want the 
point inserted and click the mouse.  

3. Now click the Highlight button  and select the section of wall on either 
side of the point and enter the exact distance dimension in the Line length 
text box. 

If the room you edited is rectangular, it will be treated as a polygon. 
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To use the Curve a Side tool – 

• Click the Curve a Side button on the toolbar   

• Move the cursor to the middle of the wall to be bowed. 

• Click and drag the wall to the desired shape. 

You can use this tool to draw completely circular rooms. 

Several toolbar buttons allow you to tune and refine your drawing. 

  

The Line length text box  allows you to enter the length of a 
wall. See Entering Lengths, p. 29, for more information on how FloorRight™ 
interprets the lengths you specify. 

If you press the Enter key when you finish typing the line length, you will see a 
message box instructing you to enter a direction for the line. 

The Direction text box  allows you to enter a Wall Direction.  Press 
the Enter key when you finish typing the wall direction. 

The Projection edit box  can be used to adjust the bow of a wall.   

• Click the Highlight button  and select the wall - straight or curved. 

• Enter a value in the projection edit box.  This would be the perpendicular 
distance from the middle of the bow to its chord.  A straight wall has a value 
of 0º.  A negative value bows the wall to the right and a positive value bows 
the wall to the left, depending on the wall direction. 
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The Close Room button  draws the last wall for you. 

The Cancel Line Draw button  deletes the walls you have drawn so far and 
lets you start your room drawing effort over. 

The Delete Side button  deletes the last wall you drew, backing you up one 
step. 

 

For more information, see these topics: 

Drawing Rectangular Rooms, p. 21  

Drawing a Circular Room, p. 25  

Selecting a Line, p. 26  

Selecting a Point, p. 27  

Strategies for Complicated Rooms, p. 41  

Drawing a Circular Room 
To draw a circular room you simply need to know its diameter.  

1. Using the Polygon tool  draw a straight line of the appropriate diameter. 

2. Change to the Curve a Side tool  and drag the line as far as it will go. 
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3. Close the room.  

4. The curve tool is still active , so drag the new straight line in the opposite 
direction as far as it will go. 

Note: Circular rooms, i.e. rooms with only 2 end points, cannot be joined to 
another room. 

Selecting a Line 
To select and modify a line - a wall of a rectangular or non-rectangular room - 
follow these steps: 

1. Click the Highlight button  on the toolbar. 

2. Move the mouse cursor to the line you wish to select. 

3. Click the mouse button and release. 

When you succeed, the wall will be drawn as a thick arrow. 

  

The arrowhead helps to distinguish the direction of the room.  A wall with 
direction East would have an arrowhead on the opposite end as one with 
direction West. 

After selecting the line, a right click of the mouse button displays a drop down 
menu of these choices: 

• Wall Properties – brings up the dialog for editing 

• Reverse Line Direction 

• Lay Room to Side  
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Once you have selected a line, you can: 

• Drag the line to a new location. 

• Delete it with the delete key or by clicking the Delete Side button  on the 
toolbar. 

• Change its length by editing the Line length text box.   Note 
that when changing the length of a line, the arrowhead moves and the end of 
the arrow remains stationary.   

• Change its direction by editing the Direction text box  

• Change the bow of the wall by editing the Projection edit box.  

You may have difficulty selecting a line if it is right next to another room.  If this is 
the case, try using Bring To Front from the Edit menu. 

Selecting a Point 
To select a point -- a corner of a room -- follow these steps: 

1. Click the Highlight button  on the toolbar. 

2. Click on the point you wish to select. 

If you are not close enough to the point, you may end up selecting the room or a 
line.  Move the mouse cursor a little closer to the point, and try again. 

You may have difficulty selecting a point if it is right next to another room.  If this 
is the case, try using Bring To Front from the Edit menu. 

Wall Direction 
When a wall of a room is selected, the direction of the wall is displayed on the 
toolbar. 
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If the direction is shown as a number, it is the angle measured clockwise, starting 
from north (straight up).  A wall with a 60° angle would be oriented like this: 

  

When the angle matches a compass direction, the compass direction is shown. 

N North 0° 

NE North East 45° 

E East 90° 

SE South East 135° 

S South 180° 

SW South West 225° 

W West 270° 
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NW North West 315° 

You can change the direction by entering the angle in degrees, or selecting one 
of the cardinal directions from the dropdown menu.   

   

Note: The direction of a wall cannot be changed so radically that it causes walls 
to cross or overlap.  If you try this you will get an Invalid room error box. 

  

These direction units are also used to rotate a room. 

Reversing a line direction will automatically change the direction of all the walls in 
the room.   

Entering Lengths 
Use these guidelines when entering line lengths and room dimensions. 
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• When entering a length in feet, use the single quote key (’), for example:  8’ 

• When entering a length in inches, use the double quote key ("), for example:  
48" 

 Typing the single quote twice for inches will not work! 

 

• When using both feet and inches, feet must come first.  Example:  6’ 10" 

• Fractions of feet are automatically converted to inches.  For example, 6.5’ 
becomes 6’ 6" 

• When entering a length in meters, follow the number with an m. Example:  
7m or 7 m 

• When entering a length in centimeters, follow the number with cm.  Example:  
823cm or 823 cm 

• Meters and centimeters cannot be mixed, as feet and inches can.  Instead, 
use decimals.  6m 45cm becomes 6.45m 

• No other units are accepted for line lengths and room dimensions. 

• If you do not indicate units, FloorRight™ uses whatever you have selected in 
the Edit Options dialog box.  If you have chosen "feet and inches", your 
length will be assumed to be in feet.  If you have chosen "meters," your length 
will be assumed to be in meters. 

Creating Room Borders  
There may be cases where you need to place a border of a different material 
around the edge of a room.  FloorRight  can take care of this for you along with 
the other individual Room Properties. 

1. Select the room. 

2. From the right click mouse button menu select Room Properties and click 
the Borders tab, or select Room Properties from the main Edit menu to 
bring up the Borders tab in the dialog. 
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A room may have multiple borders.  The first border, row (1) in the list, is the 
outer-most border, working inwards with each successive number.  For each 
border enter the following information: 

• Width – Specify the border width in current units. 

• Material – Select one from your list using the down arrow.  (Tiled material is 
excluded from the list.) 

• Miter – Check this box if you want mitered seams at the corners of your room.  
If you leave this box empty the border will be laid as a single piece.    

• Layout – Select from the drop down menu of choices.  The available 
selections depend on whether or not you selected mitered corners.   

    

In FloorRight Commercial there is one additional column: 

• Dye lot – If you have assigned dye lots with the material, you will have a drop 
down menu of choices.  If not, "Default" is displayed.  
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To delete a border, click the row number (the row will be darkened) then click the 
Delete button at the bottom of the dialog box. 

To move a border to a different position, select the row and drag it (holding the 
mouse button down) to the correct place in the list. 

The OK button accepts your changes and closes the dialog box. 

The Cancel button ignores your changes (restores the Room Properties to the 
settings as they were before you opened the dialog) and closes the dialog box. 

The Help button activates the help system and displays help for this dialog. 

Borders are automatically updated if you change the size or shape of a room. 

Creating Holes in Rooms 
If you have a room surrounding a courtyard or a large appliance or fireplace in 
the center of a carpeted room, then you need to make Holes in your room.   

After drawing your room, change the rectangular or polygonal room drawing tool 
to the rectangular or polygonal hole cutting tool using the drop down arrows to 
the right of the corresponding buttons.  When you select Rectangle Hole the 
toolbar button changes to show a room with a hole in it. 

 

Draw the hole inside the room using the scissors cursor in the same way you 
drew the room, by clicking and dragging. 

1. Depress the left mouse button. 

2. Without releasing the mouse button, move the cursor to where you would like 
the opposite corner to be.  Notice that the dimensions of the hole are 
displayed, and that they change as you move your mouse. 

3. Release the mouse button when you have the right sized hole. 

The Rectangle Hole button continues to be in effect until you select one of the 
other drawing buttons. 

For complicated holes (non-rectangular) you can select the line drawing room 
tool and change it to the line drawing hole tool, displaying a scissors with the 
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cursor.  Then use the same techniques to draw the hole as for the non-
rectangular room; just click the locations in the room where you would like the 
corners of the hole to be or use the several toolbar buttons that allow you to draw 
your hole. 

 

Refer to the section on drawing non-rectangular rooms, as the hole drawing 
works just the same. 

There are a few rules for drawing holes in rooms: 

• When first creating a hole, all points defining the hole must lie within the same 
room.  After drawing the hole you can do some rearranging as indicated 
below.   

• You can drag an existing hole as long as one point of the hole remains within 
the room where the hole was first placed.  Drag the entire hole by clicking 
inside the hole.  A heavy line will outline the hole to show that the hole is 
selected.   

 

• You can also move corners or points of a hole individually, as long as one 
point of the hole remains within the room. 
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•   The hole only affects the room in which it was created as you see in the 
seam view below. 

  

• A room may contain multiple holes.  Overlapping holes are combined during 
layout, but they remain separate in the room view to allow individual editing. 

To Delete a hole simply click inside the hole with the selection arrow cursor (a 
heavy line will outline the hole to indicate that it is selected), then press the 
Delete key or select Delete from the Edit menu. 

Creating Stairs 
Stairs are a little more complicated to describe than other rooms, since you can’t 
simply draw them on the screen.  You have to describe the rise, run (or tread), 
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and width of each step and the number of steps. 

  

To create a new set of stairs, select the Edit menu option and choose Stairs… 
or simply click on the Add Stairs button.    

This will bring up the Add Stairs dialog box. 

  

Type the rise and run of the steps, as well as the width of each step and the 
number of steps. 

Stair Orientation and Pile Direction allow you to describe how the stairs are 
situated, and which way the pile runs.  Carpet pile typically runs down stairs, so 
you can indicate which way is down here. 

 If you are using feet and inches as units, and you do not indicate the units in 
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this dialog box, it assumes you mean feet.  For example, typing in 9 for the rise 
will be interpreted as nine feet instead of 9 inches!  Type in 9" instead.  See 
Entering Lengths, p. 29, for more information. 

Recalling that the shapes in the room view represent carpeting rather than the 
dimensions of rooms, it is easier to understand the appearance of the stairs on 
the screen.  Stairs are shown as if they have been flattened out, so that all of the 
carpeted surfaces are apparent. 

  

Clicking the Next button will create one set of stairs and update the dialog for the 
next stairs with the same rise and tread.   

Click the Done button to create stairs and dismiss the dialog box.   

Cancel will dismiss the dialog box without creating stairs. 

If you have a set of uneven stairs, you may wish to make a new set of stairs each 
time the rise changes.  Another way would be to use the biggest rise to prevent 
running short on carpeting. 

You can make changes to a selected stairs with this dialog.   

Editing Stairs 
To make changes to stairs, select the Highlight button  and double click on 
the stairs you wish to change. Make changes in the Edit Stairs dialog box and 
click OK.  

You can also access the dialog box by selecting Stairs… from the Edit menu. 

Windows 
Natural light from windows can make carpet seams easier to see.  Thus, 
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windows must be taken into consideration when FloorRight™ makes decisions 
about seam placement.  FloorRight’s algorithms seek to place seams farther 
away from windows if possible. 

To add a window: 

1. Click the Window button  on the toolbar. 

2. Move the mouse to the wall that will contain the window. 

3. Press down on the mouse button where the window begins. 

4. Drag the cursor to the point where the window ends, and release. 

HINT: To avoid placing your window in the wrong room when rooms are 
adjacent, use the Bring to Front function in the Edit menu. 

If you make a mistake, simply delete the window and try again.  To delete a 
window: 

1. Click the Highlight button , allowing you to select objects in the room 
view. 

2. Select the window.  It will change from black to the highlighted color  

3. Press the delete key on your keyboard. 

Doors or Transitions 
FloorRight™ uses the location of doors when producing an automatic layout.  It 
tries to place seams far from doors, since they are high-traffic areas.   

The Door tool also allows you to lay transition materials between rooms. You can 
specify materials such as thresholds or reducer strips in the Transition 
Materials dialog and assign these materials to specific doorways in the 
Transition Properties dialog. 

To draw a door or transition:  

1. Click on the Add Door button   

2. Position the mouse cursor to the spot on the wall you would like the door or 
threshold to begin.  Press down on the left mouse button. 

3. Without releasing the mouse button, drag the mouse cursor to the other edge 
of the doorframe or threshold.  Keep an eye on the lower left corner of the 
screen to see the width of the transition. 

4. Release the mouse button when you are satisfied with the transition.  
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This brings up the Transition Properties dialog.  

5. In this dialog you can edit the transition length, select a transition material if 
applicable, or display the door symbol on the drawing. 

 

HINT: To avoid placing your door in the wrong room, when rooms are adjacent 
use the Bring to Front function in the Edit menu or drag the rooms apart 
slightly. 

All the standard editing features are available for transitions.  You can move and 
resize them, or change their properties.   

1. Click the Highlight button  on the toolbar. 

2. Click the transition.  The selected transition is highlighted with points on each 
end. 

Once you have selected a transition, you can perform various operations on it. 

• To resize the transition, grab one of the points and drag it or type in the 
correct dimension in the Transition Length window in the Transition 
Properties dialog. 

• To move the transition, grab the bar between the end points and drag it along 
the wall.   

• To change the transition’s properties, double click anywhere on the transition 
or select Edit / Transition Properties to bring up the dialog box. 

• To delete a door or transition: 

1. Click on the Highlight button  on the toolbar. 

2. Click the transition you wish to delete. 

3. Press the delete key on your keyboard, or select the Edit menu and 
choose Delete. 

 Since the layout algorithm uses doors to determine where seams go, and 
since you can drag rooms around the screen without affecting the layout, each 
room needs its own copy of the door.  If two rooms are next to each other, draw a 
door for each room. 

Aligning Rooms 
Aligning rooms is important if you are using patterned material and depending on 
the Global Pattern Start.  It is also useful for presenting a familiar looking layout 
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for your customer. 

Note that the position of rooms does not impact non-patterned carpet. 

It can become quite tedious to align rooms by carefully dragging them around the 
room view.  Two tools are available to make this easier and faster. 

The first step in using both tools is to select the corners of the rooms you wish to 
align. 

1. Click on the corner of the first room. When the rooms are aligned, this room 
will remain stationary.  A small black circle on the corner of the room will 
indicate that you have been successful. 

  

2. Hold down the shift key, and click on the corner you wish to align.  When you 
get it (be patient!), the circle on the first room will turn white, and a small black 
circle will appear on the corner you have clicked. 
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If you want to position the two corners together, the easiest way is to click the 

Align Points button  from the toolbar or choose Align Points from the 
Drawing menu.  The second corner you selected is moved so that the two 
corners meet. 

  

If you need to place the corner of a room a certain distance from the corner of 
another room, use the Position Room dialog box. 

Using the Measuring Tool 
The measuring tool is great for taking measurements in your drawing between 
any points or walls. 
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Simply click and drag.  The cursor will snap to a nearby point or line.  As you 
drag the measuring cursor the line measurement expands like a measuring tape.  
When you release the cursor the line is erased. 

  

Strategies for Complicated Rooms 
Sometimes it can be difficult to get a room just right.  Keep in mind that you are 
estimating, so if the angle is just a bit off, you are probably all right.  Try to draw 
things a bit larger if you can’t get it quite right! 

Most rooms are basically rectangles, so try starting with a rectangle and making 
changes. 

Another approach is to break the room down into more basic shapes, and then 
trace over them. 

You can also use the joining rooms  and splitting rooms  features.  

Some rooms, particularly hallways, are defined by where other rooms aren’t.  
Draw surrounding rooms, and then create a polygon by clicking on the corners of 
the surrounding rooms.  Use this as a rough draft, and refine your drawing with 
the line drawing tools.  Remember that it is better to make the room a little larger 
so that you don’t run short. 

For more examples and step-by-step instructions, see Running the Tutorial (p. 
7).  The tutorial was included with your distribution CD. 

Complicated Room Example 
Imagine that your customer has handed you a sketch that looks something like 
this: 
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At first, this may look a little daunting, but after a bit of thought, you realize that 
there are only four features that keep this room from being a perfect rectangle: 

• There is an indentation on the east wall. 

• The north wall is longer than the south wall. 

• The southwest corner is clipped off. 

• There is a bay window on the west wall. 

Drawing these features one at a time is much easier than trying to deal with them 
all at once. 

  

The three vertical sections of the east wall add up to 20’, so start with a 20’ by 16’ 
rectangle 
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Problem A:  There is an indentation on the east wall. 

To solve this problem, delete the existing east wall, and draw the walls that make 
the indentation using the line drawing tool. 

1. Select the east wall, and click on the Delete Side button  on the toolbar. 

  

2. Click on the Line Draw button  on the toolbar.  Click and hold the mouse 
button.  You will see a line drawn from the northeast corner of the room to 
your mouse pointer.  Release the mouse button when the line is close to 
where you want it to be.  Draw the rest of the indentation in this way. 

  

Notice that we did not worry about the length of the bottom wall yet.  That’s a 
different problem! 

The easiest way to adjust the lengths of any lines is to select them and type in 
the line length.  When you select the line, you will see an arrowhead.  Always 
work in the direction of the arrowheads. 

Make adjustments to angles by selecting the line and typing the compass 
direction or an angle in degrees.  
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Problems B and C: The north wall is longer than the south wall, and the 
southwest corner is clipped off. 

These problems can be solved at the same time. 

1. Delete the south wall 

  

2. Use the line drawing tool to re-draw the wall, but stop somewhere in the 
middle of the wall so there is a bend point. 
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3. Select the bend point, and adjust the south wall to be straight west and 18’. 

  

4. Drag the southwest corner north until the diagonal segment is 2’10" long. 

  

Problem D:  There is a bay window on the west wall. 

Solve this problem with these steps: 
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1. Delete the west wall, and use the drawing tool to approximate the bay 
window. 

  

2. Select each line, and set its length to the correct value.  Also make sure the 
vertical segment is exactly north. 

  

As you get to the end of this example, you will very likely not be able to get it to 
come out exactly right.  This is not your fault -- it is because the customer did not 
give you complete information!  You need to know the angles as well as the 
lengths if you want it to be perfect.  Now is the time to remember that you are 
estimating, and that it does not need to be perfect -- just close. 

Accept Room and Reset Room 
When using the toolbar to make changes to rooms or to create rooms: 

• Use the Accept Room button  if you want to keep your changes. 

• Use the Reset Room button  to discard your changes before leaving the 
toolbar window.  To reset the room after the changes have been accepted, 
use Undo. 

The enter key on your keyboard is equivalent to the Accept Room button.  This 
is helpful if you are entering a number of rooms or walls, since your hands do not 
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need to leave the keyboard. 
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Importing Files and Data 
Importing Files 

FloorRight has several ways of creating drawings quickly from existing files 
created elsewhere. 

The drop down menu from the File / Import command allows you to select the 
type of file for import: 

  

• AutoCAD files (Only available in the Commercial Version) 

• Bitmap drawings  

• Scanner Input  

• Leica Disto Input  

You can create FloorRight files over any of these imported files.  The bitmap and 
AutoCAD files can be displayed over or under the FloorRight file so that you can 
easily set the scale of your FloorRight drawing to align with the imported file.   

Bitmap Import  
If you have a picture of your layout in bitmap form (e.g. a PNG file from a 
scanner) you can use it to help create your FloorRight project in the commercial 
version.   
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Using the Import / Bitmap option in the File menu you can bring in the following 
type of files: 

♦ ♦ 

♦ ♦ 

♦ ♦ 

♦ ♦ 

IMG PNG 

JPEG TGA 

PCX TIF (uncompressed or 
compressed) 

BMP GIF 

 

With the import of a bitmap, the Floor Plan Bitmap Properties dialog 
automatically opens. 

 

This dialog lets you arrange the display and set the scale of your bitmap with 
respect to your FloorRight drawing. 

The Display radio button group presents the following options: 

• Off – the bitmap is hidden. 

• Underlay – the bitmap appears behind any FloorRight objects. 

• Overlay – the bitmap appears in front of any FloorRight objects. 

The Scale box lists the current scale as a ratio of pixels to distance.  The 
distance units are feet or meters. To adjust the scale: 

1. Click on the side of a FloorRight room.  The side you select will be highlighted 
with an arrow and the side's length will be printed next to it.  

2. Click the Set Scale button to bring up the scaling dialog box, Set Side 
Length.  
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In this box the Current length shows the length of the selected room side as you 
last defined it in either feet or meters.   

In the New length box you can change the length to match the scale of the 
bitmap overlay / underlay.  Changing this length will only affect the specified 
lengths of your FloorRight objects; the room layout will look unchanged relative to 
the bitmap. 

The OK button closes the dialog and accepts the new length. All FloorRight 
objects are assigned new dimensions to match the selected length change and 
the view automatically zooms to cover the extent of the bitmap at its new scale.  
The scale ratio display, pixels to feet / meters, is updated. 

Cancel will close the dialog and revert the scale to the previous length. 

The Floor Plan Bitmap Properties dialog can be left open while working on the 
project.  Changes in the settings take place immediately. The OK button closes 
the dialog and saves the changes, while the Cancel button closes the dialog and 
reverts the settings to their previous value. 

The bitmap file's path and property settings are saved with the FloorRight file and 
reloaded whenever the FloorRight file is opened. 

Scanner Import  
If you have a hard copy of your floor plan you can scan it into FloorRight with 
any "TWAIN" device.  The scanned input is saved as a bitmap file   

• Place your paper copy in the scanner, and click File / Import / Scanner. 
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The next menu displays a list of all available TWAIN sources. 

  

When you make your selection you will advance to the scanning mode. The 
menu for adjusting the settings is controlled by your scanner's software.  All 
scanning controls, cropping, color depth, resolution, and other settings are 
enabled.  Note:  use the monochrome setting if possible; it uses less memory. 

After the image is scanned, it is transferred to FloorRight and the Set Image 
Orientation dialog box is displayed. 

 

This allows you to change the orientation of your bitmap on the FloorRight grid by 
90° increments.  The numbers indicate the clockwise rotation from ↑North. Here 
is an example: 
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Figure 1 orientation as sent from scanner 

 
Figure 2 - 90° rotation from original 
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Figure 3  180° rotation from original 

 
Figure 4 - 270° rotation from original 

You can experiment with rotations until you get the desired orientation.  Then 
click OK to insert the scan at the displayed orientation into FloorRight.  The 
Cancel button inserts the scan into FloorRight at the original orientation. 
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To start over (rescan), select File / New and repeat this process without saving 
the current bitmap.  

Once you have your scanned image in FloorRight, the Bitmap Properties dialog 
is displayed and you can create your FloorRight project. 

When the FloorRight file is saved, the scan is automatically saved as a bitmap 
file with the name "xxx_scan.png" where "xxx" is the FloorRight file name.  The 
bitmap file and associated properties are saved and automatically loaded 
whenever you open the FloorRight file. 

The Leica Disto 
Leica Disto Input 

You can automatically enter room measurements into your project with the Leica 
Disto laser range finder.  Take measurements, label the rooms and groups of 
rooms, then plug the Disto into your serial port and make your layout.  Once you 
have checked the rooms in the Disto Data window, you can transfer the 
measurements into FloorRight with the click of a button. 

Here's how the interface between the Leica Disto and FloorRight works.  See the 
section on "Using the Leica Disto" for help in gathering data.  The model of Disto 
you use will determine the steps for using these menu selections.   

• To start your Disto import, select File / Import / Disto.  

 

Here you have a choice of Direct, File or Interactive.   

The Disto Pro will save your measurements as you gather them.   • 

• 

• 

Use Direct to bring in the data from the Disto device.  With this option you 
can send your data directly into FloorRight or save the raw Disto data to a file 
(.csd extension) for examining later. This would be useful if the file contained 
errors.   
Use File if you have saved a .csd file and now want to create a FloorRight 
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project from the data. The standard Windows Open dialog lets you select the 
data file.  
Whether you created a .csd file or brought the data in directly, the information 
is displayed in the Disto Data dialog box.  Check the data for errors, making 
any necessary corrections, then click Commit Checked to convert your 
measurements into a FloorRight drawing.  From the FloorRight™ Room View 
you can rearrange the rooms as needed. 

• 

• 

• 

Once your data is safely loaded into FloorRight, don't forget to delete it from 
your Disto Pro otherwise the old data will be included with the next batch of 
data you collect. 

The Disto Plus does not save measurements as you collect them.  For this 
model, the Interactive option can collect your data in the Disto Import 
dialog, then import it to FloorRight via the Disto Data dialog.  (See your 
FloorRight™ dealer for interface options.) 

How Do I Use the Leica Disto Pro? 
This section describes how to take room measurements with the Disto Pro so 
that FloorRight can recognize them.  This info is also contained in the Using 
Disto Pro manual. 

Equipment Required 

• FloorRight  2002 or FloorRight Commercial  version 3.0 or later 

• Disto Pro4 

• Disto Pro4 serial cable 

General Measuring Advice 

It’s a good idea to familiarize yourself with the Disto first.  Please refer to the 
Disto manual for details.  It’s important to keep the following facts in mind: 

• The Disto has a minimum range of approximately one foot.  Distances less 
than that minimum cannot be measured directly.  You can work around this 
limitation with the subtract feature or measure using the ruler on the back of 
the Disto and enter the distances manually.  See the Disto manual for details. 

• The Disto can be configured to measure from the back or front of the Disto.  
Type Menu, then press 1, 1, 1 to measure from the front.  Type Menu, then 
press 1, 1, 3 to measure from the back.   

Measuring Procedure 
Measurements must be taken in order either clockwise or counterclockwise 
around the room.  Each measurement must be tagged with a site name, room 
name, and direction. 
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1. If the Disto is off, press the On/Dist key briefly. 

2. Pressing the Dist key briefly will start the measurement.  The Disto laser will 
turn on.  Press the Dist key again, and the measurement will be taken.  You 
will see the distance displayed on the screen. 

3. Next, press and hold the = button for about a second to start storing the 
measurement.  

4. You should now see the Disto data storage screen.  The Disto allows you to 
enter three lines of text.  In the first line, you will enter the site.  In the second 
line, you will enter the room name.  In the third line, you will enter a direction.   

5. Enter the site name.  Use the up and down arrows to the left of the Dist key 
(if necessary) to move to the first line.  If necessary, use the C key to clear out 
unwanted text.  Look closely at the Disto number buttons - you will see 
characters under each one.  If you press a number briefly and wait, you will 
get the first character.  If you rapidly press a number twice in a row, you will 
get the second character – and three quick presses gets you the third.  
Pressing and holding the number for a second gets you the literal number.  
Remember – you can use C to correct any mistakes. 

6. Enter the room name in the second line, following the same procedure. 

7. Enter the direction in the third line.  The direction must be a one or two-
character direction: N, S, E, W, NE, SE, NW, or SW (For other directions, see 
step 9, below).  Choose the direction that points to the next wall you are going 
to measure.  For example, if you are measuring a N-S wall and the next wall 
is to the north, you should enter N as your direction.   

8. Alternately, you can use numbers.  Imagine the number pad is a compass, 
with 2 pointing north.  Then you get the following meaning for the numbers: 

North  2  South  8 
  North East 3  South West 7 
  East  6  West  4 
  South East 9  North West 1 

9. If the room has a single wall at an odd angle, you can skip that wall and 
FloorRight can close the room at the correct angle.   The first wall you enter 
must be just after the odd wall, and the last wall must be just before that odd 
wall for FloorRight to close the room properly.  If there are multiple odd 
angled walls or if you want to declare a specific angle for a single wall, enter 
the raw compass direction in degrees in the third line.  For example, enter 95 
for a wall direction just south of due east.    

 Caution – for angles between zero and nine, you must add a leading zero:  
00, 01, 02, etc.  Single digit numbers are reserved as short cuts for the eight 
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major directions (see the diagram above).  If you type in 8 it means south but 
08 means a little bit east of north.  FloorRight will also accept a leading letter 
‘A’ instead of a leading zero.  (A0, A1, A3, etc.)    

If you find large angle numbers cumbersome, take a look at the Quadrant 
method. 

10. When you are finished, press the = key briefly.  This will store the 
measurement along with your site, room and direction labels. 

Now you can start the next measurement.  Remember, the Disto will 
automatically copy the Site and Room names and put you at the direction line 
when you start saving the measurement.  For measurements in the same room, 
you do not have to modify these first two lines – simply enter the direction. 

If you wish, you can skip the last wall, or, in the case of a rectangular room, the 
last two walls.  FloorRight will fill in the last wall(s) for you. 

Correcting Saved Measurements 
1. Hit the Menu key, then press the following numbers:  6, 4, 3. 

2. You should see one of your measurements.  Use the arrow keys to find the 
particular measurement you wish to correct.  Press the = key when you see 
the measurement you want. 

3. Use the arrow keys to select the label you wish to change, and then use C to 
erase old text.  You can enter new text as before. When done, press the = 
key.  You can use the arrow keys to move to another measurement, or press 
the C key repeatedly to get out of the correction menu. 

Disto Measurement Mistakes 
Here is a list of some of the common measurement mistakes made with the Disto 
Pro. 

• Remember, to get a number, you must press and hold the number key.  
When using the numeric direction scheme, it is easy to forget this and enter 
some unwanted letter instead. 

• Remember to change the room name when moving to another room.  It is 
easy to enter the measurements into the last room.  The same principle 
applies to sites. 

• Be careful not to take the walls out of order, or to enter directions that point 
toward the previous wall instead of the next. 

• Make sure to keep track of which direction you a facing, especially when 
moving between rooms. 
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• If you are trying to enter an odd angle just east of north – remember to zero 
pad single digit angles.  Single digits are reserved as short cuts for the eight 
main directions (N, NE, etc.) 

You can always correct measurements in the Disto once they’re saved either in 
the Disto Data File or in FloorRight. 

Azimuth vs. Quadrant Compass Angles 
Normally, the room angles are simply one of the eight main compass points (N, 
S, E, W, NE, SE, SW, NW).   For a room with odd angles, however, the wall 
direction can be specified to the degree.  So far, we’ve only mentioned the 
Azimuth method – which specifies the angle as a raw number between 00 
(North) and 359.   

Some people find the Azimuth method difficult to use, especially for larger 
numbers.  For example, what if we want to enter an angle eleven degrees west 
of north?  To find the raw angle, we must subtract eleven from 360, giving us 
Azimuth 349.    

The Quadrant method is an alternative to Azimuth.   In the Quadrant method, you 
always start with N or S, type in the angle from due North or South, and then 
specify in which way (E or W) to go away from North or South.   Eleven degrees 
West of North becomes N11W.   Notice that the compass is divided into four 
parts, so the angle number is always between 0 and 90.  Also, you do not need 
to zero-pad single digit numbers in the quadrant method.  S1E is just fine 
(although S01E is acceptable too). 

A quadrant method direction never starts with E or W, just as using EN to mean 
North East is not correct. 

Disto Errors 

A  by a site indicates an error in one or more walls of one or more rooms. 

Here are a few types of errors that might creep into the Disto data. 

• Wall errors with illegal data - the room display window will be gray: 

o Walls with a length of 0.    

o Typo’s in directions or a direction left blank.   
 

• Room errors – these include: 

o Incomplete rooms – rooms must contain at least 2 walls in order to use 
one of the automatic Room Closing methods to finish the room. 
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o Crossing walls.   

o Wall Order – walls must be listed in order around the room, clockwise or 
counterclockwise. For example, a north wall cannot follow a south wall.  If 
the walls are out of position, you can drag their data entries into the proper 
order. 

Editing Disto Data 
If your Disto data contains errors or omissions, you can edit the data from the 
Disto Data dialog in several ways. 

Drag and drop operations can be applied to wall and room entries.  If a wall 

measurement is out of order (a cause for error ), it can be moved to the correct 
position within the room.  Walls can also be moved between rooms.  Rooms can 
be moved within the site and between sites.  Sites can also be dragged within the 
list of sites. 

Another editing possibility is to use the context menu. A right click of the mouse 
gives you the following options. 

 

• Delete –  If you have selected a site, all rooms and walls within the site 
are deleted.  If you have selected a room, the entire room is deleted.  Right 
clicking a single wall, you can delete the wall. 

• Insert Wall – Right click a room entry and Insert Wall will place the new wall 
at the end of the wall list.  Click on a wall of a room to insert a new wall after 
the selected wall.  If you click on a site the Insert Wall command is grayed, 
i.e. not available. 

• Insert Room – Right click a site and Insert Room will place the room at the 
end of the list of rooms in that site.  Click on a room to insert a new room after 
the selected room.  Click on the blue text box to edit the name of the New 
Room and hit Enter to finish the edit.  Right click the new room again to insert 
new walls. 

• Insert Site – Click on any entry in the data list to insert a new site before the 
next site in the list. Click on the blue text box to edit the name of the New Site 
and hit Enter to finish the edit.  Right click the new site again to insert a new 
room and follow the instructions above for inserting new rooms. 
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Disto Room Closing Methods 
Room Closing Methods are selected by a group of buttons.  When you open the 
room, the applicable closing methods are displayed.  Some buttons will be 
grayed (i.e. not useful for this room).  You can click any of the available buttons.  
Added walls appear in green in the room display window. 

• Square and Square Reversed give similar results. They finish the room with 
a square corner.  Depending on the room list, you may have one or the other 
or both to choose.   

• Angled closing connects the end of the last wall with the beginning of the first 
wall in the room, no matter what the resulting angles might be. 

• Adjust Length closing is handy for small overlaps of the walls.  The 
overlapping pieces are displayed in gray and trimmed before sent to the 
FloorRight drawing. 

In the room below, there is a difference between Square and Square Reversed.  
The first wall and the last wall overlap slightly for a squared closing and the 
closing methods take the overlap from different walls. 

  

If you are not sure which wall should be shorter, you may want to split the 
difference, in which case you can edit the measurements in the data window. 

Alternatively, the wall measurements could be correct and you could have an odd 
angled wall, in which case you would choose Angled closing. 
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Another kind of closing choice would be the following: 

  

The closing methods allow you to (purposefully or not) leave out the last Disto 
measurement of a room and let FloorRight insert the wall automatically.  If the 
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room is rectangular, you only need to measure any two adjacent walls, and the 
rest is done automatically with the Square or Square Reversed method.  
Another time to use this feature is if you have a wall positioned at an odd angle, 
i.e. not 90° or 45 °.  Leave this wall and enter the other walls in order, then use 
the Angled closing method.   

If none of the methods give you the right result, you can add walls to the room 
list. 

In the Disto Data dialog, Room closing buttons are grayed if there is an error  
or a wall contains illegal data.  In the Interactive mode, a room containing a wall 

error will be marked with a red X.   

Interactive Disto 
The Disto Interactive Utility is designed to interactively create a series of rooms, 
which can be saved to a file or transferred directly into FloorRight. A saved data 
file can be imported into FloorRight using the Import / Disto / File selections in 
FloorRight’s File menu. 

When the utility is started, it will search COM1 through COM4 looking for a Disto. 
If it cannot find one, it will display an error message and ask if you wish to 
continue. If it can find a Disto unit, it will connect to it and await input.  

Check that your Disto model is ready to communicate with these steps: 

• Disto Pro – the unit should be turned on. 

• Disto Plus – the unit should be turned on and the Bluetooth should be 
activated. To do this, press the Bluetooth button. The Bluetooth icon should 
begin blinking on the Disto display. 

To collect room data for importing to FloorRight  you can use a combination of 
the Disto and the keyboard and menus of the Disto Import dialog.   

The Disto Import dialog contains menu items for adding rooms and walls, as 
well as for editing those items.  Rooms and walls can be cut, copied and pasted. 
An undo / redo mechanism is also provided.  You can specify how the rooms 
should be closed, so that all of the walls of a room may not need to be entered.   

When using the Disto, walls and rooms can be added and existing walls can be 
changed. 
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Collecting Room Data 
The steps for entering room measurements are slightly different, depending on 
your model of Disto.  Once you have entered the data with the Disto device, you 
can go back and edit it with the Disto or manually by typing a correction.   

Disto Pro 

! New Wall 
1. Take a measurement 
2. Use one of the number keys to indicate the wall direction: 

1 = Northwest  2 = North 3 = Northeast 
4 = West  6 = East 
7 = Southwest 8 = South 9 = Southeast 

3. Press the enter key twice 

! New Room 
1. Press the Clear button ("C") 
2. Press the enter key 

Disto Plus 

! New Wall 
1. Take measurement 
2. Use one of the arrow keys to indicate direction. Note that in order to press 

an arrow you have to press the "2nd" key first. However, once the "2nd" 
key is pressed, you can just leave it in that mode. 

 64



! New Room 

Press the enter key. Note that in order to press enter you have to press 
the "2nd" key first. However, once the "2nd" key is pressed, you can just 
leave it in that mode. 

♦ 

Either Disto 

! Edit a Wall 
1. In the Disto Import dialog, select the wall to be changed. 
2. Use the new wall procedure above to enter a new value 

Disto Import Dialog 

From the Disto Import dialog box the following menus allow you to add or edit a 
room’s wall measurements.  

• File  
• Rooms  
• Edit  
• Help  

Disto File Menu 
The File menu in the Disto Import dialog offers the following selections: 

Menu Option Function When Available 

New Clears all room 
information and prepares 
for new entries. 

Always 

Reconnect to 
Disto 

Reestablishes the 
connection to the Disto 
device. 

Always 

Import to 
FloorRight™ 

Sends the data to the 
Disto Data dialog for 
editing, saving as a .csd 
data file, or sending to the 
current FloorRight project. 

Always 

Close Closes the Disto Import 
dialog. 

Always 

 

Disto Edit Menu 
The Edit menu in the Disto Import dialog offers the following selections: 
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Menu Option Function When Available 

Undo Undoes the last operation. A change has been made 
in the Disto Import 
dialog. 

Redo Redoes the last undone 
operation. 

After an undo. 

Cut Copies the currently 
selected room or wall to 
the clipboard and then 
removes it from its current 
location. 

A room or wall is 
selected. 

Copy Copies the currently 
selected room or wall to 
the clipboard. 

A room or wall is 
selected. 

Paste Pastes any wall or room 
in the clipboard to the 
current location. 

A room or wall has been 
cut or copied. 

Delete Deletes the currently 
selected room or wall. 

A room or wall is 
selected. 

 

Disto Cut, Copy, Paste and Delete Functions 
The Cut, Copy, and Paste functions can expedite the creation of your site list.  

You can Cut or Copy a room or a wall to the clipboard for pasting back into the 
list.  When you Cut or Copy a room, any walls listed under the room will be 
included.   

To Paste a room or wall from the clipboard back into the site list you must first 
select a place in the list to indicate where you want to paste the item.    

To Paste a cut or copied wall:  
1. Select a wall to insert the clipboard wall before the selected wall. 
2. Select a room to add the clipboard wall to the end of that room’s wall list. 
3. Walls from the clipboard cannot be pasted when you select the site. 

To Paste a cut or copied room: 
1. Select a room to insert the clipboard room before the selected room. 
2. Select a wall to insert the clipboard room before the room that contains the 

selected wall. 
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3. Select the site to add the clipboard room to the end of the site list. 

To delete a room or a wall, select it and then select Delete from the Edit menu in 
the Disto Import dialog. 

Disto Rooms Menu 
The Rooms menu in the Disto Import dialog offers the following selections: 

Menu Option Function When Available 

Edit Entry Edits the information about 
the currently selected item. 

A room or wall is 
selected. 

Add Room Adds a new room with the 
next default name 

Always 

Add Wall Displays the Add Wall 
dialog for entering length 
and direction of the new 
wall. 

A room or the end of 
an unfinished room list 
is selected. 

Close Square  Closes the room with a 
square corner. 

Always 

Close Reverse 
Square  

Closes the room with a 
square corner, similar to 
Close Square. 

Always 

Angled  Connects the end of the 
last wall with the beginning 
of the first wall in the room. 

Always 

Adjust Length  Adjusts the length of 
existing walls to close the 
room. 

Always 

 

Room Closing  
The Room Closing menu options offer you a shortcut.  For many types of rooms 
you don’t have to enter all of the walls.  FloorRight draws the remaining walls in 
the room, displayed in green in the drawing window.  The automatically 
generated walls will not be listed in the room data list. 

• To accept the room closing, continue with the next room or Import to 
FloorRight™ in the File menu. 

• To override the automatic closing, continue entering the walls of the room. 
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You can selectively change the room closing method in the following ways:  

• If a room is currently selected, the closing method of that room will change. 

• If a wall is currently selected, the closing method of the room that contains 
that wall will change. 

• If the site is selected, the closing method of every subsequently created room 
will default to the selected value. 

If the selected close method would result in an invalid room, the room is not 
closed.  Rooms that are not closed properly are marked with a red X.  

  

If improperly closed rooms are saved, you can edit them in the Disto Data dialog 
when you select Import to FloorRight from the File menu. 

Disto Help Menu 
The Help menu in the Disto Import dialog gives you the following information: 

 

Menu Option Function When Available 

Disto Import 
Help 

Runs the Help system for 
the Disto Import Utility 

Always 

About Disto 
Import 

Displays version 
information for the Disto 
Import Utility 

Always 
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Working with Layouts 
Viewing the Stock Window 

If FloorRight™ is displaying the room view, clicking the Stock Toggle button  
on the toolbar or selecting View Seam / Stock Layout from the Layout menu 
will split the window into two parts.  The top part of the window, called the seam 
view, will display the location of seams in the rooms.  The lower part of the 
window, called the stock view, will display the stock and how it is to be cut.  You 
can modify the stock view manually by the drag-and-drop method. See Moving 
Stock Pieces, p. 69, for more detail.  Clicking the toggle button again will return 
you to the room view. 

For large jobs, it may be necessary to keep stock cuts from the same room, or in 
the Commercial version, the same page, together in the stock listing.  

By default, the stock view assumes that the material rolls are of infinite length.  In 
FloorRight Commercial, when the roll allocation features in the Layout menu are 
enabled the stock view displays cuts allocated to specific rolls of material.  
Displayed to the right of the roll is the id/name and length of the roll and the 
amount remaining on the roll. 

Understanding the Display will give you more detailed information on the display. 

You may wish to use Zooming to get a better view of either display. 

Moving Stock Pieces 
If you need to change the way the stock is cut, you can manually move the 
pieces.  Select a piece or a group of pieces on the stock in the Stock View 
Window and drag them to a new position.  If the pieces overlap, the drag will not 
be allowed and the pieces will snap back to their previous location. 

You can also use the arrow keys on your keyboard -  - to move the stock 
pieces. 

Modifying Lay Direction 
You can change the lay direction of the material for the entire floor plan, or for 
individual rooms.   

If you do nothing, the lay direction will be in the east-west direction, horizontally 
across your screen.  To change the lay direction to north-south, vertically across 
your screen, click on the North-South Lay Direction button  on the toolbar or 
use the Lay Material N-S selection from the Layout menu. 

To change back to east-west, select the East-West Lay Direction button  on 
the toolbar or the Lay Material E-W choice from the Layout menu. 
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To change the lay direction of an individual room or subset of rooms, select the 
room(s) or side and choose one of these options from the Lay Room submenu 
found in the Layout main menu or the Room Properties context menu.  The 
Lay Room to Side selection is found in the Wall Edit context menu, not the 
Room Properties context menu. 

• Lay Room North  - select one or more rooms 
• Lay Room South  - select one or more rooms 
• Lay Room East   - select one or more rooms 
• Lay Room West  - select one or more rooms 
• Lay Room At Angle  - select one or more rooms 
• Lay Room As Material  - select one or more rooms 
• Lay Room to Side  - select a wall (line) 
 
The Lay Room As Material option indicates that you want no special treatment 
for this room after all.  This is the default when you create a room, and the Lay 
Material E-W / N-S options described above will affect only rooms set to Lay 
Room As Material.   

The Lay Room At Angle option gives you a choice of every possible 45° angle 
layout: northeast, northwest, southeast, or southwest. 

The Lay Room to Side option is only for rooms having a wall that does not run 
north-south or east-west.  If you need to lay the material from a diagonal wall, 
select the wall and choose this option.  A thick arrow indicating the lay direction 
will appear on the selected wall.  Seams will go parallel and perpendicular to this 
wall.  To reverse the lay direction on a selected wall use the Reverse Line 
Direction command found in the Wall Edit context menu, or Ctrl-R. 

 Changing the angle of the side of a room that is laid to that side will change 
the lay direction.  Any inserted user seams will be lost. 

The lay direction for a room is indicated with a small arrow, as shown in this 
illustration: 

  

The downward pointing arrow indicates a lay direction of south. 
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Flipping Seams 
Flipping seams places the seams in a mirror image of what they were before.  If 
your rooms are symmetrical, there won’t be any change to the stock layout.  But 
if your rooms are irregular, more (or sometimes less) waste could be incurred. 

The Horizontal Flip button  reflects the seams from left to right. 

    

 

The Vertical Flip button  reflects the seams from top to bottom. 

    

 

Flipping seams only affects automatically inserted seams; it does not move any 
seams you have added. 

You can get back to the original layout by selecting the Layout menu and 
choosing Reset Layout. 

Selecting a Room 
To select a room: 

1. Click the Highlight button  on the tool bar. 
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2. Click on the room you wish to select. 

The room will turn the highlighted color if you are successful. 

Allow More Seams 
FloorRight™ allows you to specify the maximum number of seams for a room.  
Your decision on what this value should be is generally based on aesthetics and 
how the room is used. 

Regardless of the number of seams you would allow in a room, it is usually 
preferable to minimize the number of seams, even if it incurs a nominal amount 
of additional waste.  The FloorRight™ algorithms automatically take this into 
consideration. 

For some rooms, particularly closets, adding seams to reduce the amount of 
waste is the preferable option.  Selecting the Allow More Seams option in the 
Room Layout Styles dialog box or the Room Properties dialog box informs the 
FloorRight™ algorithm to allow more seams, all the way up to the maximum you 
have specified, in order to save material. 

T-Seams 
T-seams are seams that have one or two endpoints along another seam. 

  

You can specify the number of T-seams for a room layout style in the Room 
Layout Styles dialog box. 

Butt Seams 
Butt seams are cut across the lay of the carpet stock. 
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You can specify the number of butt seams for a room layout style in the Room 
Layout Styles dialog box. 

Long-Axis Seams 
A long-axis seam runs the long dimension of a room. 

  

You can disallow long-axis seams for a room layout style in the Room Layout 
Styles dialog box. 

Sometimes a long-axis seam cannot be prevented, for example when the short 
dimension of a room is wider than the stock.  The illustration, above, is just such 
a case. 

Length Seams 
Length seams are cut with the lay of the carpet. 
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You can specify the number of length seams for a room layout style in the Room 
Layout Styles dialog box. 

Adding a Seam 
FloorRight™ locates seams to minimize the amount of waste, based on the 
information you provide.  Sometimes, however, it is desirable to add a seam or 
relocate a seam for reasons that are difficult to describe to a computer.   

To view the existing seams, you must be in the Seam/Stock View   

To add a seam to a room, follow these steps. 

1. Select the Add Seam button   

2. Move the mouse cursor to the wall or seam where your new seam will start, 
and press the left mouse button down. 

3. Without releasing the mouse button, move the mouse cursor to the wall or 
seam where your new seam will end. 

4. You can adjust the location of your new seam by moving the mouse cursor 
along the wall or seam. 

5. Release the mouse button when you are satisfied by the result.  Make sure 
the mouse cursor is right on the wall or seam before you release. 

 

Your new seam will appear as a broken line across the room. User-created 
seams are always displayed, even when you are not looking at the stock view  

Seams cannot cross existing seams, and the minimum cut width is enforced.  

If you are not happy with the result, use Undo or delete the seam and try again. 

If you have difficulty adding seams, it may be caused by having rooms that are 
adjacent to one another.  You may have selected the wall to the wrong room and 
be inadvertently trying to create an illegal seam.  To overcome this, either drag 
the room away from the other rooms, or bring the room to the front and try again.  
See Aligning Rooms, p. 38, to find out how to quickly realign the rooms when you 
are finished. 

Deleting a Seam 
You can delete seams specified by FloorRight™ as well as seams that you have 
added yourself, including mitered seams for borders. 
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To view the existing seams, you must be in the Seam/Stock View   

1. Select the seam, just as you would select a line.  The difference is that no 
arrowhead will be displayed on the seam when you have selected it. 

2. Click the Eliminate Seam button   

You can also delete a selected seam by: 

• Clicking on the Layout menu and selecting Eliminate Seam 

• Pressing the delete key on your keyboard 

• Clicking on the Edit menu and selecting Delete. 

• Right click and select Eliminate Seam from the context menu. 

Some seams cannot be deleted.  You cannot delete a seam if - 

• The width of the new piece would exceed the width of the stock. 

• Deleting the seam would make an L shape from a T-seam  

If you try to eliminate a seam in these cases, you will see a message box stating, 
"FloorRight could not eliminate a selected seam."  Try converting the seam to a 
user seam and relocating it. 

Changing Seam Location 
FloorRight  has two kinds of seams, those automatically placed by the program, 
and those that the user can place and move in the room. 

Here are the ways to manipulate seams automatically inserted by FloorRight :  

•  Use the Flip Seams Vertically / Horizontally buttons,    

• Change the layout direction for the entire floor plan   or for individual 
rooms.   
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• Convert the seam to a user seam (from the Layout or Seam context menu) 
that you can drag to a new location.  Moving a user seam may cause 
FloorRight  to automatically place another seam.   

 

 

To move a user seam, simply click on the seam and drag it to its new location. 

1. Click on the Highlight button  on the toolbar. 

2. Click on the seam and don’t release the button. 

3. Move the mouse to drag the seam to its new location.  Note the 
measurements along the walls that the seam connects -- these are the 
distances between the seam you are moving and the wall or seam next to it.   

 

4. Release the mouse when you are satisfied with the result. 

Another way to move a seam is with the arrow keys on your keyboard. 

1. Click on the Highlight button  on the toolbar. 

2. Click on the seam 

3. Press the keyboard arrow keys -  - to move the seam in small steps.  
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All user seams can be dragged as long as both ends remain attached to their 
original edge (wall, border, hole, or another seam).  While dragging a seam, an 
attached seam (e.g. a T-seam) will be adjusted to fit.  

If you wish to change the orientation of the seam, this cannot be accomplished 
through dragging.  You must delete the seam and then create a new seam. 

Experimenting With the Layout 
You have four options for experimenting with the layout created by FloorRight™. 

1. You can modify the lay direction of the material for the entire floor plan or for 
individual rooms. 

2. You can change a seam location. 

3. You can delete a seam and experiment with Layout 1, Layout 2, and Layout 
3. 

4. You can add a seam to a room. 

After any of these actions, FloorRight™ will recalculate the layout, and report the 
amount of waste incurred.  This will allow you to compare several different 
layouts before making a final estimate. 

Layout 1 
Retrieve the original layout by clicking the Layout 1 button  from the toolbar, 
or by selecting the Layout menu and choosing Layout 1. 

This option is available only after you have deleted a seam created by 
FloorRight™ and there are at least two rooms of the laid material in the drawing.  
Layout 1 is the layout that exists after the seam deletion. 

Reset Layout will recalculate the layout and restore the seams you have deleted. 

Layout 2 
Layout 2 is calculated by starting with Layout 1, and moving or removing seams 
to find a better layout.  Sometimes Layout 2 is not as good as Layout 1.  No 
seams are added when calculating Layout 2. Layout 2 differs from Layout 3 in 
that seams may be added in Layout 3. 

Calculate Layout 2 by clicking the Layout 2 button  from the toolbar, or by 
selecting the Layout menu and choosing Layout 2. 

This option is available only after you have deleted a seam created by 
FloorRight™ and there are at least two rooms of the laid material in the drawing. 
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Layout 3 
Layout 3 is calculated by starting with Layout 1, and then adding, moving or 
removing seams to find a better layout.  Layout 3 differs from Layout 2 in that no 
seams may be added when calculating Layout 2. 

Calculate Layout 3 by clicking the Layout 3 button  from the toolbar, or by 
selecting the Layout menu and choosing Layout 3. 

This option is available only after you have deleted a seam created by 
FloorRight™ and there are at least two rooms of the laid material in the drawing. 

Locking a Room 
If you spend a lot of time changing and revising the seam layout, you may wish to 
lock a room against subsequent changes. 

To lock a room, select it and then click on the Lock Room button  on the 
toolbar or use the right click mouse button to invoke this layout property. 

Select the room and click the button again to unlock the room. 

If you change the lay direction of the material, the room will be unlocked for the 
new lay direction. 

Reset Layout 
Reset Layout causes FloorRight™ to recalculate the layout.  Any computer-
calculated seams you have deleted will be reinstated by this action. 

Select the Layout menu and choose Reset Layout to reset the layout. 

Pattern Start 
There are three ways of determining the pattern start for a room with patterned 
carpeting. 

Rooms can be grouped so that the pattern matches from room to room.  This is 
called a "Global Pattern Start" and is what you get if you don’t indicate otherwise.  
To change a room back to the global pattern start, select the Layout menu and 
choose Use Global Pattern Start. 

You can remove a room from the global pattern by setting it to "Independent 
Pattern."  This will result in a more efficient layout, since the constraint of where 
the pattern starts has been removed.  Independent pattern allows the 
FloorRight™ layout algorithm to choose where the pattern will start for that room.  
Select the Layout menu and choose Use Any Pattern Start. 

Third, you can dictate a particular pattern start for a room, either relative to a 
point or centered between two points.  To set the pattern start relative to a point, 
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select the point, select the Layout menu and choose Position Pattern Relative 
To A Point.  To center the pattern between two points, select two points in the 
same room, select the Layout menu, and choose Center Pattern Between Two 
Points. 

See Global Pattern Start, p. 81, for information on how the global pattern start 
works. 

See Position Pattern Relative to a Point, p. 179, for more details on this action. 

See Center Pattern Between Two Points, p. 150, for information on how this is 
done. 

Show Pattern 
The View menu options Show Room Pattern and Show Stock Pattern display 
grids representing patterned material in the seam view and the stock view, 
respectively.   

To display the seam / stock view click the View Toggle button on the toolbar . 

The grid shows the pattern width, length, and drop as specified in the New 
Material - Detailed dialog box. 

  

In the seam view, the grid represents how the pattern appears on the carpet.  For 
example, each rectangle could represent a floral image. 
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In the stock view, you can see two grids, one on top of the other.  The dimmer, 
smaller grid is the same grid found in the room view.  The brighter grid 
represents the pattern width and length, which takes the pattern drop into 
consideration.  If there is no pattern drop, then both grids will be the same. 

Pattern Length, Width, and Drop 
Patterns are defined by their length, width, and drop dimensions as entered in 
the Edit Material Types dialog box. 

To understand the length, width, and drop of a pattern, think about a rectangular 
grid that can be drawn on a carpet so that the picture in every rectangular is the 
same. 

 

If each little carpet roll pattern in the picture above was 50 cm by 50 cm, the 
carpet would have a pattern width of 50 cm, a pattern height of 50 cm, and a 
pattern drop of 0. 

If we modify the pattern with a pattern drop of 25 cm, the carpet looks like this: 
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We no longer have the same picture in every rectangle, so we cannot use 50 cm 
for the width and 50 cm for the height. 

 

The pattern actually becomes bigger than the little repeated picture.  It must 
double in width to accommodate the pattern drop.  The pattern width for this 
pattern is 100 cm.  (Only three complete patterns are shown -- the patterns on 
the right side have been cut in half). 

Pattern length and pattern width must be used to specify the dimensions of a 
boxed tile material.   

You can use fractional measurements for pattern length, width, and drop only if 
you specify the dimensions in inches.  Fractional inches are allowed in multiples 
of 1/2, 1/4, 1/8, 1/16, 1/32, and 1/64 (e.g. 8 7/64" is allowed, 4 2/15" is not 
allowed).  The pattern drop must divide evenly into the pattern length. 

Global Pattern Start 
Very often, patterned carpeting is used in a grouping of rooms, and the pattern 
must be maintained throughout.  In this situation, you should take advantage of 
the Global Pattern Start. 

FloorRight™ uses the Global Pattern Start unless you tell it not to.  If you have 
changed some rooms, you can set them back to Global Pattern Start by selecting 
them, clicking on the Layout menu and choosing Use Global Pattern Start. 

This diagram shows the continuous pattern, which occurs when you use the 
Global Pattern Start.  You will see a continuation of the pattern in the space 
between the rooms; this has been added for illustrative purposes and will not 
appear on the FloorRight™ display. 

The isolated room may be a candidate for "Independent pattern start," since its 
pattern does not need to "flow" into adjacent rooms. 
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The Global Pattern Start changes under a variety of conditions. 

If the lay direction for the material is defined as east to west, the pattern starts in 
the upper-left corner of the room that is furthest up and to the left.  In the diagram 
above, the Global Pattern Start is the upper left corner of BDR 1. 

If you change the material direction to north to south, the Global Pattern Start is 
the lower left corner of the room that is furthest down and to the left.  If you 
changed the material direction in the diagram, the lower-left corner of BDR 3 
would become the pattern start. 

You can choose any room to be the start of the global pattern.  Select the room, 
click on the Edit menu and choose Room Layout Properties.  Click the "Pattern 
Start" checkbox near the bottom of the dialog box to choose this room as the 
pattern start. 

The isolated room may be a candidate for "Independent pattern start," since its 
pattern does not need to "flow" into adjacent rooms. 

The Global Pattern Start changes under a variety of conditions. 

If the lay direction for the material is defined as east to west, the pattern starts in 
the upper-left corner of the room that is furthest up and to the left.  In the diagram 
above, the Global Pattern Start is the upper left corner of BDR 1. 

If you change the material direction to north to south, the Global Pattern Start is 
the lower left corner of the room that is furthest down and to the left.  If you 
changed the material direction in the diagram, the lower-left corner of BDR 3 
would become the pattern start. 

You can choose any room to be the start of the global pattern.  Select the room, 
click on the Edit menu and choose Room Layout Properties.  Click the "Pattern 
Start" checkbox near the bottom of the dialog box to choose this room as the 
pattern start. 
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The isolated room may be a candidate for "Independent pattern start," since its 
pattern does not need to "flow" into adjacent rooms. 

The Global Pattern Start changes under a variety of conditions. 

If the lay direction for the material is defined as east to west, the pattern starts in 
the upper-left corner of the room that is furthest up and to the left.  In the diagram 
above, the Global Pattern Start is the upper left corner of BDR 1. 

If you change the material direction to north to south, the Global Pattern Start is 
the lower left corner of the room that is furthest down and to the left.  If you 
changed the material direction in the diagram, the lower-left corner of BDR 3 
would become the pattern start. 

You can choose any room to be the start of the global pattern.  Select the room, 
click on the Edit menu and choose Room Layout Properties.  Click the Pattern 
Start checkbox near the bottom of the dialog box to choose this room as the 
pattern start. 
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Working with Money 
Customer Information 

The Customer Information dialog box can be accessed by selecting the Job 
menu and choosing Edit Customer Information, or from the button in the Job 
Estimate dialog box. It is also displayed automatically if you have not entered 
required customer information before saving your document. 

  

FloorRight™ requires that at least a customer name, telephone number and job 
info be supplied before saving or closing the file, and before printing any of the 
reports. 

Job info is for information that is meaningful to you.  You will want to enter a 
unique identifier to distinguish this job from other jobs.   

This information is printed on your drawings and, if you select it, will be printed on 
the header of your Job Estimate.  

To save you reentering information, the Import button allows you to load the 
important customer information directly from your third party database. Contact 
your FloorRight™ distributor for more information on the availability of these 
databases. 

Entering Prices 
The price per unit of a material can be entered when you first create the material 
with the New Material - Detailed dialog box   You can also enter the price in the 
Job Estimate dialog box. 

Prices for labor, padding, and other related items are entered in the Job 
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Estimate dialog box. 

Sales Tax, or Value Added Tax Information 
Different areas have different rates of sales tax or value added tax. One 
company might assess different tax rates for different customers, depending on 
their residency. Some areas may tax labor at a different rate than they tax 
materials. FloorRight™ accommodates all of these conditions. 

To define sales tax rates, select the Default menu and choose Sales Tax. 

  

Select Add to record a new tax rate.  

To change an existing tax rate, select the name containing the rate you wish to 
change, and then select Edit.   

To completely remove a line of sales tax information, click on the name item and 
then press Delete. 

 If you have multiple tax rates, they are listed alphabetically. The first one 
listed is used automatically, so be careful! 

To change which tax rate is used, select the Job menu and choose Job 
Estimate or press the Job Estimate button  from the toolbar. Clicking on the 
tax quantity for a particular line item will allow you to choose the correct tax.  
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This needs to be done for each line item in the estimate. 

The Sales Tax Information is one of the properties saved in the Template. 

Job Estimate Dialog Box 
The Job Estimate dialog box contains an itemized quotation for the job you are 
estimating.  In FloorRight Commercial, the estimate will be for the entire job or 
just the current page, depending on the Base Stock on Page setting in the Job 
menu.   

When you complete the estimate, this report can be printed and given to your 
customer. 

To see the Job Estimate dialog box, press the Job Estimate button  from the 
toolbar, or select the Job menu and choose Job Estimate. 

  

The width of each column can be adjusted to your preference.  Position the 
mouse cursor over the header row, just between two columns.  The cursor 
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should change into a vertical line with arrows pointing to the left and right.  Click 
the mouse and drag to change the width of columns. 

Double-clicking the title bar of the Job Estimate dialog box will cause it to fill the 
entire screen, allowing you to see much more of the information at one time.  
Double-clicking again will return the dialog box to its original size. 

• Color – This is the color key for your layout display. It also shows the material 
type description for that material.  If transition materials are used, they are 
listed after the room materials.  The color box appears with an X through it for 
transition materials. 

• Item name – An identifier for the material being used.  Usually the 
manufacturer and style of the material, once it is decided upon.  This column 
also contains other estimate items associated with the material such as Pad, 
Labor and Base.   By default, this entry will say "Transition" for transition 
materials, but the box can be edited to the user’s preference. 

• Description – A textual description for the material. 

• Based on – The measurement that the price of this line item is based on.  You 
can select from these measurements:  

o Material area – area of the material being used, including waste. 

o Room area – area of the rooms for which this material is used. 

o Linear distance – the length of the material. 

o Room perimeter – the sum of the lengths of the walls of the rooms.  This 
only applies to the primary material for the room, i.e. the material with 
which the room was first created. 

o Seam length – the total of all seam lengths for all rooms of the listed 
material. 

o Fixed – a set price, entered under Unit Price for this line 

o Base area – the carpet area required for carpet base (calculated as room 
perimeter times the base height) 

o Tile count – in area covered by the tiles.  Note: this area will be larger than 
the material area because partial tiles (at the edges of the rooms) are 
counted as whole tiles. 

o Hole perimeter – the sum of the lengths of the edges of the holes.  This 
only applies to the primary material for the room, i.e. the material with 
which the room was first created. 

o Room count – the total number of rooms / stairs / hallways of the listed 
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material in the drawing. 

o Inside corner count – the total number of inside corners of the rooms. 

o Outside corner count – the total number of outside corners, e.g. in halls or 
L-shaped rooms. 

o Adjusted room perimeter – subtracts transitions and walls not included, 
from the total room perimeter. 

o Step count – the total number of steps in stairways is useful for step 
bullnosing. 

o Adjusted base area – uses the Adjusted room perimeter above to 
calculate the base area (adjusted room perimeter times the base height). 

For transitions, this value defaults to the Based on value set in the Transition 
Materials dialog.  Values can be changed to the same values available in the 
Transition Materials dialog.  They include: 

o Transition count 

o Transition length 

• Length – The length of the material, if applicable. 

• Quantity – The amount needed.  The quantity can be edited only when the 
Based on entry is set to "fixed", otherwise, it is computed by the software. 

• Waste – The amount that is discarded by the automatic layout.  The percent 
of the stock that is unusable after cutting.  This is the minimum amount of 
waste, as determined by the software. 

For materials that do not require layout, a waste percentage can be defined in 
the Edit Material Type dialog box. 

• User add – You can add material in this column to provide for an additional 
margin of error.  Stock materials are expressed in linear feet.  Other materials 
are expressed as a percentage. 

• Boxed – Material such as ceramic tile frequently comes in boxes.  In this 
case, check this column and fill in the next. 

• Amount / box – Enter the amount contained in a box (sf, sy, or whatever units 
you are using).  

• Boxes – The total number of boxes needed of this item. The program 
calculates this. 

• Unit price – The cost of the material or labor, based on the Based on column.  
If you are basing this line on "Fixed" cost, this is the cost for one item. 
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• Subtotal – The price for this line, before sales tax or value added tax.  The 
bolded sub-totals are sub-totals for a material type. 

• Tax – The sales tax or value added tax for this line item.  

• Price – The total price, including tax, for this line.  The bolded prices are total 
prices for a material type.  The grand total for the entire job is shown just 
below the scroll bars on the display. 

The menus at the top of the dialog box provide a variety of Import / Export and 
print features for your job. 

To exit the Job Estimate dialog, select Save and Exit or Ignore Changes and 

Close from the File menu.  You can also use the standard Close button  
at the upper right corner of the dialog.  This button gives you the usual option to 
save you changes. 

See also: 

Adding and Deleting Lines in the Estimate, p. 90  

Entering Customer Information, p. 85  

Printing, p. 117 

Reports, p. 110 

Adding and Deleting Lines in the Estimate 
FloorRight™ automatically generates lines for all selected job estimate items, 
based on your material definitions.   

You can add additional lines by following these steps: 

1. Bring up the Job Estimate dialog box if you have not done so. 

2. Find the material with which your new cost is associated.  There should be a 
blank line at the end of the group of costs that go with this material. 

3. Type your information into the blank line. 

You can remove any unnecessary lines by following these steps: 

1. Bring up the Job Estimate dialog box if you have not done so. 

2. Select the line you wish to delete by clicking anywhere on the line 

3. Click the Delete key on your keyboard or select Delete from the Job Estimate 
Edit menu. 

You cannot manually delete the line for the material.  To remove an entire 
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material from a bid, you must be sure that no rooms are using that material. If no 
rooms are using that material, then it will not appear in the bid. 

Changing the Currency Symbol 
You can change the currency symbol through Windows so that FloorRight™ and 
all other Windows compliant software will use it. 

1. Double-click on the My Computer icon on the desktop.   

  

2. Double-click on the Control Panel Folder  

  

3. Double-click on the Regional Settings icon   

  

4. Choose the Currency tab. 

Enter or select your currency symbol in this dialog box, and click OK.  
FloorRight™ will automatically use the currency symbol you have chosen. 

Menus - Job Estimate 
The menus at the top of the Job Estimate dialog box allow you to configure your 
estimate page for printing and import and export information to compatible 
programs. 

  

Click the menus in the image above for details about each one. 

Job Estimate File Menu 
The File menu inside the Job Estimate dialog presents the following selections: 
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• Print – displays the Print Job Estimate dialog is the usual Windows Print 
dialog with the addition of a FloorRight options section for selecting the print 
format. 

  

• Print Preview – displays the Job Estimate as it will appear in the printout.  
You can print directly from any of the preview screens using the Print button - 

 

• Print Setup – lets you choose another printer or modify your printer settings. 

• Print Format – lets you create and edit templates for your printout. 

• Reports – gives you more options for creating and exporting reports for the 
estimate. 

• Import  – Allows you to import materials and associated information from 
your third party database program. 

• Export – You can export all materials in your job estimate to a third party 
database. 
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• Export Selected – You can select one or more of the materials in your 
estimate for export. 

• Save and Exit – Saves the changes you have made to the Job Estimate and 
closes the dialog. 

• Ignore Changes and Close – Ignores any changes made since the box was 
opened and closes the dialog. 

Importing / Exporting 
FloorRight™ supports importing materials through the Detailed New / Edit 
selection from the Room color drop-down menu and through the Job Estimate 
dialog box. 

FloorRight™ supports export of all materials or only selected materials in the 
menus found in the Job Estimate dialog box. 

The Customer Information dialog, found either from the main Job menu or from 
the Job menu inside the Job Estimate dialog box, supports importing of 
customer information.   

For details on Importing and Exporting information between FloorRight™ and a 
third party database, contact your FloorRight™ distributor.  

Job Estimate Edit Menu 
The Edit menu inside the Job Estimate dialog presents the following selections: 

• Copy Estimate to the Clipboard  – This copies the entire estimate to the 
clipboard for pasting into other applications. 

• Delete Row – Job Estimate items may be deleted from the estimate.  Primary 
room materials cannot be deleted from the estimate. 

o Click the row number (the leftmost column of the estimate) of the item you 
wish to delete.  This highlights the row. 

o Select Delete Row from the Edit menu or click the Delete key on you 
keyboard. 

Job Estimate Job Menu 
The Job menu inside the Job Estimate dialog presents the following selections: 

• Header  – lets you design your header information for your printout (see 
p.169). 

• Customer Info – displays the Customer Information dialog for your review 
(see p.85).  Customer info may be included in the Header of your printout. 

 93



• Add Text for Printing – text entered in this dialog will appear in all your 
printouts (see p.105). 
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Customizing Your Screen 
Configuring the Toolbars 

Most FloorRight™ functions can be found on one of the dockable and 
configurable toolbars.  You can place toolbars that you use frequently anyplace 
on the screen, and buttons that you rarely use, can be removed from the display.   

By default all toolbars are docked at the top of the screen. They can be docked at 
the top or bottom of the window, or they can "float".   

• To move a toolbar that is docked, grab the bar at the left end and use the 

click and drag method.    

• A floating toolbar has a colored title strip at the top and can be moved like any 
other window by clicking and dragging. 
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Individual toolbars can be configured to your preference.  Move the cursor over 
any toolbar text label or icon and click the right mouse button.  A drop-down 
window displays a checklist of all the toolbars.  Each toolbar name is: 

• Checked if the toolbar is displayed 

• Not checked if the toolbar is hidden 

This drop-down is also accessed from the View menu by clicking the Toolbars 
selection. 

Change the status of any toolbar (displayed to hidden, and vice versa) by clicking 
the name. 

The last line, Customize…, will allow you to rearrange the individual toolbar (the 
one that the cursor was over when you right clicked). 

The last toolbar settings are saved and applied to any files you open, even after 
you restart the FloorRight program. 

Customizing the Toolbars 
Move the cursor over any toolbar text label or icon and click the right mouse 
button.  Select Customize… to bring up the Customize Toolbar – (toolbar 
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name) dialog. 

 

• Current toolbar buttons box – By default, all buttons and boxes are 
displayed, so they will be listed in this box. 

• Available toolbar buttons box  – If any buttons or edit boxes have been 
hidden, they are listed here and can be inserted later. 

To move buttons between these boxes, use these buttons: 

o Add -> Takes previously hidden items from the Available toolbar 
buttons box and adds them to the Current toolbar buttons box. 

o <- Remove Takes displayed items from the Current toolbar buttons box 
and hides them in the Available toolbar buttons box. 

The order of the buttons, boxes, and labels on the toolbar is left to right, and 
top down, corresponding to the list in the Current toolbar buttons box.  To 
change the order of the buttons use: 
o Move Up – First select the item to move, and then click this button to 

move it up one line.  Adjust the dialog box on the screen so you can watch 
the item move on the toolbar as you click. 

o Move Down – First select the item to move, and then click this button to 
move it down one line.  Adjust the dialog box on the screen so you can 
watch the item move on the toolbar as you click. 

If you have a hard time with the hieroglyphics of icons or you can’t make them 
out, click these dropdown menus to try these options: 

• Text options – These include: 
o Show Text Labels – displays text labels below the buttons 
o Selective Text on Right – displays text labels to the right of the buttons 
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o No Text Labels – is the default.  Only the icon is displayed. 

 

• Icon options – These include: 

o Small Icons – decreases the size of the icons   

o Large Icons – increases the size of the icons   

• Close – Saves your changes to the toolbar. 

• Reset – Abandons the changes and resets the toolbar to its previous 
appearance.  

Zooming 
Sometimes it is nice to get a close-up view of a room in order to do some detail 
work, or to select a seam that is very small.  Other times you would like to get the 
entire layout on one screen.  Both of these can be accomplished through 
zooming.  Zooming changes the scale of the screen, without altering any of the 
work you have done. 

Click on the window you would like to zoom, either the room view or the stock 
view, first.  From the View menu select one of the Zoom options. 

Six kinds on zooming are supported by FloorRight™. 

• Actual Page Size is available only in the room view.  It displays your room in 
the size it would appear on the printed page. 

•  Zoom In gives you a closer look at your drawing. 

•  Zoom Out provides a bigger perspective. 
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•  Zoom To Height scales the screen so that the entire height of the 
diagram is visible. 

•  Zoom To Fit scales the screen so the entire drawing is shown.  This is 
especially useful if you have gotten lost by zooming and scrolling too much! 

•  Zoom Box lets you select a region of interest on your diagram, and fits 
that region onto the screen. 

Zoom Restore reverses a zooming action, restoring the window scale to its 
previous state. 

Zoom to Height 
Zoom to Height adjusts the scale of the current window to encompass the full 
height of the drawing, top to bottom, including a small margin.   

Click on the window you would like to zoom, either the room view or the stock 
view, first. 

To use Zoom to Height, select the View menu, and then select Zoom To 
Height.  Alternatively, you can click on the Zoom to Height button  on the 
tool bar. 

If you need to return to the previous scale, use Zoom Restore. 

Zoom to Fit 
Zoom to Fit adjusts the scale of the current window to encompass the entire 
drawing, both width and height, including a small margin.  This is especially 
useful if you have been doing a lot of zooming and are lost! 

Click on the window you would like to zoom, either the room view or the stock 
view, first. 

To use Zoom to Fit, select the View menu, and then choose Zoom To Fit.  
Alternatively, you can click on the Zoom to Fit button  on the tool bar. 

If you need to return to the previous scale, use Zoom Restore. 

Zoom Box 
Zoom Box allows you to draw a box around part of the display that is interesting 
to you.  It then scales the screen to the box that you have drawn. 

Click on the window you would like to zoom, either the room view or the stock 
view, first. 

To use Zoom Box, select the View menu and choose Zoom Box.  Alternatively, 
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you can click the Zoom Box button  on the tool bar. 

Then, position your mouse cursor where you would like one corner of the box.  
Press the left mouse button, and without releasing it, drag the cursor to the 
opposite corner of the box.  Release the button, and the screen will zoom in on 
the part of the screen you outlined. 

If you are not happy with the result, use Zoom Restore and try again. 

If the box you made has a different shape than the screen, the zoom will be 
made so that the entire box will fit without changing the way the rooms look. 

For example, selecting this tall, narrow box: 

  

results in this zoom: 
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Note that the window is centered on the area of interested, and the entire height 
of the box has been accommodated.  The zoom has not distorted the shapes of 
the rooms. 

Zoom In 
Zoom In reduces the scale of the current window by a factor of two, making 
everything look twice as large. 

Click on the window you would like to zoom, either the room view or the stock 
view, first. 

To use Zoom In, select the View menu, and then choose Zoom In.  
Alternatively, you can click on the Zoom In button  on the tool bar. 

If you need to return to the previous scale, you can either use Zoom Out or 
Zoom Restore. 

Zoom Out 
Zoom Out increases the scale of the current window by a factor of two, making 
everything look twice as small. 

Click on the window you would like to zoom, either the room view or the stock 
view, first. 

To use Zoom Out, select the View menu, and then choose Zoom Out.  
Alternatively, you can click on the Zoom Out button  on the tool bar. 

If you need to return to the previous scale, you can either use Zoom In or Zoom 
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Restore. 

Zoom Restore 
Zoom Restore returns the current screen (either the layout screen or the stock 
screen) to its previous scale. 

Click on the window you would like to zoom, either the room view or the stock 
view, first. 

Select the View menu and choose Zoom Restore to take this action. 

If you select Zoom Restore repeatedly, it switches between two different scales.  
It will not "undo" a sequence of zooms. 

Choosing a Font 
You can select a font to be used on the room view and the stock view.  The font 
selection only affects the current document. 

Select the Defaults menu option and choose Set Font. 

  

Select a desired font, font style, and size. The result of your selection is 
displayed in the sample text box. 

Setting Grid Attributes 
The room view grid helps you to create and align rooms in the room view.   
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The grid options include: 

• Grid spacing – The distance between the fine lines on the grid. 

• Major grid spacing – The distance between the thick lines on the grid. 

• Snapping distance – When grid snapping is turned on, this is the finest 
incremental change allowed when drawing a rectangle or a line. 

See Entering Lengths, p. 29, for more details on entering distances and 
lengths in FloorRight™. 

• Grid on – When checked, the grid is displayed in the room view.  You can 
also turn the grid on and off using the Grid button  on the tool bar. 

• Grid snapping – When selected, drawing lengths are rounded based on the 
snapping distance. 

Turning the Drawing Grid On and Off 
The drawing grid assists you in drawing rooms in the room view.  The 
background of the room view becomes a graph paper grid.  You can set the 
dimensions of the grid with the Edit Options dialog box. 

To turn the drawing grid on, click the Grid button  on the toolbar. 

To turn the drawing grid off, click the Grid button again. 

Free-Form Text 
You can add informative text to your room view by using the Text Mode button 
on the tool bar.    Click the button, and then click the location on the room view 
where you would like your text to appear.  This will bring up the Add Text dialog 
box. 

You can easily edit text you have entered either in select mode -  - double 
click on the text, or if you are in text mode - , click once on the text you wish to 
change.  The Edit Text dialog box will allow you to make changes. 
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You can move and resize the text from the select mode  by clicking on the 
text.  Click anywhere inside the text box to drag it to another position.  You can 
click-and-drag one of the corner dots to resize the text.  You can set the text to 
an exact point size in the Add Text dialog by double clicking on the displayed 
text. 

To delete free-form text, click on the Highlight button .  Then click on the text 
you wish to delete.  When the text is selected, it will turn the highlighted color.  
Press the Delete key or select Delete from the Edit menu to delete the text. 

Attach Text to Room 
At some time you may wish to create a note about a particular room.  Then, 
when you move the room in the room view, you would like the note to move with 
it.  To do this, attach the text to the room. 

1. Create the room and the text object you wish to attach. 

2. Select both the room and the text object. 

3. Select the Drawing menu or use the right click mouse button and choose 
Attach Text To Room. 

You can detach the text from the room later if you desire. 

Detach Text From Room 
If you wish to detach a text object from a room: 

1. Select the text object. 

2. Select the Drawing menu or right click the mouse and choose Detach Text 
From Room. 

You can attach text to that room again or to another room if you like. 
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Text for Printing 
You can add titles or other information to printouts from either of these menus: 

1. Select the Drawing menu and choose Add Text For Printing. 

2. From the Job Estimate dialog select the Job menu and choose Add Text 
For Printing.   

This will bring up the Add Text For Printing dialog box. 

 

Type any information you wish into the text box.  The text is printed at the bottom 
of the room view, seam view, stock view, and job estimate printouts, but it is not 
visible on the screen.  To review the text, open the dialog box again. 

For information on printing, see Printing, p. 117. 

Templates 
You may create a series of FloorRight  files that have many similar properties, 
layouts, and materials.  Templates come in handy so that you don't have to start 
from scratch with each file you create.  The following properties are saved in the 
template: 

• Material type 
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• Room layout style 

• Layout direction (NS or EW) 

• Material colors 

• Transition Materials 

• Boxed material information 

• Job Estimate Items  

• Minimum seam width allowed 

• Job estimate print formats  

• Job estimate header 

• Sales tax 

• Page settings for printouts 

• Maximum guillotine cut 

Save the file as you would usually do, then also save it as a template if you know 
you will need to create more files that are similar.  When you start your next file, 
set the template first and then start a new file.   

You cannot change the template after you open a new file.  The template must 
be set before selecting File New.  

The last saved template becomes the default template.  
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Creating Reports 
Creating a Report 

The Report Generator lets you create professional looking reports from your 
FloorRight file.  You can create three types of reports from the templates 
available: 

• Room View reports  

• Stock View reports 

• Job Estimate reports – complete or summarized 

FloorRight Commercial lets you completely customize your reports with the 
Design option.  

When you select Reports from the File menu you have the following choices: 

• Preview – To view the report before printing.  

• Print – To print the report directly. 

• Export – To export the report in various formats or to use in other programs. 

For each of these options, you first select one of the Report Templates 
subfolders, and then choose the appropriate template file, with the .lst extension.  

There are some limitations to reports from the File menu: 

• You can only select one report at a time, the Batch option is only available 
from the Job Estimate / Reports (see below). 

• You cannot Print, Preview, or Export any of the Job Estimate reports from 
the File menu.  You will get an error message. 

• To select a stock or cut list report you must be in the stock view or you will get 
an error message. 

The FloorRight Report Options dialog lets you select the appropriate output 
options including changing the printer and setting page ranges and number of 
copies to be printed.  The FloorRight data is automatically inserted into the report 
template when you press Start. 

The Job Estimate dialog, Reports menu gives you an additional option – 

• Batch – lets you select multiple templates for printing, previewing or 
exporting.  The current template being used is displayed in the top box of the 
FloorRight Report Options dialog.  Click the Start button to invoke each 
template report.  When a report is finished, close the report view and start the 
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next one from the Report Options dialog.  

Rules applying to the Batch command are:  

• You can print any type of reports from the Job Estimate / File / Report / 
Batch command, no matter what view is currently displayed. 

• You can only Print, Preview, and Export Job Estimate reports from the Job 
Estimate dialog.  The Batch command is the exception to this rule 

Cancel will stop the report creation and return you to the Job Estimate window. 

Report Templates 
Report templates are located in a folder of that name which was installed with 
your FloorRight™ system.  

• All report templates have the .lst extension. 

• A description of the report appears to the right of the file list. 

The two basic types of reports have different templates associated with them. 

Appropriate templates to choose from the File / Reports menu are those 
showing the Checklist, Rolls (Commercial version), Rooms or Stock.  Templates 
containing Job Estimate info should only be selected from the Job Estimate 
dialog – File / Reports menu.   

If you try to select any of the Job Estimate reports you will get the following error 
message: 

  

To select a stock or cut list report you must be in the stock view or you will get 
the following error message: 
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Only the Job Estimate / File / Reports / Batch option lets you select any 
template.  If you try to select a room or stock template from the Preview, Print, 
or Export commands from the Job Estimate dialog, you will get the following 
error message: 

  

Previewing Reports 
You can preview Room / Stock reports from the main menu using File / Reports 
/ Preview. 

To preview a Job Estimate, click the Reports button at the bottom of the Job 
Estimate dialog and select Preview. 

1. Select a report template  

2.  After selecting the appropriate template, click the Open button. 

3. Various options may be specified in the FloorRight Report Options dialog 

• The target printer may be changed. 

• You can specify a range of pages and the number of copies to be printed. 

4. Press Start to see the preview 

5. Thumbnail images of the report pages are available along the left side of the 
preview to allow easy access to individual pages.  If the thumbnails aren’t 
visible, move the cursor to the left side of the window. When it changes to a 
double arrow, move the window to the right (by clicking and dragging) and the 
thumbnail strip will appear. 

You can save or fax your report preview file for viewing with the Report Viewer 
that comes with your FloorRight installation.  These files will have the extension 
.LL. 

• To save a report preview click the Save as disk icon on the report toolbar. 

 

• To fax a report click the Send as fax icon on the report toolbar.   
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Your mail program will be launched with the preview file attached to a blank 
document.  The recipient of the fax must have a copy of the Report Viewer to 
see the preview report. 

The Report Viewer 
The Report Viewer is used to view Preview files (.LL extension).  The viewer is 
automatically installed with FloorRight (v5.0 / 2004 and above) 

A setup file for installing the viewer is located in the "Report Viewer" subdirectory 
of your FloorRight installation and in the "Report Viewer" directory on your 
FloorRight CD.  This may be freely redistributed to anyone who needs to view the 
report preview files. 

The FloorRight Report Viewer shortcut is added to the Start menu when 
installing FloorRight. 

Printing Reports 
Print Room / Stock reports from the main menu, File / Reports / Print. 

Print a Job Estimate by opening the Job Estimate dialog and select Reports / 
Print from the File menu. 

1. Select a report template. 

2.  Click the Open button. 

3. Various options may be specified in the FloorRight Report Options dialog 

• The target printer may be changed. 

• You can specify a range of pages and the number of copies to be printed. 

4. Press Start to print. 

Exporting Reports 
One of the great advantages to the Report Generator is the vast array of formats 
and settings available for exporting, so you can use FloorRight information in 
spreadsheets, databases, and other programs. 

After selecting your Report Template, click the Direct to… drop-down list in the 
FloorRight Report Options dialog. 
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Once you have selected a format you can adjust the settings by clicking the 

Properties icon . 

The formats include: 

• Printer – prints the report  

• Preview – shows preview  

• File – saves a file as .PRN for printing later.  

• HTML Format – saves the report as an HTML document that can be viewed 
in a web browser.  Images are saved as individual files.  

• Multi-Mime HTML Format – saves the report as a single HTML file that can be 
viewed in a web browser.  
o Images are embedded in the document so there is only one file.  
o Current Internet Explorer can view these files. 
o Current Mozilla browser CANNOT view these files.  
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• Adobe PDF Format – saves the report for viewing with Adobe Acrobat  

• Bitmap – saves the report as Windows Bitmap (bmp) images  
o One image is created for each page of the report  

• Metafile – saves in Windows Metafile format  
o One file is saved for each page of the report  

• JPEG-Picture – saves as a JPEG image  
o One image is saved for each page of the report  

• Multi-TIFF-Picture – saves a TIFF format image  
o All pages are saved in a single file  

• TIFF-Picture – saves TIFF format images  
o Each page is saved to a separate file  

• Rich Text Format (RTF) – saves in Rich Text Format which is suitable for 
reading in Word and other word processing programs  

• Text Format – saves just the text portions of the report  
o Generally only useful for reports with a grid (such as the job estimate)  

• Microsoft Excel Format – saves an Excel spreadsheet file  
o Graphical elements can optionally be included or excluded  

• XML Format – saves a standard XML format file  
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Buttons, Menus, and Dialog Boxes 
Buttons 
Toolbar Help 

You can customize and configure the FloorRight toolbars to suit your individual 
preference of the screen layout.   

 

Some buttons are only active under certain circumstances.  Buttons that are not 
on the following list are always active. 

Button Name When Available 

   East-to-west and north-
to-south lay direction 
buttons 

At least one room or 
border uses the material 
in the Room color 
window. 

  Show seam / stock 
button 

At least one room is 
drawn. 

  Lock room button Seam view is shown and 
a room is selected. 

   Horizontal and vertical 
seam flipping buttons 

Seam view is shown and 
a room is selected. 

  Close room button At least two walls of a 
non-rectangular room are 
drawn. 

  Cancel line draw button 
and delete side button 

A line drawing action is 
started. 

 

  Align points button A point on the edge or 
corner of each of two 
rooms is selected. 

 Position room button A point on the edge or 
corner of each of two 
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rooms is selected. 

  Join rooms button A point on the edge or 
corner of each of two 
rooms is selected. 

  Split room button Two points on different 
walls or corners of a room 
are selected. 

  Eliminate seam button A seam is selected 

    Layout options 1, 2, and 
3 

Drawing contains at least 
2 rooms of the same 
material and a seam in 
one of the rooms has 
been deleted. 

    Cut and Copy buttons One or more drawing 
elements are selected. 

  Paste button One or more drawing 
elements is cut or copied. 

   Undo button  After any action is taken. 

 Redo button After an Undo. 

 

Menus 
File Menu 

The File menu provides options for creating, opening, and saving estimate files, 
for printing displays, and for exiting the program. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

New Creates a new project. Always 

Open… Brings up the Open File 
dialog box so you can 
open a project. 

Always 
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Menu Option Function When Available 

Save Saves the file.  If you 
have not yet saved the 
current work to a file, the 
Save File As dialog box 
lets you specify where to 
save the project file. 

Always 

Save As… Brings up the Save File 
As dialog box so you can 
specify where to save the 
project file or change the 
file name 

Always 

Import  For importing AutoCAD, 
Bitmap, Scanner, and 
Leica Disto files 

Always – AutoCAD 
available in Commercial 
version only  

Export  Export a file in AutoCAD 
format - .dwg or .dxf 

Always, Commercial 
version only 

Set Template  Brings up a saved 
template and its 
associated properties 

Before starting a New file

Save File as 
Template  

Saves some of the 
drawing and layout 
properties and defaults in 
a template to apply to new 
files 

Always 

Set Factory 
Defaults  

Sets the default material 
types and their attributes 

Always 

Print Stock 
Sideways 

When checked, indicates 
that the stock print will be 
rotated 90° - saves paper 

Always 

Page Setup  Sets the scale and other 
options for the Room, 
Seam and Stock printouts 

Always 

Print Setup  Displays the Print Set-up 
dialog box so you can 
choose a printer and print 
options 

Always 
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Menu Option Function When Available 

Print  Displays a submenu for 
printing and previewing 
various parts of the 
project 

Always 

Reports  Displays submenu to 
Preview, Print, or Export, 
and with FloorRight 
Commercial, Design  

Always 

Design option in 
Commercial version only 

(List of file 
names) 

These are the four most 
recently used 
FloorRight™ files.  
Clicking on one opens it. 

Always 

Exit Exits the program, after 
prompting for save 

Always 

New Document 

  

A click of the New Document button on the toolbar closes your current 
document (prompting you to save it first, of course), and gives you a blank page 
to start your next FloorRight file.   

Open File 

  

This familiar icon displays the standard Windows Open dialog.  It looks in the 
directory you last used to save a file.  FloorRight data files are Files of type: *.flr.    

You can also open a file by selecting Open from the File menu.   
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Save File 

  

Use this button frequently to save your work.  You can also save your file by 
selecting Save from the File menu.   

To save a separate copy of a file use Save As, also found in the File menu. 

Set Template 
Templates are for creating many similar kinds of files.  To use a previously saved 
template, select Set Template from the File menu.  The Windows Open dialog 
box will display the templates you have saved.  Simply select the template and 
then start File New.   

Note that you cannot change the template after you have opened a new file; i.e. 
selecting File / New loads the new template you selected.   

Save File As Template 
To reuse some default settings, layout styles, and material colors in the next file 
you create, simply save your file as a template.  When you click on File and 
select Save File As Template, the Windows Save dialog box looks exactly like 
the regular File Save box, but the default file extension is .flt - for FloorRight  
Template.  Type your template file name, and you'll be ready to create the next 
file with similar properties.   

The last template saved becomes the default template. 

   Saving your file as a Template does not save the file itself, only some of its 
properties.  You still need to save your file using the File Save / Save As 
selections. 

Printing 
The Print selection in the File menu will display a submenu to let you print or 
preview various parts of your project: 

Menu Option Function When Available 

Print Rooms  Prints the room view, with 
or without seams. 

Always 
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Menu Option Function When Available 

Print Stock  Prints the stock view. Stock view must be open. 

Print Stock 
Cuts  

Prints the list of stock cuts 
from the stock view*. 

Stock view must be open   
Commercial version only 

Print Rolls  Prints allocated rolls from 
the stock view 

Stock view must be open   
Commercial version only 

Print Preview 
Rooms  

Provides a display of the 
room printout for review 
before printing. 

Always 

Print Preview 
Stock  

Provides a display of the 
stock printout for review 
before printing. 

Stock view must be open. 

Print Preview 
Rolls  

Provides a display of the 
roll allocation for review 
before printing. 

Stock view must be open   
Commercial version only 

 

* Print Stock Cuts is the same as Print Stock but without the stock diagram 
across the top.  

To print the job estimate, bring up the Job Estimate dialog box and select the 
File menu. 

You can print directly from any of the preview screens using the Print button. 

 

You can choose another printer or modify your printer settings by selecting the 
File menu and choosing Print Setup.  See the person on your site who is in 
charge of the computer system for help in setting up printers. 

You can print the stock view sideways to conserve paper by selecting the File 
menu and choosing Print Stock Sideways.  This option is the default when you 
install FloorRight™. 

Your printouts can be further configured with regard to color, size and scale in 
different views, by using the Page Setup selection in the File menu. 

Page Breaks 
Page Breaks for the printout are set from the View menu and from the File 
menu in the Page Settings dialog box.  To see the page breaks, the Room / 
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Seam printouts must not be set to Fit to Page.  

 

They appear as a dotted line in the Room / Seam View. 

You can move the page breaks relative to the drawing.  The Move Page Breaks 
option is available from the View menu and the Display context menu.  Simply 
click the arrow keys until the page breaks are positioned as you like them. 

Edit Menu 
The Edit menu provides a variety of options for editing the room layout display.   

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

Undo  Reverses the last action 
you took. 

After any action has been 
taken. 

Redo  Reinstates an action that 
you have undone. 

After using Undo. 

Cut  Deletes an object, but 
saves it so it can be put 
somewhere else. 

A room, stairway, or text 
has been selected. 
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Menu Option Function When Available 

Copy  Does not delete the 
object, but saves is so it 
can be put somewhere 
else. 

A room, stairway, or text 
has been selected. 

Paste  Puts whatever has been 
cut or copied onto the 
screen 

A room, stairway, or text 
has been cut or copied. 

Delete  Deletes whatever is 
selected, without saving it.

A room, stairway, or text 
has been selected. 

Bring To Front  Makes sure the selected 
room is not obscured by 
any other room. 

A room or stairway has 
been selected. 

Send To Back  Places the selected room 
behind any rooms that are 
hidden behind it. 

A room or stairway has 
been selected. 

Pages  Displays submenu to add, 
insert, delete or rename a 
page. 

Always - Commercial 
version only 

Room 
Properties  

Brings up the Room 
Properties dialog box for 
editing room material 
properties, layout 
properties or borders. 

A room or stairway has 
been selected. 

 

Wall 
Properties  

Brings up the Wall 
Properties dialog to 
adjust the length, direction 
and curvature of a wall. 

A side of a room has been 
selected. 

Transition 
Properties  

Brings up the Transition 
Properties dialog to 
adjust the size, 
appearance, and material 
of the transition 

A transition or door has 
been selected 

Stairs  Edits stairs properties Stairs have been selected. 

AutoCAD 
Properties  

Displays the AutoCAD 
Properties dialog box 
containing levels, layout, 
scaling, and snap options. 

An AutoCAD file has been 
imported; Commercial 
version only 
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Menu Option Function When Available 

Floor Plan 
Bitmap 
Properties  

Displays the Bitmap 
Properties dialog box 
containing overly and 
scaling choices. 

When a Bitmap file or 
scanned image has been 
imported 

Tile  Brings up the Tile editing 
cursor to allow placing 
and moving tiles. 

Always 

Material List  Displays details for all of 
the materials you have 
defined and allows you to 
edit them. 

Always 

 

Undo (CTRL+Z) 
If you make a mistake, FloorRight™ allows you to quickly "undo" your action.  
Simply click the Undo button  on the toolbar or select the Edit menu, and 
choose Undo.  The Edit menu will indicate the action you are able to undo.  If 
there are no actions to undo, the menu option will be grayed, and the words 
"can’t undo" will appear on the Edit menu. 

Pressing the CTRL key and the Z key at the same time will also undo your last 
action. 

You can undo as many actions as you need, depending on the number of undos 
you set under Options in the Defaults menu. 

If you need to reinstate an action, use Redo (CTRL+Y). 

Redo (CTRL+Y) 
Redo reinstates actions that you have undone.  Simply click the Redo button  
on the toolbar or select the Edit menu, and choose Redo.  The Edit menu will 
indicate the action you are able to redo.  If there are no actions to redo, the menu 
option will be grayed, and the words "can’t redo" will appear on the Edit menu. 

Pressing the CTRL key and the Y key at the same time will also redo your last 
action. 

You can redo as many actions as you have undone.  Performing a new action 
clears the list of undone actions. 

Selecting More Than One Object 
Some actions require that you select more than one object at the same time.  For 
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example, 

• To align or position rooms you must select two points. 

• To attach text to a room you must select a text object and a room. 

To select more than one object 

1. Click on the Highlight button  on the tool bar. 

2. Hold down the CTRL or SHIFT key as you click on the objects you want to 
select. 

3. If you click on the wrong object while holding down the CTRL key, click on it 
again and it will become unselected. 

If all of the objects you wish to select fall within a rectangular region, you can 
select them by 

1. Clicking on the Highlight button  on the tool bar. 

2. Drawing a rectangle around all of the objects by clicking and dragging. 

Cut, Copy, and Paste 
Cutting an object removes it from the screen, but tucks it away in computer 
memory.  Later, you can paste the object back onto the current room view, or into 
a different FloorRight™ file.  You can paste the object several times to create 
several identical objects. 

Copying an object is essentially the same as cutting an object, except that it is 
not deleted from the screen. 

You can copy information from the Job Estimate dialog box, and paste it into 
other software programs like spreadsheets and word processors.  

To Cut an object you must first select the object, then use one of the methods 
listed below: 

• Click the Cut button  on the toolbar. 

•  Select the Edit menu and choose Cut. 

• Use the shortcut key – press CTRL and X at the same time. 

To Copy an object you must first select the object, then use one of the methods 
listed below: 

• Click the Copy button  on the toolbar. 

•  Select the Edit menu and choose Copy. 
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• Use the shortcut key – press CTRL and C at the same time. 

To Paste an object you must have previously cut or copied an object, then use 
one of the following methods: 

• Click the Paste button  on the toolbar. 

• Select the Edit menu and choose Paste. 

• Use the shortcut key – press CTRL and V at the same time. 

Click and drag the object where you would like it to be. 

Delete 
This menu option deletes the currently selected: 

• Room  • Stairs 

• Point • Hole  

• Wall • Window 

• Door • Text 

• Seam  

 

With any of the above selected, you can also use the Delete key on the 
keyboard. 

Another way to delete a seam is to select the seam and click the Delete Seam 
button  on the toolbar.  See Deleting a Seam, p. 74, for more information. 

Bring to Front 
Bringing a room to the front of the room view makes it easier to edit. 

1. Click the Highlight button  on the toolbar. 

2. Click on the room you wish to bring to the front of the display.  If you cannot 
see any of the room, try using Send To Back on a room that might be 
covering it up. 

3. Select the Edit menu or right click the mouse and choose Bring To Front. 

Send to Back 
Sending a room to the back of the room view reveals rooms that are hidden 
behind it. 
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1. Click the Highlight button  on the toolbar. 

2. Click on the room you wish to send to the back of the display. 

3. Select the Edit menu or right click the mouse and choose Send To Back. 

See Bring to Front, p. 123, if you want to view the room that is hidden behind 
some other room. 

Defaults Menu 
The Defaults menu allows you to create and edit information that stays the same 
for all estimation projects. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

Material Type  Allows you to create and edit 
material types. 

Always 

Room Layout 
Styles  

Allows you to create and edit 
room layout styles. 

Always 

Job Estimate 
Items  

Allows you to specify items for 
the estimate that are associated 
with a particular material, e.g. 
pad, labor. 

Always 

Transition 
Materials  

Allows you to define materials 
used in room transitions. 

Always 

Sales Tax  Allows you to create and edit 
sales tax, or value added tax, 
information. 

Always 

Set Font  Allows you to choose a font for 
the room view and the stock 
view. 

Always 

Company Info  Allows you to create and edit 
information about your company. 

Always 

Set Splash 
Screen  

 

Allows you to insert a splash 
screen when you open 
FloorRight™ with your bit map. 

Always 
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Menu Option Function When Available 

Clear Splash 
Screen  

Eliminates the splash screen the 
next time you open FloorRight™ 

Always 

Options  Lets you set various general, 
drawing, layout and creation 
default values. 

Always 

Room Layout Styles 
FloorRight™ takes into consideration the way a room is used when it lays out 
carpet, just as a professional carpet layer would.  You can take advantage of this 
feature by indicating the style of each room in the layout. 

Each style specifies the number and type of seams that are allowed in that sort of 
room.  You can also indicate whether the recommended number of seams can 
be exceeded if necessary. 

The FloorRight™ system is delivered with several pre-set styles, including 
closets, hallways, stairs, and several more generic styles.  These styles can be 
modified to better fit your requirements, and more styles can be added through 
the Room Layout Styles dialog box. To access this dialog box, select the 
Defaults menu and select Room Layout Styles. 

To apply a style to a particular room, first select the room.  Choose the type of 
the room from the room type list box. 

 

Set Splash Screen 
This feature shows your customized bit map when you open FloorRight .  You 
can display your company name and logo, and you may want to reference a 
favorite client on the screen.  You can design several screens in any drawing 
program or word processor that supports bit map files (.bmp extension). 
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It's easy to change the splash screen for a special job: 

Select Set Splash Screen from the Defaults menu.  The standard Windows 
Open dialog will appear.   

 

Find the folder and the bitmap you want to use the next time you open the 
FloorRight  program.  When you click Open you will return to the FloorRight  
screen as if nothing has happened.  Exit the program and restart it to see the 
splash screen you selected.  It is just as easy to clear the splash screen.  

Clear Splash Screen 
If you get tired of the Splash Screen that appears when you start the Floor 
Right  program, simply select Clear Splash Screen from the Defaults menu. 

Job Menu 
The Job menu allows you to create and edit information that is specific to this 
particular job. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

Job Estimate  Allows you to view and edit the 
job estimate. 

Always 

Edit Header  Lets you configure the Job 
Estimate Header with your 
company logo and customer 
information. 

Always 
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Menu Option Function When Available 

Edit Customer 
Information  

Allows you to enter information 
about the customer. 

Always 

Count Rooms Provides information about the 
number of rooms and the 
material that is to be used for 
their floors. 

Always 

 

Group Room 
Pieces  

When checked, displays stock 
cuts from the same room 
together. 

Always – 
Professional 
version only. 

Stock Grouping  Brings up a dialog with check 
box options for grouping stock 
pieces by room or by page. 

Always - 
Commercial 
version only 

Base Stock on 
Page  

When checked, the job estimate, 
stock view and status line 
display info only for the current 
page. 

Always, 
Commercial 
version only 

Open Job 
Checklist 
Template  

Allows you to view and edit a job 
checklist text file in Microsoft 
Word. 

Always 

Print Job 
Checklist 
Template  

Provides a printout of your Job 
Checklist. 

Always 

 

 

Job Checklist 
You may have a standard set of tasks to check off for your floor covering job.  
The checklist can be viewed and edited while you are completing your job 
estimate.  You can print the checklist right from FloorRight's Job menu.  

Opening the Job Checklist Template 
Several standard text formats are supported, including rich text format (.rtf), MS 
Word files (.doc) and simple text (.txt).  You can open your word processor 
without leaving FloorRight .  This is handy for changing your checklist while 
viewing the job estimate.   

From the Job menu, click Open Job Checklist Template.  From the standard 
Windows Open dialog select your checklist file.  After making any changes you 
can print the checklist along with your Job Estimate. 
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Printing the Job Checklist Template 
A Job Checklist can be printed right from the Job menu.  Simply click on Print 
Job Checklist Template and the Print dialog box will open the selected 
checklist file for printing. 

Drawing Menu 
The Drawing menu provides a host of tools for adjusting and refining your layout. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

Flip Drawing 
Vertically 

Flips the entire room 
view top-to-bottom. 

When there is a room in 
the drawing 

Flip Drawing 
Horizontally 

Flips the entire room 
view left-to-right 

When there is a room in 
the drawing 

Flip Selected 
Rooms 
Vertically 

Flips all selected rooms 
top-to-bottom 

When one or more rooms 
are selected 

Flip Selected 
Rooms 
Horizontally 

Flips all selected rooms 
left-to-right 

One or more rooms are 
selected. 

Rotate Room  Rotates a room by 
changing the direction of 
a wall. 

A wall of the room is 
selected 

Align Points  Helps you to set two 
rooms exactly next to 
each other. 

The corners of two rooms 
must be selected.  

Position Room  Helps you to set two 
rooms a relative distance 
from one another. 

The corners of two rooms 
must be selected.  

Reverse Line 
Direction  

Changes the direction of 
a line. 

A line has been selected. 

Join Rooms  Brings two rooms 
together to make them 
one room. 

A point on both rooms to 
be joined is selected. 
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Menu Option Function When Available 

Split Rooms  One room is cut through 
2 points to make 2 
rooms. 

A point on each of two 
walls is selected. 

Expand 
Rooms  

Expands rooms by the 
specified amount in north 
/ south and east / west 
directions. 

One or more rooms are 
selected. 

Add Text For 
Printing  

Creates a comment to be 
printed with the room 
view, the stock view, and 
the Job Estimate. 

Always 

Attach Text To 
Room  

Associates text with a 
room, so they can be 
moved together. 

Both a room and a text 
object have been selected 

Detach Text 
From Room  

Disconnects a text object 
from a room. 

Text that is attached to a 
room has been selected. 

Reversing Line Direction 
To change the direction of a line: 

1. Select a Line whose direction you wish to change. 

2. Now use one of these methods: 

• Select the Drawing menu and choose Reverse Line Direction 

• Press CTRL and R at the same time 

• Right click the mouse and select Reverse Line Direction from the Wall 
context menu. 

When you select a line, it appears as an arrow.  Changing the length of the line 

with the Line Length text box  causes the arrowhead to move, 
keeping the tail end of the arrow where it was.  If the line is part of a room, the 
direction of the line will affect the shape of the room when the line’s length is 
changed. 

 129



 
    

The pictures above show a room in its original state, the result of changing the 
length of the north side when the arrow is pointing east, and the result of 
changing the length of the north side when the arrow is pointing west. 

Joining Rooms 
Two rooms can be joined into a single room. 

1. Select a point in the first room 

2. Hold the Control key and select a point in the second room 

3. Select Join Rooms from the Drawing menu or click on the Join Rooms 
button  in the Misc2 toolbar. 

The second room selected will be moved to the first room so that the points 
merge and the two rooms become one with the following provisos: 

• The two rooms must not overlap. 

• The two rooms must join such that they touch on at least one side or part of a 
side, i.e. rooms cannot be joined at only a single point.  So circular rooms and 
curved sides cannot be joined. 

•  If one or both of your joined rooms contains overlaid (pattern) tiles, the 
overlain tiles will be lost.  A warning dialog lets you reconsider this action.   

The new room gets its properties from the first room selected. 

Splitting Rooms 
Split a room into two rooms by cutting through two points on two walls. 

1. Select the first split point 

2. Hold the control key and select the second split point 

3. Select Split Rooms from the Drawing menu or click the Split Rooms button 
 in the Misc2 Toolbar. 

The room will be split into two new rooms with the following provisos: 
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• An imaginary line between the two points must not cross another wall unless 
the crossed wall is a hole (see the L shaped room below). 

• An imaginary line between the two points must not extend outside the room. 

• Points for splitting must not lie on a hole (if one of your selected points is the 
corner of a hole the Split Rooms button will not be lit ).  However, the 
imaginary line connecting the points may go through a hole.  In this case, the 
hole is copied for both rooms as in the example below. 
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  If one or both of your joined rooms contains overlaid (pattern) tiles, the 
overlain tiles will be lost.  A warning dialog will let you reconsider this action. 

Layout Menu 
The Layout menu allows you to make modifications and experiment with the 
computer-generated layout. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

View Seam / 
Stock Layout  

 

Toggles the display 
between the Room view 
and the Seam / Stock 
view. 

 When a room is in the 
drawing. 

Lay Material E-W  Sets the default direction 
of the pile to east-to-
west. 

When the selected 
material listed in the 
Room color window is 
used in some rooms. 

Lay Material N-S  Sets the default direction 
of the pile to north-to-
south 

When the selected 
material listed in the 
Room color window is 
used in some rooms. 

Use Global 
Pattern Start  

Uses the global pattern 
start for this room’s 
layout 

A room of patterned 
material must be 
selected  

Use Any Pattern 
Start  

Exempts this room from 
the global pattern start 

A room of patterned 
material must be 
selected  
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Menu Option Function When Available 

Center Pattern 
Between Two 
Points  

Allows you to center the 
pattern start between two 
points. 

Two points in the same 
room containing 
patterned material must 
be selected.  

Position Pattern 
Relative To A 
Point  

Allows you to set the 
pattern start any distance 
from a corner of the 
room. 

The corner of a room of 
patterned material must 
be selected.  

Layout 1  Displays the original 
layout, after a seam has 
been deleted. 

Drawing contains at 
least 2 rooms of the 
same material and a 
seam in one of them is 
deleted. 

Layout 2  Calculates "What-if" 
option 2. 

Drawing contains at 
least 2 rooms of the 
same material and a 
seam in one of them is 
deleted. 

Layout 3  Calculates "What-if" 
option 3. 

Drawing contains at 
least 2 rooms of the 
same material and a 
seam in one of them is 
deleted. 

Eliminate Seams  Deletes a selected seam. A seam must be 
selected. 

Convert to User 
Seam  

Changes an 
automatically placed 
seam to a user seam 
that can then be moved. 

An automatically placed 
seam in any room 
except a stairs is 
selected. 

Set Roll Lengths  Lets you specify roll 
lengths for each material 
for the stock view. 

When a room is drawn 
and after you first 
enable the stock view. 
Commercial version 
only. 
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Menu Option Function When Available 

Show Roll 
Allocation  

Stock view displays roll 
allocation. 

When a room is drawn 
and after you first 
enable the stock view. 
Commercial version 
only. 

Reset Layout  Restores the seams you 
have deleted, and 
recalculates the layout. 

At least one room must 
be defined. 

 

View Menu 
The View menu provides tools for refining the appearance of the layout window 
and the stock window. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Note that zooming affects the active window.  You can make the room view or 
the stock view active by clicking in it before zooming. 

Menu Option Function When Available 

Actual Page 
Size  

Displays the diagram in the exact 
scale of the printout. 

Room View, Fit 
to page 
deselected 

Zoom Restore  Returns the window to the previous 
scale. 

Always 

Zoom Box  Zooms to a defined portion of the 
screen. 

Always 

Zoom To 
Height  

Scales the height of the window to 
include the full height of the 
diagram. 

Always 

Zoom To Fit  Scales the window to include the 
entire diagram. 

Always 

Zoom In  Scales the window so that rooms 
appear twice as large. 

Always 

Zoom Out  Scales the window so that rooms 
appear half as large. 

Always 
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Menu Option Function When Available 

Move Page 
Breaks  

Displays a dialog to move the page 
grid up, down, left and right. 

At least one room 
has been drawn 
and the page 
settings are not 
scaled to Fit to 
page. 

Show Page 
Breaks  

Displays the page breaks in the 
printout as dotted lines. 

Room & Seam 
Views; Fit to 
page deselected 

Show Room 
Pattern  

Displays the pattern repeat for 
patterned material in the room 
view. 

Always 

Show Stock 
Pattern  

Displays the pattern repeat for 
patterned material in the stock 
view. 

Always 

Toolbars  Displays a list of toolbars that are 
checked if they are displayed. 

Always 

Legend  Displays a window containing all 
materials used in the document. 

Always 

Tool Tips  When checked, definitions of 
toolbar buttons appear when the 
mouse cursor rests on them. 

Always 

Actual Page Size 
This scale is only available for the room view.  This is the scale you need to see 
the exact size of your layout as it appears on your printout. 

If you are in the split window displaying the room and stock views, click in the 
room view window, since Actual Page Size is not an option in the stock view.  
Also check the Page Settings dialog box from the View menu or click the Page 
Setup button  on the tool bar. From the Page Settings dialog box, deselect 
the Fit to Page option - make sure this option is not checked.  Now you can take 
advantage of the Actual Page Size view. 

Click the View menu and select Actual Page Size. 

If you need to return to the previous scale, use Zoom Restore. 

See Zooming, p. 98, for other available zoom features. 
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Help Menu 
The Help menu allows you to get help on FloorRight™. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available

Help Topics Invokes this help facility. Always 

License Info  Displays info about your 
type of FloorRight license 
and serial number or trial 
license. 

Always 

About FloorRight Provides information on the 
version of FloorRight™ you 
are running. 

Always 

 

License Info 
The License Info… option under the Help menu displays the type of license and 
its serial number.   

If you have a WIBU-key connected locally to your computer, then a dialog box 
similar to the following will appear 

 

To display more detailed information about your hardware key click the Search 
button.   

If you have difficulty with your WIBU security key, please contact your distributor. 
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Configuring Your License 
To view your license configuration, first select License Info from the Help menu.  

If FloorRight doesn't recognize your hardware key or to display more detailed 
information about your hardware key click the Search button.  FloorRight scans 
your computer for all FloorRight hardware keys connected to your computer and 
displays detailed information about any keys it recognizes. 

 

Custom Search List – use this button to expand your license search to servers 
on your network. 
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License Server Search List 

  

This dialog box allows you to add, delete or move names or IP addresses in the 
custom search list. 

To add a name or IP address 

1. Click in the lower edit box and enter a name or IP address 

2. Click on the Add button 

To delete a name or IP address 

1. Select the name or IP address that you want to delete 

2. Click on the Delete button 

You can move names or IP addresses around by selecting one and clicking the 

Up and Down arrows to the right of the list window.   

Click OK to accept your changes and exit or click Cancel to abandon any 
changes that you’ve made and exit the dialog. 
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Context Menus 
Context menus are invoked by right clicking the mouse.  The menu displayed 
depends on the where the arrow cursor is located in the window when you right 
click.   

The table below lists the various context menus displayed for the corresponding 
cursor location. 

Context Menu Cursor Location / Selection 

Room Edit Menu  Room 

Multiple Rooms / Stairs Menu  Select rooms and stairs then position 
cursor over one of them. 

Stairs Menu  Stairs 

Wall Menu  Wall 

Seam Menu  Seam 

Transitions Menu  Transition 

Room View Display Menu  A blank area of the room view 
window, outside of the drawing 

Stock View Display Menu  Any area in the Stock view window 

Room Context Menu 
This menu presents several selections for adjusting the layout and positioning 
individual rooms.  To access this menu select a room or group of rooms and click 
the right mouse button.   

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

Room Properties  Invokes the Room 
Properties dialog. 

A single room is 
selected 

Cut  Removes a room from the 
drawing to Paste it in 
another location 

One or more 
rooms selected 

Copy  Makes a copy of the 
room(s) for pasting 

One or more 
rooms selected 

Delete  Deletes the selected 
room(s) 

One or more 
rooms selected 
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Menu Option Function When Available 

Bring to Front  If rooms are overlaid, puts 
the selected room(s) on 
top 

One or more 
rooms selected 

Send to Back  If rooms are overlaid, puts 
the selected room(s) 
underneath  

One or more 
rooms selected 

Lay Room  Displays a submenu of 
choices for the lay 
direction of the selected 
room(s)  

One or more 
rooms selected 

Use Global Pattern 
Start  

Uses the global pattern 
start for this room’s layout 

One or more 
patterned material 
rooms selected 

Use Any Pattern 
Start  

Exempts this room from 
the global pattern start. 

One or more 
patterned material 
rooms selected 

Flip seams 
Horizontally  

Reflects the seams from 
left to right. 

 

In the Seam view 
one or more 
room(s) selected 

Flip seams 
Vertically  

Reflects the seams from 
top to bottom 

 

In the Seam view 
one or more 
room(s) selected 

Lock Room  Locks the room  In the Seam view 
one or more 
room(s) selected. 

Flip Room 
Horizontally 

Flips the entire room left-
to-right. User inserted 
seams are also flipped 

One or more 
rooms selected 

Flip Room Vertically Flips the entire room top-
to-bottom.  User inserted 
seams are also flipped 

One or more 
rooms selected 

Expand Room(s)  Expands the room(s) by a 
margin of inches on 
north/south, east/west or 
all sides.  

One or more 
rooms selected, 
except curved 
rooms and stairs 
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Stairs Context Menu 
The Stairs context menu gives you all the possible adjustments you can make to 
an existing stairs.   

To display this menu, move the cursor over the stairs and right click the mouse.  
You now have the following options: 

Menu Option Function When Available 

Room Properties  Invokes the Room 
Properties dialog 

A single stairs is 
selected 

Edit Stairs  Invokes the Edit Stairs 
dialog 

A single stairs is 
selected 

Cut  Removes rooms / stairs 
from the drawing to Paste 
in another location 

One or more 
rooms / stairs 
selected 

Copy  Makes a copy of the 
rooms / stairs for pasting 

One or more 
rooms / stairs 
selected 

Delete  Deletes the selected 
rooms / stairs 

One or more 
rooms / stairs 
selected 

Bring to Front  If rooms are overlaid, puts 
the selected rooms / stairs 
on top 

One or more 
rooms / stairs 
selected 

Send to Back  If rooms are overlaid, puts 
the selected rooms / stairs 
underneath  

One or more 
rooms / stairs 
selected 

Lay Room  Displays a submenu of 
choices for the lay 
direction of the selected 
rooms/stairs  

One or more 
rooms / stairs 
selected 

Use Global Pattern 
Start  

Uses the global pattern 
start for this stairs’ layout 

One or more 
patterned material 
rooms / stairs 
selected 

Use Any Pattern 
Start  

Exempts this stairs from 
the global pattern start. 

One or more 
patterned material 
rooms / stairs 
selected 
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Menu Option Function When Available 

Flip seams 
Horizontally  

Reflects the seams from 
left to right. 

In the Seam view 
one or more 
rooms / stairs 
selected 

Flip seams 
Vertically  

Reflects the seams from 
top to bottom 

In the Seam view 
one or more 
rooms / stairs 
selected 

Lock Room  Locks the room / stairs  In the Seam view 
one or more 
rooms / stairs 
selected 

 

Wall Context Menu 
The Wall context menu gives you all the possible adjustments you can make to 
an existing wall.   

To display this menu, position the cursor on the wall and right click the mouse.  
You now have the following options: 

Menu Option Function When Available 

Wall Properties  Invokes the Wall 
Properties dialog 

A single wall is 
selected 

Reverse Line 
Direction  

To reverse the direction of 
the selected wall. 

A single wall is 
selected 

Lay Room to Side  To lay material from a 
diagonal wall.  Seams will 
go parallel and 
perpendicular to the wall. 

A single wall is 
selected 

Rotate Room  Rotates a room about a 
corner. 

A single wall is 
selected 

 

Seam Context Menu 
To display the Seam context menu, select a seam and right click the mouse. 

The popup menu gives you the following choices: 
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Menu Option Function When Available 

Eliminate seam  Deletes a seam from the 
drawing. 

A seam is selected. 

Convert to User 
Seam  

Changes the selected 
FloorRight created seam to 
a user seam. 

An automatically 
created seam (except 
in stairs) is selected. 

  

 

Transition Context Menu 
To display the Transition context menu, select a transition and right click the 
mouse. 

The popup menu gives you the following choices: 

Menu Option Function When Available 

Transition 
Properties  

Invokes the Transition 
Properties dialog. 

A Transition is 
selected. 

Delete Transition Deletes the selected door 
or transition. 

A Transition is 
selected. 

 

Room View Context Menu 
This menu provides tools for refining the appearance and layout of the drawing.  
To access this menu, position the cursor over a blank space next to the drawing 
and click the right mouse button. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

Paste  Inserts a previously 
cut item into the 
drawing  

One or more rooms or 
stairs cut or copied 

Flip Drawing Vertically Flips the entire room 
view top-to-bottom. 

When there is a room 
in the drawing 

Flip Drawing 
Horizontally 

Flips the entire room 
view left-to-right 

When there is a room 
in the drawing 
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Menu Option Function When Available 

Lay Material E-W  Sets the default direction 
of the pile to east-to-
west. 

The material listed in 
the Room color window 
is used in at least one 
room 

Lay Material N-S  Sets the default direction 
of the pile to north-to-
south. 

The material listed in 
the Room color window 
is used in at least one 
room. 

Move Page Breaks Lets you move the page 
break grid relative to the 
drawing. 

At least one room has 
been drawn and the 
page settings are not 
scaled to Fit to page 

Show Page Breaks  Displays the page 
breaks as dotted lines. 

Room & Seam Views, 
Fit to page 
deselected. 

Show Room Pattern  Displays the pattern 
repeat for patterned 
material in the seam 
view. 

Always 

 

Stock View Context Menu 
This menu displays options pertaining to the layout and display of the stock.  To 
access this menu, position the cursor over any space in the stock window and 
click the right mouse button. 

When a menu item is gray in color, it is not available.  This table lists the menu 
options, their function, and when they are available. 

Menu Option Function When Available 

Stock Grouping  Lets you group pieces 
in the same room or 
the same page 
together in the stock 
layout. 

Always, Commercial 
version only. 

Group Room Pieces  Keeps the pieces of a 
room together in the 
stock layout. 

Always, Professional 
version only 
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Menu Option Function When Available 

Base Stock on Page  Displays Stock, Job 
Estimate and status 
line info only for the 
current page in the 
Room View. 

Always, Commercial 
version only. 

Show Stock Pattern  Displays the pattern 
repeat for patterned 
material in the stock 
view. 

Always 

Set Roll Lengths  Lets you specify the 
lengths of rolls, the dye 
lots, and guillotine cut 
gap for each material. 

Always, Commercial 
version only. 

Show Roll Allocation  A check box for 
displaying Roll 
Allocations in the 
Stock View 

Always, Commercial 
version only. 

 

Group Room Pieces 

For large jobs, it may be necessary to keep stock cuts from the same room 
together.  This feature ensures that stock pieces from the same room are 
grouped together in the layout. 

1. If you’re not in the Seam / Stock view, click the  on the toolbar. 

2. Right click anywhere in the Stock view to display the Stock View context 
menu. 

3. Click the Group Room Pieces selection.  When checked, pieces from the 
same room will placed together on the stock roll.  When unchecked, the 
layout changes to the most efficient use of material. 

Dialog Boxes 
Add New Material Dialog Box 

The Add New Material dialog box can be found by clicking on the color and 
material menu in the upper-left of the window. 
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Use the Add New Material dialog box to couple a color with a material type, 
resulting in a new material.  Thereafter, all of the rooms with that color will share 
the same material. 

  

Here are the basic steps: 

1. Select a color. 

2. Select a material type. 

3. Click on the Add button, then click OK if you are finished adding materials. 

Basic Colors 
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This is a palette of colors to choose for your material. Click on the one you wish 
to associate with the material you are creating. 

The More Colors… button invokes the Custom Colors dialog. 

Create Custom Colors 

  

Use this tool if you are not satisfied with the palette of basic colors.  When 
selecting the color for a material, remember that it is not necessary to match the 
color of the material with the actual dye.  All that is important is that the color can 
be distinguished from other materials you have defined. 

• Select anywhere on the rainbow display to choose a color. 

• Clicking in the thin rectangle on the right lets you make the color darker or 
lighter. 

• The rectangle labeled Color/Solid displays the color you are creating.  If your 
display is set to 256 colors, the Color half of the rectangle will often display a 
pattern, while the Solid half displays a solid color.  This shows how the 
computer is attempting to approximate the color you have selected by mixing 
different bits of the "pure" colors it has available. 

• Hue, Sat, and Lum allow you to mix these three attributes to obtain any color 
you would like.  This is an alternative to the Red, Green, Blue scheme for 
defining colors. 

o Hue is a circular scale, 0 to 239 through the spectrum. 

o Saturation indicates the depth of the color.  The larger the number, the 
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deeper the hue. 

o Luminescence indicates the brightness of the color. 

• Red, Green, and Blue allow you to mix amounts of these three basic hues to 
obtain any color you would like.  This is an alternative to the Hue, Saturation 
and Luminescence scheme for defining colors. 

• The Create a Custom Color button saves this color in the Custom Colors 
palette for later use. 

Color/Solid 
If your computer monitor is set to 256 colors, then many colors are approximated, 
or “dithered”.  This can make the text difficult to read. 

  

This portion of the New Material dialog box allows you to choose between the 
approximation of a color and the solid color that is closest to it.  Double-click the 
half of the rectangle you wish to use. 

If you do not choose either color or solid, the color side will be used. 

If your computer monitor is set to High Color or True Color, more colors are 
available so the two halves of the rectangle will appear the same. 

Custom Colors 

  

This is a palette of colors you have created with Create Custom Colors  

Click on the one you wish to associate with the material you are creating. 
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Select a Material Type 

  

• Choose the material type from the Material drop down menu. 

• If the material is patterned, check and edit the pattern Length, Width, and 
Drop boxes. 

• Click the Add or OK button: 
o Add creates a new material, but does not close the dialog box.  This is 

useful if you want to create more than one material.  Select another color 
for your next material.   

o OK accepts the new material and closes the dialog box.   
o Cancel closes the dialog box without doing anything and will not add any 

new materials you have created in this session. 

Add Text Dialog Box 
You can add free-form text to your diagram by typing any information you wish 
into the Add Text dialog box.   
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The usual Windows style selection of fonts and font attributes is available in the 
text box.  These settings are dependent on the font selected for the layout 
window. 

Clicking OK accepts the text.  Clicking Cancel exits the dialog box without 
making changes. 

Center Pattern Between Two Points 
Centering a carpet between two points removes the room from the Global 
Pattern Start and allows you to set a particular pattern start for the room. 

First, select the two end-points of the wall between which the pattern will be 
centered. 

Click both points while holding the SHIFT key, and then click the Layout menu.  
Choose Center Pattern Between Two Points. This will bring up the Center 
Pattern dialog box. 

  

You can center the pattern horizontally, vertically, or both.   
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Select whether you are defining the Pattern center or the Pattern top left for the 
pattern start, and click the appropriate radio button in the Horizontal and 
Vertical boxes. 

Count Rooms Display 
The Count Rooms Display gives a quick accounting of the material types you are 
using, and the number of rooms of each type. 

 

To access this display, select the Job menu and choose Count Rooms.  This is 
an information display only; nothing in it can be edited.  To make changes to the 
Style / Name or the Color / Description for a material type, use the New Material 
- Detailed dialog box. 

Disto Data Dialog Box 
The Disto Data dialog contains a window for display and editing of the data, a 
room display window, a group of radio buttons for choosing the room closing 
method, and the buttons for final action before closing the dialog box. 

Disto data is arranged in a tree structure just like files in the Windows Explorer, 
or the table of contents of this help system.  Sites contain rooms containing a list 
of wall measurements.  
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 Click this button to open an entry, or a double click on the entry name or 
symbol.   

 Click this button to hide all subentries of the clicked entry. 

  Click to toggle the checkmark.  If the box is not checked, the 
entry and its subentries will not be imported to the FloorRight file.  If you click on 
a checked site, the check is deleted from the site and all rooms in the site.  None 
of these unchecked rooms will be imported.  This function is handy if you find old 
data that is not part of the current batch. 

Site is an optional label for grouping rooms, e.g. by upstairs / downstairs, 
apartment number, material type, etc. Under the room entry, walls must be listed 
in the order that they connect.   

 Wall data consists of a length and a direction. See the Using Disto Pro With 
FloorRight Application manual for more information on gathering data. 

 - Indicates an error in the data.  An error in a wall measurement will result in 
an error mark by the wall, by the room containing that wall, and by the room's 
parent site.  Any rooms containing errors will not be imported.  See the Disto 
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Errors section, p. 59, for some examples that would cause errors. 

You can edit the Disto data before sending it to FloorRight.  Drag-and-drop 
operations are available for walls and rooms.  Walls, rooms and sites can be 
created, deleted, and renamed.   

The Room Display window appears when you click on a room entry.  If the room 
display is grayed when the room entry is highlighted, there is some illegal data in 
one or more wall entries or the room may contain less than two walls.  Open the 
room and edit the errors.  Walls are displayed with the following color code: 

• Walls without errors are displayed in black.  

• A wall selected from the data list is displayed in blue. 

• Walls with errors are displayed in red. 

• A selected error wall is displayed in pink. 

• Walls that have been added by one of the room closing method buttons are 
displayed in green. 

• Wall segments that are ignored as a result of adjustments made by the 
Adjust Length room closing button.  These are displayed in gray. 

Room Closing Methods are selected from the following group of buttons: 

• Square and Square Reversed give similar results. They finish the room with 
a square corner.   

• Angled closing connects the end of the last wall with the beginning of the first 
wall in the room. 

• Adjust Length closing is handy for small overlaps of the walls. 

Room closing buttons are grayed if there is an error  or a wall contains illegal 
data.  

File closing buttons are located at the bottom of the Disto Data dialog. 

• Commit Checked will send to the FloorRight drawing only the rooms with a 

checked entry  and which are error free.  The Disto Data 
dialog is closed and rooms from the Disto appear in the FloorRight room view.  
The raw data in the Disto device is not affected.  Once you have checked that 
all rooms have made it into the FloorRight drawing, you can delete the data 
from the Disto device, otherwise it is included with your next batch of data.  

• Cancel will close the Disto Data dialog without importing the data.  First you 
are prompted with the standard confirmation dialog asking you if you would 
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first like to save the changes you have made.  
o Click Yes to save or resave your raw Disto data with any changes you 

have made. 
o Click No to discard the changes you have made to your data.  This action 

doesn't delete a previously saved Disto data file; you only loose the 
changes you have made in the current session.  If you have not saved the 
discarded data you must Import it again from the Disto device. 

o Click Cancel to return to the Disto Data dialog. 
• Save will save the raw data with a .csd extension.  This would be used if the 

Disto data contained errors that you want to examine and correct at a later 
time.  The Save button brings up the Windows Save As dialog and will 
append the .csd extension to the file name you specify.  You can come back 
to this data using File / Import / Disto / File. 

• Undo will reverse the most recent change you have made.  Multiple undoes 
are available in the reverse order of your changes.  When no changes have 
been made or the last change is undone, Undo is gray (inactive). 

Disto Data - Wall Direction 
Each line in the Disto data file marked with the  wall icon represents a single 
wall’s length and direction.  The wall direction is listed in two ways: 

1. Azimuth – as an angle between 0º and 360º.  0º and 360º are north. 

2. Quadrant – a bearing given as degrees from either north or south toward 
either east or west.  Some examples: 
o N30E = 30º in azimuth 
o S20W = 200º in azimuth. 
o N45W = NW = 315º azimuth 

  

If you entered a direction of 405º, you will see it represented as 45º (NE). 
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The radio buttons in the Angle Format box indicate in which format the 
directions are displayed.  The unselected format is displayed in parentheses. 
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Editing Material Types Dialog Box 
Defining material types allows you to express the properties of the materials you 
are working with.  Does it require layout?  Should you allow T-Seams?  What is 
the pattern like?  How is it sold and installed? 

Specify the answers to these questions using the Edit Material Types dialog 
box.  Access this dialog box by selecting the Defaults menu and then choosing 
Material Type. 
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FloorRight™ provides many standard material types.  If you do not see one that 
fits your material, you can change one of the existing types, or create your own.  
Simply click on the box you want to change and type in your changes, or scroll to 
the end of the dialog and fill in the blanks. 

You may want to view materials in a different order, e.g. by price or by roll width.  
You can sort materials by ascending or descending order of any of the column 
headings.  When you click the column heading, a "+" or "-" will appear next to the 
text. 

• Click a heading with the "+" to sort in ascending order 

• Click a heading with the "-" to sort in descending order 

The column headers define the material type as follows: 

• Material name – This is a name that helps you identify the material you are 
defining.  The pre-defined materials have names that identify the types of 
flooring material.  It is a good idea to use a name that is general, rather than a 
specific manufacturer or design, since many carpets will have the same basic 
type. 

• Sold by – This specifies the units that the material is sold by.  You may 
choose from square feet, square yards, and square meters.  These units are 
not affected by the units that you can change in the Edit Options dialog box 
(see Units of Measurement, p. 161), since the "sold by" units depend on the 
manufacturer. 

• Hide – Checking this box will hide this material from the job estimate.  The 
material will not appear in the job estimate nor will it be included in price 
calculations. 

• Layout – Click this box if you must lay out this type of material.  Carpets and 
vinyl are two types of material that must be laid out.  Ceramic tile and wood 
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are examples of materials that do not need to be laid out. 

• Layable – You may want some extra margin on your cuts.  If the room 
measurement is exactly equal to the roll width, you may not want to cut 
pieces this close.  Specify how much less than the actual width you can use; 
e.g. if you rolls are 12’ wide, but you don’t want to cut pieces more than 11’ 
8”, then your layable width is 11’8".  All the layouts will be based on the 
layable width, but the total quantity and price in the Job estimate will be based 
on the Actual roll width (next column). 

• Actual – This is the actual width of the stock.  You can enter a value of 0 for 
ceramic tile and other materials that are not delivered by the roll.  The stock 
width is displayed in the units you have chosen in the Edit Options dialog 
box (see Units of Measurement, p. 161).  When you type in a width value, 
whichever length units you have chosen will be used.  You can avoid 
problems by including units with the value, e.g. 3’ for three feet or 1m for one 
meter.  

• T-seam – Click this box if you will allow T-Seams when installing this material. 

• Waste – This allows you to pre-set an estimated amount of waste for a 
material.  It does not apply to materials that are laid out, since their waste 
depends on the sizes and shapes of the rooms.  An example of how this 
would be used would be to estimate that 5% of ceramic tile is wasted through 
cutting and breakage. 

• Boxed – Check this box for any material (e.g. tile) sold by the box, such as tile 
or carpet tile. 

• Amount / box – For the check box above, enter unit area (square feet, square 
yards) per box.   

• Estimate Items – The list of Estimate items will always include the choices of 
Pad, Labor, and Base but could cover other items that you can specify from 
the Defaults menu.  These are displayed in a drop down list of check boxes 
from which you can select the appropriate items for each material type. The 
items checked for a given material will be the default item selection for any 
specific material derived from this material type. 

  

• Pat. width – If the material is sold by the roll and has a pattern, you can 
specify the width of the pattern here.  If you specify the pattern width in 
inches, you can use fractional measurements in multiples of 1/2, 1/4, 1/8, 
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1/16, 1/32, and 1/64 (e.g. 8 7/64" is allowed, 4 2/15" is not allowed).   This 
information is used to perform an automatic layout or to invoke the Carpet Tile 
feature.  Use this box the specify tile width.   

• Pat. length – This is the pattern length for patterned material. If you specify 
the pattern length in inches, you can use fractional measurements in multiples 
of 1/2, 1/4, 1/8, 1/16, 1/32, and 1/64 (e.g. 8 7/64" is allowed, 4 2/15" is not 
allowed).  This information is used by the automatic layout to match patterns 
on a seam. This box is also used for Carpet Tile.  Use this box the specify tile 
length. 

• Pat. drop – The pattern on many patterned materials is offset from one row of 
patterns to the next, providing a diagonal appearance.  The amount of the 
offset is called the pattern drop. If you specify the pattern drop in inches, you 
can use fractional measurements in multiples of 1/2, 1/4, 1/8, 1/16, 1/32, and 
1/64 (e.g. 8 7/64" is allowed, 4 2/15" is not allowed).  The pattern drop must 
divide evenly into the pattern length.  The automatic layout needs this 
information as well as it tries to find the best layout. 

• Tile scrap use – For tiled materials that might be cut to fit the edges of a 
room, you can choose whether or not to use the scraps on other edges.  
These choices are available: 

o Opposite side – means you can use scraps from the uncut or opposite 
side to the cut side of the tile.  This is the default setting.  Pieces are not 
rotated, thus this mode is appropriate for tongue and groove products or 
any material with a visible "direction". 

o Any side – lets you use any scraps that will fit.  This setting requires that 
the material can be rotated at 90/180/270 degrees. 

o None – Choose this option when you don’t want to use scraps.  This 
selection can result in much waste especially with long materials such as 
wood. 

See Additional notes on scrap usage at the end of this section.   

Blank lines at the bottom of the table allow you to enter additional materials. 

If you are satisfied with your changes, click the OK button.  To return to the 
material types as they were before you enter the dialog, click the Cancel button. 

To delete unwanted material types: 

1. Click the number on the far-left side of the line you wish to delete.  This will 
highlight the line, changing it to the Windows defined highlighted color. 

2. Click the Delete button. 
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Tile Scrap Usage 
Tiles are processed in order from lower left to upper right in a room. If a tile is to 
be cut and a scrap of the appropriate size is available it is used; otherwise, the 
new scrap piece is added to a scrap list to be used elsewhere in the room. No 
attempt is made to find the optimum scrap use for an entire room. Also scraps 
are not shared between rooms. 

When using the "Any side" method, using scrap on the opposite side is given 
priority over other sides.  Scraps are not used for corners. 

Edit Options Dialog Box 
The Edit Options dialog box allows you to set a variety of options that take effect 
across all of your projects. This tabbed dialog is found under the Options 
selection in the Defaults menu.  The options cover: 

• General settings including units of measurement, zooming, and undos. 

• Drawing options covering grid setup and wall colors. 

• Layout selections specifying stock cutting limits, seam width, and displaying 
piece offsets. 

• Creation Defaults identifying the default room name prefix, and how curved 
pieces are cut. 

General Edit Options 
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• Units – the settable units include: 

o Length units: The user can select either feet and inches or meters. 

o Area units: The user can select square feet, square yards, or square 
meters. 

• Zoom options – Some people appreciate the views automatically zooming to 
accommodate new rooms, while others find it distracting or annoying.  Check 
these options if you would like the room view and stock view to automatically 
resize as you are adding rooms. 

• Number of undos – This option allows you to set the number of undos the 
system will remember.  

Units of Measurement 
You may choose to measure in feet and inches or in meters and centimeters.  

Select the Defaults menu and choose Options. The list boxes at the top of the 
dialog box allow you to choose units for linear and area measurement. 

  

Materials are sold by the square yard, square foot, or square meter. You can 
describe how a particular material is sold by selecting the Defaults menu and 
choosing Material Type. For more information, see Editing Material Types, p. 
156. 
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For information on entering lengths with different units, see Entering Lengths, p. 
29.  

If you wish to change the currency units, see Changing the Currency Symbol, p. 
91.  FloorRight™ only supports decimal currencies (we can’t handle pounds, 
shillings and pence). 

  

You can also set the room type before creating rooms.  This is particularly useful 
if you are creating several rooms that are all the same type. 

If you have a room that is unique, you can modify the characteristics of the room 
through the Room Properties dialog box (p. 181). 

Number of undos 
FloorRight  will remember all actions and information you enter into your 
drawing file up to the number of undos that are set under the Edit Options dialog 
in the Defaults menu.   

The default number is 50, which gives you ample opportunity to correct mistakes.  
If you are short of memory or disk space, reduce this number to 5 or 10.  The 
minimum number is 1 and the maximum number is 10,000!   

   A high number of undos may slow your machine's performance unless you 
have lots of memory and disk space. 
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Drawing Edit Options 

  

• Grid – The room view grid helps the user to create and align rooms in the 
room view 

o Grid spacing: The distance between the fine lines on the grid. 

o Major grid spacing: The distance between the thick lines on the grid. 

o Snapping distance:  When grid snapping is turned on, this is the finest 
incremental change allowed when drawing a rectangle or a line. 

See Entering Lengths, p. 29, for more details on entering distances and 
lengths in FloorRight™. 

o Grid on: When checked, the room / seam view grid is turned on.  You can 
also accomplish this using the Grid button  on the tool bar. 

• Snap 

o Grid snapping: When selected, drawing lengths are rounded based on 
the snapping distance. 

o Horizontal / vertical snapping:  When selected, lines that are drawn 
close to vertical or horizontal will automatically snap to the exact vertical or 
horizontal orientation.  If unchecked, lines will remain just as they are 
drawn. 
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• Walls 

o Color:  It’s sometimes hard to see walls when they lie over the black or 
gray lines of an imported bitmap or AutoCAD file.  Click the menu button 
next to the color box to select another color for your walls.  You can select 
from the basic colors on this menu or create a custom color.  

o Adjusted Color:  Select a different color to highlight walls that are not 
included in the adjusted perimeter.  

Layout Edit Options 

  

• Stock – The stock options provide information about how stock is cut.   

o Max guillotine cut size: The longest possible piece of stock. 

o Max combined length:  This is the maximum cut size for a group of 
pieces.  Together these pieces may not exceed the maximum guillotine 
cut size. 

o Minimum seam width: The width of the smallest usable piece of stock. 

o Default max separation:  The maximum distance separating material 
pieces for a room in the stock view. 

• Display 

o Show piece offsets: When checked, offsets for selected pieces in the 
stock & roll views will be shown in popup balloons. 
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• Orientation  

o Horizontal radio button displays the stock / rolls from the bottom of the 
screen.  By dragging the sizing arrow at the bottom of the window, you 
can adjust the amount of stock view and room view displayed. 

o Vertical radio button displays the stock / rolls from the right side of the 
screen.  By dragging the sizing arrow at the right side of the window, you 
can adjust the amount of stock view and room view displayed. 

After making changes to these options tabs, select OK to apply the changes and 
close the dialog, or Cancel to leave the options as they were and exit the dialog.  
Click the Help button to get explanations of any of the options. 

Creation Edit Options 

  

• Rooms – The Room Prefix edit window changes the automatic name added 
to successive numbers for each room created - New room 1, New room 2, 
etc. 

Changing the default Room Prefix only changes rooms created after the 
change is made.  Names of rooms created before changing this default are 
left as they were. 

• Arcs – For curved walls the Number of Steps button and edit box lets you 
specify how the curve cut is represented in the stock view.  

Default values are 4 for outward bowed walls, and 3 for inward bowed walls. 
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The minimum value is 3.  Higher numbers represent more stock cuts to 
approximate the curve.   

You can also change this value for individual curved walls in the Wall 
Properties dialog.  

Estimate Print Formats Dialog 
The format of the Job Estimate printout can be adjusted from the Job Estimate 
dialog. Click the File menu and select Print format. 

 

In the Estimate Print Formats dialog saves a list of formats that you define.  
The buttons let you: 

• Add a new format to the list. 

• Edit an existing format. 

• Delete a format that you no longer want. 

• Set Font to your choice in the body of the estimate.  This will display the 
standard Windows Font dialog with your choice of Font, Font style, Size, and 
Script.  This setting is applied to any format you select. 

OK saves all new formats and font settings on exit. 

Cancel deletes any changes and reverts to previous settings. 

When you select Add or Edit from the Estimate Print Formats dialog, the 
following dialog will appear for your choices: 
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• Name – If you are adding a new format you will enter a name to identify it 
here.  If you are editing a format, the name of the format is displayed and 
can’t be changed. 

• Contents – This is a list of the templates for the printout.  As you click 
through the drop down menu, watch the Preview window to see which parts 
of the estimate will be included for each entry. 

• Style – The choices in this menu change the attributes of the estimate 
headings.  As you click through the drop down menu, the Preview window 
shows the difference in styles. 

The formats you have saved will be displayed in the standard Print dialog.  To 
view the actual printout, select Print Preview from the File menu in the Job 
Estimate dialog. 

Click OK to accept the format and return to the Estimate Print Formats dialog.  
If you’ve added a format, the new format name will appear in the format list.  

Click Cancel to abort the save and revert to previous settings. 

Expanding Rooms Dialog Box 
The Expand Rooms dialog lets you add a margin of inches, up to one foot, onto 
the selected room(s).   
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The margin can apply: 

• Only in the east and west orientations 
• Only in the north and south directions 
• All sides of the room  

A rectangular room expanded 2" north / south will have a 2" strip added to the 
top and bottom of the room; so each side wall will be 4" longer.  Likewise if the 
room is expanded by 2" east / west, it will have a 2" strip added to either side and 
the top and bottom walls will be 4" longer. 

  

For polygonal rooms the expansion may not be as obvious.  In some cases extra 
walls are added.  Here are some examples: 
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Job Estimate Header Dialog Box 
It is easy to customize the heading of your Job Estimate printout with your 
company and customer information. 

To display the Job Estimate Header dialog box use either Job menu - 

• Select Edit Header From the main Job menu, or 
• Select Header from the Job menu inside the Job Estimate dialog.  
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The top line allows you to change the type font, size and text attributes.  

The Layout box lets you select what information will be in the header and how it 
is arranged on the page.  Up to three blocks of information, which you can 
choose from the drop down windows below, can be displayed either in a Row 
across the top of the page, or in a Column down the left margin of the printout. 

The Set Logo button will allow you to identify the bitmap file containing your 
company logo.  A click of this button brings up the Select Picture dialog box. 

 

The Select Picture button brings up the Open dialog from which you select your 
logo file.  You can save the image as a reference location, which saves space 
but runs the risk of loosing the image if files get moved, or you can embed the 
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image in the FloorRight  file, which increases it's size.  Set the scale for your 
logo to suit the header.  The width and height are shown below the scale.  In 
order to see the new dimensions of the image after changing the scale, you must 
leave the dialog box (click OK) and then return (Set Logo) 

Now if one of the header information blocks is set to the Logo only option, you 
will see your logo displayed in the box.   

. 

Job Estimate Items Dialog 
Estimate Items are additional items that would be associated with a given 
material in your estimate.  The most common items, pad, labor, and carpet base 
are permanent items in the list.  You may add as many items as you like to this 
list, but only the first 32 items will appear in the Edit Material Type and New 
Material - Detailed dialog boxes. 

To access the Job Estimate Items dialog, select Job Estimate Items from the 
Defaults menu.   

 171



  

Insert your additional items by name and "Based on" (cost basis).  This 
information is conveyed to the New Material - Detailed and Edit Material Type 
dialog boxes and the Job Estimate screen.  Items will appear in the estimate in 
the same order that they appear here.  You can drag and drop items into a 
different order. 

The Item Name column appears in 3 shades.  

• Dark gray names are permanent items that cannot be deleted or renamed.  
The cost basis can, however, be changed.  

• Light gray names are items that have been attached to a material that is 
being used in the drawing.  They cannot be renamed, but can be deleted and 
the cost basis can be changed. 

• Names with a white background are new unused items and can be changed 
or deleted. 

The Based on column gives you a drop-down menu of choices.  The Fixed 
option is a general purpose one when none of the others apply. 

These items are saved with the FloorRight file and template if one exists. 
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Layout Properties Dialog Box 

  

Layout Properties of individual rooms are based on room layout styles that 
specify the number and types of seams a room can have. 

For each room you can adjust: 

• The number of T-seams allowed 

• The number of butt-seams allowed 

• The number of length-seams allowed 

• Whether long-axis seams are permitted 

• Whether to expend a bit more material to reduce the number of seams.  
Clicking Allow more seams overrides this common practice. 

• Whether the pattern starts in this room.  The Pattern start check box will be 
grayed out if the selected room doesn’t use patterned material. 

 Note that if you change the basic style of the room, all of these values with 
the exception of Pattern start are reset. 

Legend 
The Legend is a moveable window displaying all of the materials used in the 
document.  To display the Legend, select Legend from the View menu. 
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The window is easy to adjust: 

• Click and drag the title bar of the floating window to either side of the drawing 
window to dock the legend. 

• The docked legend can be moved along the side panel by clicking and 
dragging the frame of the window. 

• Double click the frame around the docked Legend window to make it float. 

• Floating Legends can be resized with the sizing arrows on the edges of the 
window. 

• To close the Legend, click the x on the upper right corner of the floating 
Legend, or click the Legend toggle selection in the View menu. 

You can bring up the material dialogs with a click: 

• Double click inside the Legend window to display and edit the New Material - 
Detailed dialog box. 

• Right click inside the Legend window to display the selections - Detailed 
New/Edit and Add New Material.   
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New Material - Detailed Dialog Box 
The New Material - Detailed dialog box can be found by clicking on the color 
and material menu in the upper-right of the window. 

  

Another way to display this box is by selecting Material List from Edit menu 

The New Material - Detailed dialog box displays details for all of the materials 
you have defined for this project. 
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The following information can be specified for a material: 

• Color is the color code for the material. 

• Material is the material type of the material. 

• Width is the roll width as defined in the Material Type dialog box. 

• Style name appears in the job estimate to indicate what this style of material 
is. 

• Color/Desc. is a description of the material to help you to remember which 
material it is.  This also appears in the job estimate. 

• Est. items is the list of estimate items. This list will always include the choices 
of Pad, Labor, and Carpet Base but could provide other items that you can 
specify from the Defaults menu.  These are displayed in a drop down list of 
check boxes.  You can select or deselect (click to remove the check) the 
appropriate items for each material. 

  

• Pat. width is the width of the pattern.  If there is no pattern, enter 0, unless 
you are entering tile.  This column must be used for boxed tile width. 

• Pat. length is the length of the pattern.  If there is no pattern, enter 0, unless 
you are entering tile.  This column must be used for boxed tile length. 

• Pat. drop is the offset from one row of patterns to the next. 

• Tile scrap specifies whether or not tile scraps can be used.  This choice is 
set in the Material Type definition. 

• Base height is use to calculate the base area if the material requires a base.  
Carpet base is assumed to be cut in strips lengthwise along the material. 

• Unit price is the price you charge for a unit (square yard, square meter, or 
square foot) of this material. 

• Tax is the tax rate in effect for this sale.  See Sales Tax Information, p. 86, to 
discover how to define sales tax or value added tax rates. 

You can sort materials by ascending or descending order of any of the column 
headings.  When you click the column heading, a "+" or "-" will appear next to the 
text. 
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• Click a heading with the "+" to sort in ascending order 
• Click a heading with the "-" to sort in descending order 

Click the heading again to resort the column in reverse order. 

The New button creates a new material.  It starts by asking you to assign a color 
to the material type with the New Material dialog box. 

The Change Color button brings up the Color dialog so that you can choose a 
new color for the selected material.  Place the cursor anywhere in the material’s 
row to change that material’s color. 

The Delete button removes a material that you have selected.  Click anywhere 
on the line for the material that you want to delete, and then click the delete 
button.  If the material is being used in a room, FloorRight™ will not let you 
delete the material.  You must change the material for that room first. 

The Import button imports material information from a third party database.  
Contact your FloorRight™ distributor for more information on the availability of 
material databases. 

The OK button accepts your changes and closes the dialog box. 

The Cancel button ignores your changes and closes the dialog box. 

Page Settings Dialog Box 

The Page Settings button  gives you several options for the Room, Seam, 
and Stock view printouts. 
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In all views you can select whether to print the material colors, an absolute scale 
for the drawing, or the Fit to page option. 

If you choose not to fit to page, the scale values are set using the Scale radio 

button and text entry fields.  The number in the window on the 
left represents a distance on the printout (usually in inches), and the number on 
the right indicates the actual real world length that this distance represents, 
usually in feet. 

The Fit to page button will automatically scale the drawing so that the whole 
view fits on one page.  

In the Room and Seam printouts you can choose to print the drawing grid, and 
whether or not to display page breaks (when Fit to page is not checked) and 
room dimensions on the printout. 

In the Stock view you can choose to print the stock sideways, which is the default 
because it saves paper.  The Back view button is helpful when cutting the stock 
especially for cutting the back of patterned material.  In the back view the stock is 
flipped vertically so that you are looking at the back of the material.   "BACK 
VIEW" is printed under the stock rolls as a warning. 

Position Rooms Dialog Box 
The Position Room dialog box allows you to place a room in the room view a 
relative distance from another room.  To use the Position Room dialog box, you 
first need to select the corners you wish to align.  See Aligning Rooms, p. 38, if 
you need help doing this. 

First select the corners of the rooms you wish to align. Then choose the Drawing 
menu and Position Room, or click on the Position Rooms button  on the 
toolbar to bring up the dialog box.  If you don't first select the corners you wish to 
align, the option and button will appear gray.  

 178



 

You may choose to enter the offset distances directly into the text boxes.  The 
units used depends on the settings specified in the Edit Options dialog box.  
Indicate whether you want the second room to the left or to the right of the first 
room by typing W (West) for left and E (East) for right.  Similarly, indicate that the 
second room will be above the first with N (North) or below with S (South). 

If you prefer, you can "nudge" the room by clicking on the arrow buttons.  Each 
click will move the room a short distance in the direction indicated. 

Position Pattern Relative to a Point 
Positioning a carpet relative to a point removes the room from the Global Pattern 
Start and allows you to set a particular pattern start for the room. 

First, select the point that will serve as a reference for the pattern start.  The 
upper-left point is perhaps most intuitive. 

Click the reference point, and then click the Layout menu.  Choose Position 
Pattern Relative To A Point.  This will bring up the Position Pattern dialog box. 
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Describe the location of the pattern start as an offset from this point.  You can 
indicate a horizontal offset, a vertical offset or both. 

• Horizontal – enter the Position and Offset of the point in this box to define the 
start east or west of the selected point. 

• Vertical – enter the Position and Offset of the point in this box to define the 
start north or south of the selected point. 
o Position – select whether you are defining the Pattern center or the 

Pattern top left for the pattern start, and click the appropriate radio 
button. 

o At a point – enter the distance and select the appropriate direction from 
the drop down menu. This is the offset from the selected point. 

Room Layout Styles Dialog Box 
Room layout styles help you to specify the types and quantities of seams for a 
particular type of room.  For example, you are likely to allow more seams in a 
closet than in the middle of a highly trafficked hallway.  The Room Layout 
Styles dialog box is accessed by selecting Defaults from the menu and then 
selecting Room Layout Styles. 

  

For each room style you can define 

• The number of T-seams allowed 

• The number of butt-seams allowed 

• The number of length-seams allowed 
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• Whether long-axis seams are permitted 

• Whether to trade off extra waste for fewer seams.  See Allow More Seams, p. 
72, for an explanation of this concept. 

To change the number of seams, click on the number you want to change, and 
type over it. 

To add a new room layout style, click on any blank line and enter your 
preferences. 

You can set as default any changes and additions to the layout styles: 

1. Click the number on the far-left side of the line to be set as default. This will 
"highlight" the line, changing it to white letters on a highlighted background. 

2. Click the Set Default button.   

Any layout styles set as default will be saved with a template, if you are using a 
template or one is saved. 

To delete unwanted layout styles: 

1. Click the number on the far-left side of the line you wish to delete.  This will 
"highlight" the line, changing it to white letters on a highlighted background. 

2. Click the Delete button. 

Room Properties Dialog Box 
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The Room Properties dialog box contains these tabs: 

• Room Properties – displays the room name, area and perimeter of the room, 
and materials and other items used. 

• Layout Properties – shows the layout style of the room and allows you to 
change one or more of these properties. 

• Borders – lets you add or edit the borders of a specific room.  

Invoke the room properties group of dialogs in one of these ways: 

• Double click the room. 

• Select the room you wish to change, then click the right mouse button and 
select Room Properties from the Room context menu. 

• You can also select a Stairs and right click as above to select Room 
Properties, but you cannot add borders to stairs, so the Borders tab will not 
be displayed in the dialog box when you select Stairs…. 

Rotate Room 
A room can be rotated around one of its corners.  Changing the direction of the 
wall that starts at that corner drives the rotation.  Here are the steps: 

1. Select a wall of the room. 

2. Right click the mouse and select Rotate Room from the Wall context menu 
or choose Rotate Room from the Drawing menu. 

The Rotate Room dialog displays the Old wall angle, which is the current 
angle of the wall, and the New wall angle edit box. 

3. Enter the new direction you want the wall to be pointing. 

4. Click OK to close the dialog and see the new room location. 

In the diagram below you can see how the point of rotation and, therefore, the 
selection of the wall makes a big difference in the resulting position of the room.  
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Sales Tax (Value Added Tax) Dialog Box 
Enter or modify sales tax or value added tax information through these dialog 
boxes.   
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The first text box identifies the tax, usually with the name of a municipality or 
other governmental region. 

The second text box is the percentage of the tax rate.  Enter this value in the 
form of a percent rather than as a fraction.  For example, entering 0.05 will be 
interpreted as 0.05% instead of 5%. 

For more information on Sales Taxes and Value Added Taxes, see Sales Tax 
Information, p. 86. 

Tile Editor 
The Tile Editor is used to place additional tiles in rooms made with tiled material.  

To place or arrange tiles in a room, click Tile in the Edit menu.  This changes the 

cursor to the tile edit cursor  and brings up the Edit Tile dialog box.   

  

This dialog gives you a choice of tiles to use from the material types you 
specified.  Click on the down arrow to the right of the window to select a different 
type of tile.  As with the material window for rooms, you can add new tile types 
(Add New Material in the drop down window) if you have properly defined them 
in the Edit Material Type dialog box.  If you don't find the type of tile in the 
window, use the Detailed New / Edit selection to edit your material list. 

To edit tiles select one of the available tools from the toolbar:  
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  Pencil tool – places tiles anywhere under the cursor when the mouse 
button is down. 

  Line tool – places a straight line of tiles.  When the Snap to Grid is on, the 
tiles are placed in a stair step along the line.  When the Snap to Grid is off, the 
tiles will be slightly overlapped to create a smoother line. 

 Rectangle tool – arranges tiles in an unfilled rectangular pattern.  Click and 
drag the mouse for the placement of the rectangle. 

  Filled Rectangle tool – arranges tiles in a filled rectangular pattern when 
you click and drag the mouse.   

• Using the left mouse button fills the rectangle with the current tile. 
• Using the right mouse button fills the rectangle with the current pattern if it 

exists. 

  Stamp tool – stamps the current pattern with the click of the mouse under 
the cursor.  To precisely place the pattern click the mouse hand hold it down 
while you drag the pattern rectangle to the desired position.  Release the mouse 
button when you have the pattern in the spot you want.  The tool is grayed when 
no pattern has been defined. 

  Erase tool – erases a tile of the current type (color).  You can click the 
cursor to erase individual tiles or click and drag like an eraser on a blackboard to 
quickly erase many tiles.  Note:  you cannot remove the original tiles used to 
create the room. 

 Flood Fill tool – fills the entire room with the current pattern.  The tool is 
grayed when no pattern has been defined. 

  Select tool – creates the pattern by selecting a grid of tiles which you have 
already placed in the room.  Position the cursor at one corner of the pattern and 
drag the rectangle to include the tiles making up the pattern.  When you release 
the mouse button, the pattern appears in the Pattern window of the dialog.   

  Edit tool – moves a selected tile anyplace in the room.  Click the tile to 
move and drag it to the new location. 

  Grid Movement tool – moves the grid within the room by the click and drag 
method.  This is handy if you want to align the grid with the edge of the room 
rather than centering it in the room. 
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Show Grid is a toggle box which, when checked, puts a grid over the displayed 
rooms.  The grid is the size of the tile type selected.  When the Show Grid box is 
empty, no grid is displayed. 

Snap to Grid is a toggle box that allows you to place tiles exactly aligned in the 
grid.  If the box is empty (i.e. the Snap is not selected) you can place the tiles 
anywhere in a room, wherever the cursor is positioned. 

Transition Materials Dialog Box 
Transition materials may be created, edited, or deleted from the Transition 
Materials dialog listed under the Defaults menu. 

 

Once the transition material list is created, it becomes available to the Job 
Estimate and Transition Properties dialogs. 

The following transition properties can be defined: 

• Name – The name of the material must be unique.  A warning dialog will 
appear if you use a duplicate name.  If the material is used in the drawing, the 
name will appear on a light gray background.  The name cannot be changed 
if the material is in use. 

• Length – This is an optional entry for the length of a single piece of material.  
It can be used to calculate the number of pieces needed for a transition; i.e. a 
48" transition using 36" transition material will need 2 pieces of that material. 

• Based on – This entry sets the default Based on criterion used in the job 
estimate.  The choices are: 
o Transition length – the amount of material is calculated based on the 

total length of all transitions using this material.  In the transition materials 
list shown above, acoustic & aluminum threshold is sold by the foot and 
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calculated on total threshold length. 
o Transition count – the amount of material is calculated based on the total 

number of transitions using this material.  In the transition materials list 
shown above, brass threshold comes in 36" and 48" pieces and is 
calculated by threshold count, assuming one threshold piece at each 
transition. 

• Boxed – If this box is checked, the material is sold by the box. 

• Amount / box  – Lists the quantity of the material per box.  This entry is also 
handy for material that comes in a long roll.  In the transition materials list 
shown above, reducer strip comes in 9' lengths with 10 pieces in a box and is 
calculated based on total threshold length. 

In order to rearrange the order of materials in the dialog, you can:  

• Click the material number (the row will be highlighted) and drag the cursor to 
the new row.   

• To move more than one neighboring row click and hold the mouse button 
while dragging over more than one material number. When you release the 
mouse, the rows you selected will be highlighted.  Click again and drag the 
group to the new row. 

Note: If you select the wrong materials, clear the highlighting by clicking any cell 
in the table, then try again. 

Delete – Click this button to delete the currently selected material.  If the material 
is in use, a warning dialog asks you to confirm: 

Yes – delete the material and clear it from the transition materials list 

No – (oops!) don’t delete the material after all. 

OK – Click here to accept any changes made to the list and close the dialog. 

Cancel – Click this button to abandon any changes made and close the dialog. 
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Transition Properties Dialog Box 

  

The Transition Properties dialog appears when you create or edit a transition 
(door or threshold material). 

• Transition Length – allows you to change the length of the transition using 
the current default units.  This number can be selected from the drop-down 
list or nonstandard lengths can be entered in the box.  

• Remove from adjusted perimeter – when checked, the length of this 
transition is subtracted from the Adjusted Perimeter measurement. 

• Transition Material – Click the drop-down button to select one of these 
materials for the transition.  If the material that you need is not currently in the 
list, you can go directly to the Transition Materials dialog by selecting 
Add/edit transition material from the drop-down.  Once you have entered 
the material it is available to this window. 

• Door – If the transition contains a door, you can show it on your drawing by 
clicking the Display as door checkbox.  When this box is checked, you can 
display on which side it is hinged and which way it swings by clicking the 
appropriate radio button. 

Click the OK button to save any changes and exit the dialog. 

Click the Cancel button to exit without saving changes and revert to the previous 
settings. 

Wall Properties 
Wall Properties gives you information and fine control over the size and shape of 
the selected wall.   
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To display this dialog: 

1. Select a wall  

2. Right click the mouse and choose Wall Properties from the menu or select 
Wall Properties from the Edit menu.   

  

When the selected wall is straight (above right) the Wall Length and the Line 
Length are identical.  If the selected wall is curved (above left) the Wall Length 
is the actual length of the curve and the Line Length is the dimension of the cord 
as shown.   

If you change the Line Length, the Projection value will remain the same, and 
the Wall Length will change accordingly.  The Wall Length is calculated 
automatically and cannot be edited directly. 

The Direction box allows you to change the wall direction.  The wall direction of 
a curved wall is the direction of the line connecting its two endpoints. 

The Projection edit box allows you to change the curvature of the selected wall.   
The value, in current units, is the perpendicular distance from the middle of the 
bow to its chord.  A straight wall has a value of 0º.  A negative value bows the 
wall to the right and a positive value bows the wall to the left, depending on the 
wall direction. 

The Line Length, Direction, and Projection boxes are also available for editing 
directly on the toolbar after you have selected a line. 

For curved walls the Number of Steps buttons lets you specify how the curve 
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cut is represented in the stock view.  

The minimum value is 3.  Higher numbers represent more stock cuts to 
approximate the curve. 

Use the Count in adjusted perimeter checkbox when you have estimate items 
that are based on an adjusted perimeter measurement, e.g. you won’t need 
molding on a wall that will contain a built-in bookcase.  In this case, the wall 
would be excluded from the adjusted perimeter (unchecked), and the molding 
would be based on the adjusted perimeter. 
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Commercial Version 
What is FloorRight™ Commercial? 

The main features of FloorRight™ Commercial are digitizer and AutoCAD file 
support, Roll Allocation, and designing custom Reports. Utilizing a digitizer or an 
AutoCAD file allows you to enter Blueprints or drawings in a fraction of the time 
and with fewer mistakes.  Roll Allocation minimizes waste in large jobs and is 
handy for using up partial rolls of material. 

FloorRight™ Commercial will support most newer digitizers. The only 
requirement is that your digitizer uses a WinTab driver. If you are unsure if your 
digitizer uses a Wintab driver, refer to your digitizer documentation or contact the 
digitizer vendor. 

Designing Reports  (Commercial Version) 
From the File menu select Reports / Design to start the report designer.  The 
flexible Report Designer lets you create custom report designs or edit existing 
designs. 

The complete Designer documentation is found in your "Doc" subdirectory in two 
formats: 

• Report Designer.pdf   (PDF document)    

• Report Designer.doc  (Word document) 

For a simple summary of the basics see Report Designer Quick Start.doc (found 
in a folder of the same name, installed with your FloorRight™ system). 

You can make two basic types of reports, Room / Stock reports and Job Estimate 
reports. Both of these reports make use of the following elements. 

• Company information – this is the information that is entered in the Company 
Info dialog box found under the Defaults menu. 

• Customer information – this is the information from the Customer 
Information dialog found under the Job menu.  

• Date & time – these are in the format used in printouts in previous versions of 
FloorRight.  The report designer also contains many other options for 
including date and time information in a report (see the documentation).  

• FileName – this contains the name of the currently open FloorRight file.  
• FilePath – this contains the full path to the currently open FloorRight file.  
• Annotation – this is the text that is entered in the Add Text For Printing 

dialog found under the Drawing menu. 
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Designing Room / Stock Reports (Commercial Version) 
The following elements are available for the Room / Stock reports: 

• Text Elements - 

o PageName – contains the name of the current document page for jobs 
with multiple pages. 

o Material Information – including material Style and Description from the 
material definition. 

o Material stock information – including roll lengths - used and free, roll ID’s, 
and dye lots. 

• Graphical Elements - 

o CutList – a list of all cuts for a roll of stock  

o Legend – shows the color assigned to each material  

o Rolls – equivalent to roll view  

o Rooms – equivalent to the room view  

o Stock – equivalent to the stock view  

Layout of the Room / Seam Reports is controlled by the Fit to page check box in 
the Room / Seam printouts section of the Page Settings dialog. 

 When Fit to page is checked, the room view is scaled to fit inside the room 
element box and on one page. 

 When Fit to page is unchecked, the room view is drawn to the scale specified 
on the last line of the Room / Seam printouts box in the Page Settings dialog.  In 
this case, the room view may extend over several pages. 

Layout of the Rolls / Stock Reports is controlled by the Fit to page check box in 
the Stock printouts section of the Page Settings dialog. 

 When Fit to page is checked, the Roll / Stock view is scaled to the width of 
the box with the vertical scale to match the horizontal scale.  The stock material 
will fit on one page. 

 When Fit to page is unchecked, the Roll / Stock view is scaled to the height of 
the box with the horizontal scale to match the vertical scale.  The scale specified 
on the last line of the Roll / Stock printouts box in the Page Settings dialog is not 
used.  In this case, the roll / stock view may extend over several pages. 

You can also change the text font for a graphical element in your report. 

Notes:  
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• With the exception of the Legend, only use one instance of a given element in 
a report, i.e. don’t use two Rolls elements in the same report.   

• Use only one of Rolls, Rooms or Stock in a report, i.e. if you have the Stock 
element in a report, it should not also have Rolls or Rooms elements.  

For more complete information on designing reports see Report Designer Quick 
Start.doc (found in a folder of the same name, installed with your FloorRight™ 
system) and Report Designer pdf or .doc, found in your "Doc" subdirectory. 

Designing Job Estimate Reports (Commercial Version) 
The following elements are available for job estimate reports  

• Total – this is the total job cost as shown at the bottom of the job estimate 
screen 

• PageName – contains the name of the current document page for estimates 
that are broken down by pages.  

• All the fields of the job estimate grid are available.   Most are provided as text 
with these exceptions: 
o Color is graphical – It’s displayed as it appears in the FloorRight file, room 

color window. 
o Boxed is a Boolean (true / false).  

• An extra RowType field is available to allow easier formatting based on type 
of row.  This field contains a single letter string.  
o "M" – material row  
o "I" – item row  
o "S" – subtotal row  
o "B" – blank row  

The contents of this field can be used in conditional expressions (see the 
designer documentation for more information).  The field’s value is available 
even if it is not present in any table  

Additional fields are available to enable using the report generator formula and 
group capabilities  

• Color  
o Box – draws a box in the material color  
o Index – material index.  This is useful for grouping. 

• RGB – material color RGB value as an integer.  This value can be used to fill 
in cells with the material color. 
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• Tax 
o Name – name of tax 
o Percent – tax percentage as a floating point number (10% will be 

displayed as 10.0) 
o Rate – tax rate (percent/100) as a floating point number (10% will be 

displayed as 0.10) 

• Units – units of measurement for the various values (see below) as strings 
o Length o UserAdd 
o Quantity o UnitPrice 
o Waste  

• Value – all numeric fields as floating point numbers  
o Length o Quantity 
o Waste o UserAdd 
o AmountPerBox o Boxes 
o UnitPrice o Subtotal 
o Tax o Price 

To use a field just drag it into a grid object in the report. 

A job estimate report should contain at least one table.  Tables are available from 
the objects toolbar in the designer.  Fields can be added to the table by dragging 
& dropping. 

Multiple tables are supported – the number of lines shown in each table is based 
on the shortest table  

For more complete information on designing reports see Report Designer Quick 
Start.doc (found in a folder of the same name, installed with your FloorRight™ 
system) and Report Designer pdf or .doc, found in your "Doc" subdirectory. 

Customizing Report Text (Commercial Version)  
You can change the text font in any of the graphical elements (CutList, Legend, 
Rolls, Rooms, Stock) in the report designer.   
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1. Select the graphical element on the page. When you click the element, a 

crosshatching appears around its edge. .  

2. In the Properties pane select the "Properties" line just below "Variable"  

3. Click the button at the right end of the line to bring up a font selection dialog  

• If  Use FloorRight default font is checked then the font found in 
FloorRight’s Defaults / Set Font menu item will be used and all other 
information is grayed out. 

• If  Use FloorRight default font is NOT checked then the font, style, size, 
etc. can be set in the Font dialog. 
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Roll Allocation (Commercial Version) 
Two commands from the Layout menu allow you to specify the length of each 
roll of material and view the exact cuts on each roll in the stock view. 

• Set Roll Length will bring up the Roll Length dialog box where you can 
specify the lengths of rolls for each type of material.  Roll lengths can be 
grouped by dye lots.  This dialog also allows you to specify the guillotine cut 
gap for your rolls. 

• Show Roll Allocation is a check box that lets you display the roll allocations 
in the stock view.   
o If this box is not checked, all stock cuts for a given material are displayed 

with each dye lot specified.  If dye lots are not specified, cuts for each 
material appear on the default roll.  

o If this box is checked, the cuts appear on the allocated roll. The end of 
each roll displays the Dye lot, roll ID, roll Length, and the amount 
available on the roll.  Unused rolls are also displayed. 

Rooms are individually assigned to dye lots using the Dye lot drop-down list. 

Dye Lots (Commercial Version) 
Once you have specified material rolls and their dye lots in the Roll Allocation 
dialog, you can assign material in each room to a dye lot. 

The Dye lots drop-down list to the right of the Material type drop-down list on 
the toolbar, let you select the current dye lot setting. 

 

• Any new rooms created with the currently displayed Material will be cut from 
the currently displayed Dye lot. 

• You can change the Dye lot that a room’s material is cut from by first 
selecting the room or rooms, then click the drop-down arrow of the Dye lot 
window and click the desired dye lot from the list. 

Note:  if you select more than one room whose materials have been assigned to 
different dye lots, the dye lot window will be blank. 
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Page Tabs  (Commercial Version) 
The page tabs feature in FloorRight Commercial is a handy way of organizing 
large or complicated jobs.  Some useful applications are: 

• Grouping rooms, e.g. by floor or wing of the building. 

• Importing an AutoCAD drawing with layers. You may want to put layers on 
separate pages. 

• Trying different layouts or options; you could Copy the rooms in your drawing 
to multiple pages and change the defaults and layout options for quick 
comparisons.  (The Base Stock on Page option in the Job menu works well 
here.) 

Page tabs are found at the bottom of your screen.  Click the tab of the page you 
want to display. 

  

You can Add, Insert, Delete, Rename and Rearrange page tabs. Invoke the 
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popup menu by one of these methods: 

• Move the cursor over the tab and right click the mouse  
• From the Edit menu select Pages. 

Editing Page Tabs  (Commercial Version) 
You can configure pages of your drawing by editing the Page Tabs.   

From the Edit menu select Pages or right click any page tab to display the popup 
menu with the following options: 

• Add  – places a new page at the end of the document and a new Page Tab to 
the left of the tab list.  By default the tab is called "Page #", where # is the 
new total number of pages (i.e. if you now have 3 page tabs, including "Main", 
the new tab is called "Page 3"). 

• Insert – places a new page as in Add, but puts it before the current page and 
the new page tab goes to the left of the current tab.  As in Add, the next tab 
name has the next number ("Page #"). 

• Delete – removes the currently selected page and ALL ITS Contents  from 
the document. 

• Rename – invokes the dialog to change the name of the current page tab. 

 

• You can rearrange page tabs by clicking the tab and dragging it along the 
page tab line to a new location. 

Base Stock on Page (Commercial Version) 
This feature is found in the Stock View context menu. 

Right click anywhere in the stock view to see the Base Stock on Page option. 

• When checked, the Stock View, Job Estimate, and status line will display the 
information pertaining only to the current page in the Room View. 

• When unchecked, the Stock View, Job Estimate, and status line contain the 
details of the entire document. 

This feature is handy for big jobs for example – 
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• Tract housing with different layout options on separate pages. 

• Multi-story building with each floor on a separate page. 

• Staged jobs with separately bid stages on each page. 

 Flipping between page and document modes can yield unexpected results.  
Layout changes and some changes to the Job Estimate may not show up when 
you toggle the checkbox, even when the changes were made on the same page. 

The best way to use this feature is to decide in the beginning which mode to use 
and avoid changing back and forth.   

AutoCAD Import (Commercial Version) 
If you already have a floor plan layout in an AutoCAD, DXF or DWG format file, 
you can use it to help create a FloorRight project.  From the File menu select 
Import / AutoCAD to bring an AutoCAD file into FloorRight.   

 

The import automatically opens the AutoCAD Properties dialog.  If you've 
already attached your AutoCAD file to a FloorRight file, you can bring up the 
properties dialog box from the Edit / AutoCAD Properties menu selection.   
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The Layers list box gives you control of each individual AutoCAD layer.  All 
checked layers will be displayed.  Click on a checked box to hide a layer.  

All is a toggle button that turns on or off all layers of the AutoCAD file.  You can 
use any combination of the All button and the individual check boxes to display 
the desired layers. 

The Layout drop down allows you to select from the layouts that were created in 
the AutoCAD file.  All files are created with the default layout, "MODEL_SPACE".  
Most files have a "PAPER_SPACE", although it may be empty.  Any additional 
layouts created in the AutoCAD file will be available from this menu. 

Units is used to tell FloorRight how to interpret the dimensions of your AutoCAD 
drawing.  Most drawings will use one of the five preset units (feet, inches, meters, 
centimeters or millimeters).  Note that the units for the AutoCAD file are 
independent of the units being used in the FloorRight drawing. 

If your AutoCAD drawing is made in units other than those listed in the Units 
menu, you can use the "custom" option.   

1. Click on the side of a FloorRight room.  The side you selected will be 
displayed with a black arrow and the side's length will be printed next to it.  

2. Select "custom" from the Units menu to bring up the scaling dialog box, Set 
Side Length. 
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3. In this box the Current length shows the length of the selected room side as 
you last defined it in either feet or meters. 

4. In the New length edit box you can change the length to match the scale of 
the drawing overlay / underlay.  Changing this length will only affect the 
specified lengths of your FloorRight objects; the room layout will look 
unchanged relative to the AutoCAD drawing. 

The Display radio button group presents the following options: 

• Off – the AutoCAD drawing is hidden. 

• Underlay – the AutoCAD drawing appears behind any FloorRight objects. 

• Overlay – the AutoCAD drawing appears in front of any FloorRight objects. 

Snap, when checked, snaps to lines or points in the visible AutoCAD drawing 
within the Snapping distance defined in the FloorRight menu Defaults / 
Options / Drawing tab.  When unchecked, snapping is governed by the Grid 
snapping checkbox in the same menu. 
The OK button closes the Set Side Length dialog and accepts the new length. 
All FloorRight objects are assigned new dimensions to match the selected length 
change and the view automatically zooms to cover the extent of the drawing at its 
new scale. 
Cancel will close the Set Side Length dialog and revert the scale to the previous 
length. 

The AutoCAD Properties dialog can be left open while working on the project.  
Changes in the settings take place immediately. The OK button closes the dialog 
saving the changes; the Cancel button closes the dialog and reverts the settings 
to their previous value.   

AutoCAD file's path and property settings are saved with the FloorRight file and 
reloaded whenever the FloorRight file is opened. 

AutoCAD Export (Commercial Version) 
Any FloorRight file can be saved in AutoCAD format (.dwg or .dxf files).  Simply 
select File / Export and fill in the Export dialog.   
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If your file already contains AutoCAD layers, you can check Save AutoCAD data 
and choose between saving All layers or just the Currently selected layers 
with the file.  Then enter the file name, with the .dwg or .dxf extension, or the 
program will automatically supply the extension for you.  The default supplied is 
.dxf. 

The resulting AutoCAD file will contain the following layers: 

• Existing AutoCAD layers if present    

• FloorRight room including room outlines, stock outlines, doors, windows, tiles 
and text.  Bitmaps are not exported. 

• Seams 

• Drawing legend mapping colors to materials  

Units for the AutoCAD export are feet or meters depending on the FloorRight 
default settings. 
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Calibrating the Digitizer 
Setting a Fixed Scale and Orientation (Commercial Version) 

 

Setting a Scale 
If you know the scale then select Set Fixed Scale from the Digitizer menu. 

Set Ratio Select Set Ratio if you know the scale as a ratio, for 
example 50 to 1. 

Set Fixed Scale Choose Set Fixed Scale if you know the scale for 
example ¼ inch = 1ft 

You may want to use the digitizer in a non-standard orientation, for example 
when the power cord is in an inconvenient position on the digitizer.  

You may use any edge of the digitizer as the "top." There is a picture of the 
drawing in relation to the digitizer’s standard orientation.  In this orientation, the 
physical top of the digitizer will be the top (or north) of the drawing.  If you wish to 
reposition the physical top of the digitizer, click on the radio button  that 
matches the physical top of your digitizer. 

Note:  Resetting the digitizer scaling will automatically rescale all existing rooms. 

The digitizer scale is saved with the FloorRight file.  You have the option of 
setting the scale when you load the file. 

Manually Calibrating the Digitizer (Commercial Version) 
If you do not know the scale, select Manually Scale from the Digitizer menu. 
This will bring up the Manually Calibrate Digitizer dialog box. 
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• Current Scale Display – The current scaling is displayed as text on the top 
right section of the dialog box. This dialog also displays a graphical 
representation on the left side. The graphical representation shows a square 
drawn on the digitizer screen. If the current scaling is rotated or stretched, the 
square will become slanted or stretched. The square also displays an arrow 
on the left side of the square. This arrow is pointing NORTH. If the scale is 
rotated, for example if the digitizer is turned upside down, this arrow will 
display this rotation. 

 

• Calibrating – Calibrating the digitizer is a simple as clicking on two points on 
a line. The further away the two points are, the more accurate the calibration 
will be. After you click on the second point, FloorRight  will display the length 
and direction of the line using the current scaling. Enter a new length and 
direction and click Next to enter an additional calibration line, or click OK to 
finish manual calibration. 

If you’ve made a mistake when clicking on the first or second point, don’t 
enter a new value for the calibration line and don’t click on the Next button. 
Instead, reenter the first and second point. FloorRight  will only accept a 
calibration line when you click the Next or OK buttons. 

• Compass Directions – FloorRight  uses a compass to specify direction. 
The calibration lines use the same directions that are used when defining 
walls. See Wall Directions, p. 27, for an explanation. 

Note:  Resetting the digitizer scaling will automatically rescale all existing rooms. 

The digitizer scale is saved with the FloorRight  file.  You have the option of 
setting the scale when you load the file. 
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Adjusting Horizontal and Vertical (Commercial Version) 
If you know the exact scale, you can calibrate the digitizer by selecting Set Fixed 
Scale from the Digitizer menu, but there are times when you know the scale but 
the drawing or digitizer is not perfectly square. For example, the blueprint might 
not be printed straight or the blueprint might not be perfectly aligned on the 
digitizer. 

You can make adjustments to the direction that FloorRight  will use as 
horizontal or vertical by selecting Manually Scale from the Digitizer menu. 

Digitize several horizontal or vertical calibration lines, but instead of entering a 
new length and direction, only enter a new direction. Be careful when entering 
compass directions. Remember that north is up and west is left on the blueprint. 

Resetting all Digitizer Settings (Commercial Version) 
If for some reason the digitizer scale is incorrectly calibrated and you cannot 
seem to correct the problem, you can reset all digitizer settings to their default 
values. The default values are the settings that were used the very first time 
FloorRight  was run. 

 Resetting the scale will affect the digitizer settings in relation to any 
existing rooms. If you have already digitized at least one room you MUST re-
calibrate the digitizer and then correlate the FloorRight  file with your blueprint. 

After the settings are reset, you should then re-calibrate the digitizer using either 
the menu command Set Fixed Scale or Manually Scale. 

Using the Digitizer 
Viewing Digitizer Information (Commercial Version) 

It is useful to be able to view the information that your digitizer driver is reporting 
to FloorRight . This can be an invaluable tool when troubleshooting possible 
problems. 

Digitizer Information 

Manufacturer: The manufacturer information that your driver is 
reporting. Some drivers will report that they are 
Wacom Tablets, when they are really produced by 
a different manufacturer, for compatibility with 
older software. 

Width: The physical width of the active digitizing surface. 
Height: The physical height of the digitizing surface 
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Digitizer Sound 

FloorRight  will make a click sound when the digitizer puck or pen is clicked. 
This audible sound helps when drawing rooms, since you may not be looking at 
the screen. For more information refer to the section on configuring digitizer 
sounds.  

Digitizer Menu (Commercial Version) 
The following table lists the Digitizer menu options and what their function is. All 
items should be available if the correct digitizer drivers are installed. If only the 
Digitizer Info option is available the correct drivers may not be installed. If this is 
the case, then refer to the troubleshooting section. 

Menu Option Function 

Digitizer Info  Display digitizer driver manufacturer, digitizer 
dimensions, and set digitizer sound. 

Digitizer Mode  Activate or deactivate digitizer mode. 

Mouse Region  Activate or deactivate a mouse region. 

Button Template  Activate or deactivate a button template. 

Set Fixed Scale  Set a fixed scale, for example "1 to 50" or "¼ 
inch = 1 foot". Also lets you set the digitizer 
orientation, for example if the digitizer is 
flipped upside down. 

Manually Scale  Manually calibrate the digitizer when the 
exact scale is not known, or if the blueprint is 
stretched. Can also be used to set the 
rotation, for example if the blueprint is not 
exactly aligned horizontally or vertically. 

Correlate FloorRight 
And Digitizer Points  

Synchronize a point in the FloorRight™ 
drawing with a point on the blueprint. Use 
when the blueprint has been moved from its 
original position.  

Zoom To Digitizer  Zoom the FloorRight  room view to fit the 
entire digitizer drawing surface. 

Reset Digitizer To 
Defaults  

If for some reason the digitizer scale is 
incorrectly calibrated and you cannot seem to 
correct the problem, you can reset all 
digitizer settings to the default values that are 
used during installation. 
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Configuring the Digitizer (Commercial Version) 
There are settings that you will want to change frequently, like the scale of a 
blueprint, and there are setting that you might only set the first time you use 
FloorRight , like defining the button template. 

Set a Scale 
Whenever you start digitizing a blueprint, you will want to set the blueprints scale. 
Setting the scale lets FloorRight  read the correct dimensions when you click 
the digitizer puck or pen. 

If you know the exact scale as a ratio, for example 50 to 1, or as a relation, for 
example ¼ inch = 1 foot, you can enter that scale using the Digitizer menu 
command Set Fixed Scale. If you don’t know the exact scaling, you must 
manually calibrate the digitizer using the Digitizer menu command Manually 
Scale. The digitizer scale is saved with the FloorRight  file.  When you load the 
file you have the option of setting the scale.  If you’ve entered a fixed scale but 
the blueprint is not plumb on the digitizer, you will also have to adjust what 
FloorRight  will consider horizontal or vertical directions. See Adjusting 
Horizontal and Vertical, p. 205, for more information. 

Define the Blueprint’s Positioning 
If you are starting a new blueprint, you don’t have to set any specific blueprint 
position. FloorRight  will position all rooms correctly relative to one another. If, 
on the other hand, you have adjusted the scale after entering at least one room, 
you need to tell FloorRight  how to position new rooms relative to the rooms that 
were already entered. See the section on correlating FloorRight  and digitizer 
points, p. 213, for more information. 

Configure the Button Template 
If you want to use the digitizer to enter FloorRight  commands, for example 
zooming, switching modes, or toggling digitizer mode, you must define the 
location of the button template. This is a feature that you don’t have to configure 
often. You will probably want to configure the button template once and use the 
same setting all the time. 

Configure a Mouse Region 
You can also use a portion of the digitizer as a mouse. See Digitizer Mouse 
Region, p. 211, for more information. 
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Digitizer Button Template (Commercial Version) 

  

Activating 
Attaching the button template to the digitizer. 

Activate the toolbar by selecting Button Template from the Digitizer menu.  This 
will put a check mark in front of the Button Template. 

Using the digitizer, click on the top left corner of the button template. Next, click 
on the top right corner. You will see the button template drawn on the digitizer 
screen in the Button Template dialog box. Verify the positioning.  

Press Accept if the size and positioning is correct. If it is not correct you can 
redefine the button template by clicking on the top left and top right corners 
again. 

HINT: FloorRight  includes several button templates, but if you don’t have a 
button template handy you can print this page and cut out the picture. 

Deactivating 
Selecting Button Template again will deactivate the digitizer button template 
and remove the check mark from the menu item. 

Using the Digitizer Button Template (Commercial Version) 

  

The following tables describe the buttons that appear on the digitizer button 
template. 

Button - Row 1 Description 
Activate/Deactivate 
Digitizer Mode  

Toggles digitizer mode ON and OFF 
 
 

Polygonal Room / Hole  Starts a non-rectangular room or hole 
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Button - Row 1 Description 
Rectangular Room / 
Hole  

Starts a rectangular room or hole 
 

Door Mode  Adds a door to a wall 
 

Window Mode  Adds a window to a wall 
 

Close Room  Closes a non-rectangular room 
 

Cancel Line Draw  Cancels the drawing of a non-rectangular 
room 
 

Delete Room Side  Deletes the last non-rectangular room side 
that was drawn. 

 
Button - Row 2 Description 
Zoom Box Lets you select a region of interest on your 

diagram, and fits that region onto the 
screen 

Zoom To Height Scales the screen so that the entire height 
of the diagram is visible 

Zoom To Fit Scales the screen so the entire drawing is 
shown.  This is especially useful if you have 
gotten lost by zooming and scrolling too 
much. 

Zoom In Gives you a closer look at your drawing 
Zoom Out Provides a bigger perspective 
Zoom To Digitizer  Scales the screen so the entire digitizer 

drawing surface is visible. 
Undo  Undoes the last action 
Redo  Reinstates actions that you have undone. 

 

Activating Digitizer Mode (Commercial Version) 
To activate digitizer mode, select Digitizer Mode from the Digitizer menu or 

press the F2 key or use the Activate Digitizer button  on the toolbar. 

To deactivate the digitizer mode, simply select the Digitizer Mode from the 
Digitizer menu again or press the F2 key or use the Activate Digitizer button 
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 on the toolbar. 

If the digitizer does not seem to respond when digitizer mode is on, refer to the 
section on digitizer troubleshooting. 

Configuring Digitizer Sounds (Commercial Version) 
FloorRight  will make a click sound when the digitizer puck or pen is clicked. 
This audible sound helps when drawing rooms, since you may not be looking at 
the screen. 

The digitizer sounds can be configured to use your computer’s sound card. If you 
computer does not have a sound card, you can also configure FloorRight  to 
use your computers internal speaker. 

Sound Card Uses your computers multimedia speakers and 
sound card. 

PC Speaker Uses your computers internal speaker. 
None Deactivates all digitizer sounds. 

 

NOTE: Not all computers have sound cards or internal speakers. It is possible 
your computer does not have any sound devices. 

Configuring Click Sounds 
If you selected Sound Card under Digitizer Sound, you can change the 
individual sounds that will be used for digitizer clicks. These sounds can be 
changed using the Sounds applet in the control panel. 

To open the Sounds applet, click on the Start button in the task bar. Next, select 
Settings and then Control Panel. Finally, select the icon labeled Sounds. 
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Digitizer Mouse Region (Commercial Version) 
When you have a digitizer attach to your computer, the digitizer puck or pen can 
normally be used as a mouse inside non-digitizer programs. In most digitizer-
enabled programs, the puck can only be used as a digitizer device, and not as a 
mouse. 

When FloorRight  is in digitizing mode, this mouse functionality is not enabled 
by default, but unlike most other digitizer-enable programs, you can enable a 
rectangular region on the digitizer to work like a mouse. It can be very useful to 
have a region on the digitizer that controls the mouse. This lets you pull down 
menus and change modes directly from the digitizer, without having to reach for 
the mouse or keyboard. 
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Activating 
To define the mouse region, select Mouse Region from the Digitizer menu.  
This will bring up the Define Mouse Region dialog box, where you can define 
your mouse region by clicking on the top left and bottom right corners of the 
mouse region on the digitizer. 

The mouse region will be displayed on the digitizer screen in the Mouse Region 
dialog box. If the size and positioning are correct, press the Accept button. 
Otherwise, you can redefine the region by clicking on the top left and bottom right 
corners again. 

Hint: You should somehow mark the mouse region on the digitizer by attaching a 
piece of paper or masking tape. Otherwise, you may not remember the location 
of the mouse region and have unpredictable behavior. 

Deactivating 
To deactivate the mouse region, select Mouse Region from the Digitizer menu 
again. This will remove the check mark from the menu item. 

Entering Rooms Using the Digitizer (Commercial Version) 
You can use the digitizer to enter rectangular rooms, polygonal rooms, curved 
rooms, windows, and transitions (doors). You can also use the digitizer to 
perform a zoom-box. 

 Before entering rooms using the digitizer you must set the correct scale. 
You can set a fixed scale if you know the actual blueprint scale factor. Otherwise, 
you must manually calibrate the digitizer. 

First, using the toolbar, select the mode for the type of entry that you want to 
perform. Use either the toolbar in FloorRight , or the toolbar template that can 
be attached to the digitizer. 

Next, using the digitizer puck click on each point that defines the object. Do not 
drag. Any operation that is normally a click and drag operation with the mouse 
will be click, release, then click again with the digitizer. For example, to define a 
rectangle, perform a two click operation, one click on each corner of the room. 

Tool Icon Function Description 

  Draw rectangular 
room / hole 

Select the upper left corner of the 
icon to draw rooms, the lower right 
corner for holes. To draw, click on 
one corner (for example top left), 
and then click on the opposite 
corner (for example bottom right). 
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Tool Icon Function Description 

  
Draw non-
rectangular room / 
hole  

Select the upper left corner of the 
icon to draw rooms, the lower right 
corner for holes.  To draw, click on 
each corner of the polygon.  Right 
click for curves. 

  Add a door or 
transition to a wall 

Click on one side of the door. Then 
click on the other sided to complete 
the door. Note: the door must be 
drawn on an existing wall. 

  Add a window to a 
wall 

Click on one side of the window. 
Then click on the opposite side to 
complete the window. Note: the 
window must be drawn on an 
existing wall. 

  Zoom Box Click on one corner (for example 
top left), and then click on the 
opposite corner (for example 
bottom right). 

Digitizer Entry Status 
FloorRight  will display the current entry status when entering rooms and when 
zooming to a box. You can cancel an operation by clicking on the Cancel button 
in the digitizer status window. 

 

Digitizing Curves (Commercial Version) 
Curves may be entered with the digitizer using the polygonal room or hole mode.   

• Left click on the starting point of the curve, right click near the middle of the 
arc, and right click over the end point to create the curve. 

• Continue right clicking to make additional curves.  Every two right clicks 
define a curve. 

Correlating FloorRight™ and Digitizer Points (Commercial Version) 
If you have an existing drawing in FloorRight  and want to add rooms using the 
digitizer, you should correlate an existing point in FloorRight  with a location on 

 213



the digitizer. 

NOTE: Make sure you have calibrated the digitizer scale first. 

• Select a single point from FloorRight drawing  

• Next, select Correlate FloorRight And Digitizer Points from the Digitizer 
menu. 

• Finally, using the digitizer, click on the point of a room on the blueprint that 
you want to correlate with the selected point in the FloorRight drawing. 

Zooming to the Digitizer (Commercial Version) 
Zooming changes the scale of the screen, without altering any of the work you 
have done. You can zoom the room view to fit the entire digitizer. 

You can call this feature in any of the following ways: 

• Zoom To Digitizer from the Digitizer menu 

• Click the Zoom to Digitizer button from the toolbar   

• Use the Digitizer Zoom button from the button template. 

Troubleshooting the Digitizer (Commercial Version) 

General 
If the digitizer doesn’t seem to be working, first check all the connections. 

• Check that the digitizer is connected to the computer. 

• Check the digitizer power connection. 

• Check the connection to the digitizer puck or pen. 

The digitizer should include a control panel applet. You should use this to check 
your digitizer settings, as well as test your digitizer. Most digitizers will behave 
like a mouse by default. If so, you can test that the entire digitizer works by 
moving the digitizer cursor all across the digitizer. 

You verify the digitizer Wintab drivers are loaded by selecting Digitizer Info from 
the Digitizer menu. This dialog box should display the digitizer driver 
manufacture and digitizer dimensions. If it does not, then the Wintab drivers are 
not installed correctly. Refer to your digitizer documentation or contact the 
digitizer vendor to learn how to install the Wintab drivers. 

To verify the digitizer is working correctly, select Zoom To Digitizer from the 
Digitizer menu. This will zoom the FloorRight  drawing to fit the entire digitizer. 
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Now move the puck or pen along the digitizer surface. You should see a 
horizontal and vertical line that corresponds to the puck location. 

Mouse Region 
When you define a mouse region on the digitizer, FloorRight  uses the 
digitizer’s default mouse behavior. If the digitizer does not function as a mouse 
outside FloorRight , it will not function as a mouse inside FloorRight . 

If you can enter rooms using the digitizer in FloorRight  but it does not seem to 
work correctly when defining a mouse region, close FloorRight  and try using 
the digitizer as a mouse when FloorRight  is not running. If the digitizer does not 
work correctly as a mouse device when FloorRight  is not running, check the 
mouse settings in the digitizer applet in the control panel, or refer to your 
digitizer’s documentation. 

Mouse region does not work at all 

First, verify that the digitizer is working correctly inside of FloorRight .  Check 
that the correct drivers are installed by opening the Digitizer Info dialog box. 
Next, try entering a room using the digitizer. 

If the digitizer works inside of FloorRight , but you cannot use a mouse region, 
exit FloorRight  and try using the digitizer to control the mouse. If the digitizer 
does not control the mouse outside of FloorRight  then you cannot use a 
digitizer mouse inside FloorRight . 

Please check the mouse settings for he digitizer applet in the control panel, or 
refer to your digitizer’s documentation 

The mouse region only works in a small section on the screen. 

Many digitizer drivers can be set so only a portion of the digitizer will function as 
a mouse. The digitizer can also be configured to control the mouse on only a 
portion of the screen, for example the top left corner. This is commonly referred 
to as a screen-digitizer mapping. 

If you can enter rooms using the digitizer in FloorRight , but the digitizer does 
not seem to work correctly as a mouse, you may have a screen-digitizer mapping 
set in your digitizer control panel. Please check the mouse settings for the 
digitizer applet in the control panel, or refer to your digitizer’s documentation 

The mouse moves in the wrong direction. 

FloorRight  uses the exact same mouse setting as the digitizer’s mouse driver. 
The mouse region in FloorRight  will work the same as the digitizer mouse 
driver when FloorRight  is not running. 

If you have turned the digitizer upside down then the mouse may appear to be 
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working backwards. Exit FloorRight  and try using the digitizer as a mouse. If 
you experience the same problem when FloorRight  is not running then your 
digitizer may be turned the wrong way. 

Button Template 
The button template can be rotated or flipped. When defining the digitizer button 
template you must define the top right corner first. Next you must define the top 
left corner. If you define these points in the wrong order, or use different points, 
the button template will not be defined correctly. 

Dialog Boxes 
Grouping Stock Pieces (Commercial Version) 

For large jobs, it may be necessary to keep stock cuts from the same room 
together.  The Group Stock dialog box gives you some options. 

  

Use these steps to invoke the dialog: 

1. If you’re not in the Seam / Stock view, click the  on the toolbar. 

2. Right click anywhere in the Stock view to display the Stock View context 
menu. 

3. Click the Stock Grouping selection to display the Group Stock dialog. 

The Group Stock dialog presents the following checkbox choices: 

• Group room pieces together  – When checked, pieces from the same 
room will be placed together on the stock roll.  When unchecked, the 
layout changes to the most efficient use of material. 

• Group page pieces together – When checked, for each material, pieces 
on the same page are grouped together on the stock roll.  When 
unchecked, the layout changes to the most efficient use of material.  This 
choice is grayed (unavailable) when Base Stock on Page is checked. 

Roll Lengths Dialog Box (Commercial Version) 
The Roll Lengths dialog lets you keep track of all rolls of material and their dye 
lots.   
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Each layable material type has a tab for roll length information.  Every material 
type has a default dye lot.  If dye lot support is not required, roll lengths can be 
created in this default.  Any FloorRight Commercial data file created before dye 
lots were featured will list all stock in the Default dye lot for each layable material. 

Roll lengths are defined by selecting Set Roll Lengths from the Layout menu.   

  

Each tab in the dialog is labeled with the material Style / Name. 

The material color and type appear in the window at the top of the dialog.  Next 
to the window the total length of all rolls and the approximate length of material 
required is listed. 

The dye lot table contains the following fields: 

• First column – numbers for rolls within a dye lot. 

• Second column – a "+" or "–" for expanding and contracting the roll list for a 
dye lot. 
o Clicking on "-" will hide the rolls in a dye lot. 
o Clicking on "+" will show the rolls in a dye lot. 

• Dye lot contains the dye lot name or identifier. 
o “Default” is always the first dye lot name and cannot be deleted. 
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o All rolls can be defined in this dye lot if dye lot support is not required. 
o To create a new dye lot enter its name in the empty cell at the bottom of 

the grid.  Note: Each dye lot name must be unique. 
o To change a Dye lot name select the name and edit it. 
o To delete a dye lot name select the row and press the Delete key.  You 

will get a warning prompt before the dye lot and any rolls it may contain 
are deleted.  Any rooms assigned to the deleted dye lot will be reset to the 
default dye lot. 

• The fourth and fifth column next to the dye lot name display the approximate 
length required based on the rooms assigned to that dye lot, and the length 
available based on the rolls entered for this dye lot.  These numbers are not 
displayed until the first time you have viewed the seam layout (click the Stock 
Toggle button ) after opening the file. 

• ID / Name is an optional field for a number or designation of a roll. 

• Length – enter the roll lengths for each roll in the dye lot.   
Roll ID and Length can be changed or deleted. 
You can change the order of a roll.  Select the roll row, then click and drag the 
left end of the row to the new location.  The layout uses the rolls in the order they 
are placed in this table.  Valid locations for moving are displayed with a red line; 
invalid locations are marked with a slashed circle.  Rolls can be moved to a 
different dye lot. 

The default gap for guillotine cuts is 3".  You can change this value in the 
Guillotine cut gap box near the bottom of the dialog. 

Click the Show Roll Allocation button at the bottom of the dialog box to see roll 
allocations in the stock view. 

In case of mistakes, use the Delete key to remove a selected roll from the list, or 
an entire dye lot, including its rolls.  When you select a dye lot and click Delete, 
you are prompted to make sure you want to remove the lot. 

To accept changes and new rolls you have entered click OK. 

To ignore all changes and additions made in the current session and go back to 
the previous allocation settings, press Cancel. 
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Technical Support 
Accessing the FloorRight™ Website 

Information on upgrades, distributors, and additional technical support is 
available through the FloorRight™ Website, www.FloorRight.com. 

Contacting Saltire Software 
You should first contact the distributor where you purchased FloorRight . 

You can contact Saltire Software at: 
Saltire Software Inc. 
P.O. Box 1565 
Beaverton, OR 97075 

What is a Saltire? 

 

The Saltire is the heraldic name of the Cross of St. Andrew.  Legend has it that 
St. Andrew was to be crucified, but he felt unworthy to be killed in the same way 
as Christ.  He asked to be put to death on an X-shaped cross instead. 

A flag featuring the Saltire has been used as the national emblem of Scotland 
since the Sixteenth Century. 

The name Saltire Software reflects the Scottish origins of the founders of the 
company. 
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What's New in FloorRight 
New Features 

The latest version of FloorRight™ Professional v6.0 and FloorRight™ 
Commercial v6.0 contain many new features. The toolbar sports some new 
items: the Measuring Tool , and New Document, Open, and Save buttons - 

  .  A configurable Legend lists all the materials in the document.  To 
make the drawing easier to read, you can now select the color for walls.  You can 
enter your own special prefix for room labels.  There are new controls for 
grouping stock pieces and adjusting seams.  The latest drawing shortcuts include 
room rotation and expansion.  The Job Estimate has some new cost bases, 
adjusted perimeter and step count.  To keep pace with the latest new hardware, 
there is a new Disto Import utility. 

The latest addition to the Commercial version also features Tabbed Pages. With 
this feature, you can divide a large job into discrete pieces, with the Stock Rolls, 
and Job Estimate broken down by page. 
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